INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Cannot run multisite website locally

Cannot run multisite website locally

(OP)
Good Afternoon

I've very new to WordPress but have been in IT for 30 years plus! (Not sure why I mentioned that!! smile)

I have a client who wants their site moved to a new hoster. I've found out how to do that and believe it should be pretty straightforward, however, I want to be able to view it all locally first. The current hosting company has provided me with WP and SQL backups of the site. The main issue I have is that there are multiple sites within and I cannot get WP to run. Below is a set of steps that I have followed, could someone please advise what I need to do as I think that nearly 3 days trying to resolve is detrimental to my hair?

Installed XAMMP
Started both Apache and MySQL
Imported the SQL script as per the backup supplied
Amended the siteurl and home data within WP_Options from 'sites.domain' to 'localhost/sites.domain'
Reset a password (MD5) to an existing user within WP_Users
Copied the WP data into c:\htdocs\domain from the supplied backup
Renamed the wp-config.php to wp-config-sample.php in order to retain the existing config parameters
Ran the WP install
Amended the database parameters within wp-config.php
Attempted to browse to localhost/domain, this tried to redirect to localhost/sites.domain which it says it is unable to find on the server. I also tried using 127.0.0.1/domain with the same result!

Any advise would be very gratefully received.

Many thanks in advance

Steve

RE: Cannot run multisite website locally

On Windows or a Linux box?

Chris.

Indifference will be the downfall of mankind, but who cares?
Time flies like an arrow, however, fruit flies like a banana.
Webmaster Forum

RE: Cannot run multisite website locally

(OP)
Hi Chris...Windows 7

RE: Cannot run multisite website locally

(OP)
Thanks Chris, I'll take a look...is this the same for XAMMP?

Steve

RE: Cannot run multisite website locally

(OP)
Hi Chris

I've followed this through and I still cannot get Wordpress to load!

When I type in my domain name, it now takes me to the WAMP server....if I had hair I would pull it out!!

Any further suggestions would be very much appreciated.

Best wishes

Steve

RE: Cannot run multisite website locally

(OP)
Hi Chris

Right, I've not got further but I'm back exactly at the point I was at with the XAMMP installation in that when I enter my test domain, it takes me back to the sites.domain page in the live environment!

I really haven't got a clue what I'm doing!

Cheers

Steve

RE: Cannot run multisite website locally

Wordpress relies on .htaccess rules to map names to

Have you renamed .htaccess and configured the new name in httpd.conf? Because windows doesn't play at all with filenames that start with a .

find this text in httpd.conf,

CODE -->

# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives. See also the AllowOverride
# directive.
#
AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files> 

Change .htaccess to htaccess.txt then rename .htaccess to htaccess.txt, and remove the \. from the Files directive

Chris.

Indifference will be the downfall of mankind, but who cares?
Time flies like an arrow, however, fruit flies like a banana.
Webmaster Forum

RE: Cannot run multisite website locally

By the way,

I've always found it simpler to have a local Centos box tucked away in a corner for 'local' testing.

Chris.

Indifference will be the downfall of mankind, but who cares?
Time flies like an arrow, however, fruit flies like a banana.
Webmaster Forum

RE: Cannot run multisite website locally

(OP)
Unfortunately I don't have the luxury of a Centos box Chris!

I'll try the suggested changes and advise...thanks again

RE: Cannot run multisite website locally

(OP)
Me again Chris!

The code you mention does not exist in the httpd.conf file! Should I add it, also, what is the expected path for the .HT files?

RE: Cannot run multisite website locally

.htaccess, and .htpasswd can be in any directory you need them in.

In the root they affect all files all subdirectories off the root, in a subdirectory they affect that directory and all subditectories off that.

A Centos box doesn't have to a 'luxury', a Linux development server only needs a P4HT, Pentium D or an Athlon equivalent spec CPU and 768MiB to 1GiB of RAM, just about any kit that Windows has 'grown out of' will do for light duty web server.

Chris.

Indifference will be the downfall of mankind, but who cares?
Time flies like an arrow, however, fruit flies like a banana.
Webmaster Forum

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close