INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Nexus 7000 - no switchport command does not work

Nexus 7000 - no switchport command does not work

(OP)
Hi,

I need to configure one port on Module 1 and met some issue

XXX(config-if)# no switchport
ERROR: Ethernet1/30: requested config change not allowed

Below modules which are in this Nexus :

XXX(config-if)# show module
Mod Ports Module-Type Model Status
--- ----- ----------------------------------- ------------------ ----------
1 32 1/10 Gbps Ethernet Module N7K-F132XP-15 ok
5 0 Supervisor module-1X N7K-SUP1 active *
10 48 10/100/1000 Mbps Ethernet XL Module N7K-M148GT-11L ok

Port is down (nothing connected), SFP is inserted.
When i tried to do the same operation on Module 10 (the same situation with port ) there was possible, here is not

Have not found anything on the google, have anyone this in your network ?

RE: Nexus 7000 - no switchport command does not work

F1 series are L2 only ...

if you need to route for some reasons, use an SVI ...


int e1/30
swi ac vlan 10



int vlan 10
ip address 10.10.10.1/24


there now.. you have routing..... you got an M1 series card.. you should be able to route. :D

We must go always forward, not backward
always up, not down and always twirling twirling towards infinity.

RE: Nexus 7000 - no switchport command does not work

(OP)
imbadatthis - thanks, it works pretty well :)

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close