INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Migration from Layer 2 1238P to Layer 3 1638P (no layer 3 necessary)

Migration from Layer 2 1238P to Layer 3 1638P (no layer 3 necessary)

Migration from Layer 2 1238P to Layer 3 1638P (no layer 3 necessary)

(OP)
Okay, so customer is a car dealership. I am coming in to help the tech who was already assigned to the project. Unfortunately, my Layer 3 is a little rusty. Enough of that though, here's the beef.

This is a three POE switch environment (2x 1638p, 1 Layer 2 24 port switch (sorry forgot the model))
Mitel 5000 with nearly all IP sets
Cisco router handling IP addressing on the data VLAN

Customer bought the switches new from a vendor on the west coast and agreed to pay us time and material to install and configure (lucky us or so I thought.) They are upgrading because some customer management software company they are going with requires "a gig network." Lol, if I had a dollar.

I may be leaving out some pertinent info. If I am, forgive me, it's been a long one.

Here's the old switch config that worked:

hostname "(redacted) Auto 1"
enable password (redacted)
!
ip default-gateway 192.168.200.1
ip name-server 10.0.0.200 166.102.165.13
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "(redacted)" password "(redacted)"
!
banner motd #
****** Important ******

Enable and Telnet passwords are configured to "password".
Please change them immediately.

The vlan 1 interface is enabled with an address of 10.10.10.1
Telnet access is also enabled.

#
!
no dot11ap access-point-control
!
ip dhcp-server excluded-address 192.168.200.1 192.168.200.20
ip dhcp-server excluded-address 10.0.0.1 10.0.0.179
ip dhcp-server excluded-address 10.0.0.200 10.0.0.254
ip dhcp-server excluded-address 192.168.200.201 192.168.200.254
!
ip dhcp-server pool "Voice"
network 192.168.200.0 255.255.255.0
default-router 192.168.200.1
option 43 ascii id:ipphone.mitel.com;sw_tftp=192.168.200.201;call_srv=192.168.
200.201;vlan=6;l2p=6;dscp=46
qos queue-type wrr 25 25 25 expedite
!
qos dscp-cos 0 8 16 24 32 40 46 56 to 0 1 2 3 4 5 6 7
!
vlan 1
name "Default"
!
vlan 6
name "Voice"
!
interface switchport 0/1
no shutdown
switchport mode trunk
!
interface switchport 0/2
no shutdown
switchport mode trunk
!
interface switchport 0/3
no shutdown
switchport mode trunk
!
interface switchport 0/4
no shutdown
switchport mode trunk
!
interface switchport 0/5
no shutdown
switchport mode trunk
!
interface switchport 0/6
no shutdown
switchport mode trunk
!
interface switchport 0/7
no shutdown
switchport mode trunk
!
interface switchport 0/8
no shutdown
switchport mode trunk
!
interface switchport 0/9
no shutdown
switchport mode trunk
!
interface switchport 0/10
no shutdown
switchport mode trunk
!
interface switchport 0/11
no shutdown
switchport mode trunk
!
interface switchport 0/12
no shutdown
switchport mode trunk
!
interface switchport 0/13
no shutdown
switchport mode trunk
!
interface switchport 0/14
no shutdown
switchport mode trunk
!
interface switchport 0/15
no shutdown
switchport mode trunk
!
interface switchport 0/16
no shutdown
switchport mode trunk
!
interface switchport 0/17
no shutdown
switchport mode trunk
!
interface switchport 0/18
no shutdown
switchport mode trunk
!
interface switchport 0/19
no shutdown
switchport mode trunk
!
interface switchport 0/20
no shutdown
switchport mode trunk
!
interface switchport 0/21
no shutdown
switchport mode trunk
!
interface switchport 0/22
no shutdown
switchport mode trunk
!
interface switchport 0/23
no shutdown
switchport mode trunk
!
interface switchport 0/24
no shutdown
switchport mode trunk
!
interface switchport 0/25
no shutdown
switchport mode trunk
!
interface switchport 0/26
no shutdown
switchport mode trunk
!
interface switchport 0/27
no shutdown
switchport mode trunk
!
interface switchport 0/28
no shutdown
switchport mode trunk
!
interface switchport 0/29
no shutdown
switchport mode trunk
!
interface switchport 0/30
no shutdown
switchport mode trunk
!
interface switchport 0/31
no shutdown
switchport mode trunk
!
interface switchport 0/32
no shutdown
switchport mode trunk
!
interface switchport 0/33
no shutdown
switchport mode trunk
!
interface switchport 0/34
no shutdown
switchport mode trunk
!
interface switchport 0/35
no shutdown
switchport mode trunk
!
interface switchport 0/36
no shutdown
switchport mode trunk
!
interface switchport 0/37
no shutdown
switchport mode trunk
!
interface switchport 0/38
no shutdown
switchport mode trunk
!
interface switchport 0/39
no shutdown
switchport mode trunk
!
interface switchport 0/40
no shutdown
switchport mode trunk
!
interface switchport 0/41
no shutdown
switchport mode trunk
!
interface switchport 0/42
no shutdown
switchport mode trunk
!
interface switchport 0/43
no shutdown
switchport mode trunk
!
interface switchport 0/44
no shutdown
switchport mode trunk
!
interface switchport 0/45
no shutdown
switchport access vlan 6
!
interface switchport 0/46
no shutdown
switchport access vlan 6
!
interface switchport 0/47
no shutdown
switchport access vlan 6
!
interface switchport 0/48
no shutdown
switchport access vlan 6
!
!
interface gigabit-switchport 0/1
no shutdown
!
interface gigabit-switchport 0/2
no shutdown
switchport mode trunk
!
interface gigabit-switchport 0/3
speed 100
no shutdown
switchport mode trunk
!
interface gigabit-switchport 0/4
no shutdown
switchport mode trunk
!
!
interface vlan 1
ip address 10.0.0.254 255.255.255.0
ip mtu 1500
shutdown
!
interface vlan 6
ip address 192.168.200.254 255.255.255.0
no shutdown
!
!
!
no ip tftp server
no ip tftp server overwrite
ip http server
ip http secure-server
no ip snmp agent
no ip ftp server
ip ftp server default-filesystem flash
no ip scp server
no ip sntp server
!
line con 0
login local-userlist
!
line telnet 0 4
login local-userlist
password password
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
end



AND HERE'S MY UPDATED AND SOMEWHAT CLEANED UP SCRIPT FOR THE 1638P


hostname "(redacted) Switch 1"
enable password Windstream1
!
ip default-gateway 192.168.200.1
ip name-server 10.0.0.200 166.102.165.13
!
clock timezone -5-Eastern-Time
clock no-auto-correct-DST
!
ip subnet-zero
ip classless
no ip routing
!
!
no ip route-cache express
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "mike" password "mike"
!
banner motd <
##########################################################
## ##
## All sessions to this device are being monitored. ##
## If unauthorized access is detected, your address ##
## will be logged and all appropriate actions ##
## including disciplinary and legal actions will ##
## be pursued. ##
## ##
##########################################################
<
!
no dot11ap access-point-control
!
ip dhcp-server excluded-address 192.168.200.1 192.168.200.20
ip dhcp-server excluded-address 10.0.0.1 10.0.0.179
ip dhcp-server excluded-address 10.0.0.200 10.0.0.254
ip dhcp-server excluded-address 192.168.200.201 192.168.200.254
!
ip dhcp-server pool "Voice"
network 192.168.200.0 255.255.255.0
default-router 192.168.200.1
option 43 ascii id:ipphone.mitel.com;sw_tftp=192.168.200.201;call_srv=192.168.200.201;vlan=6;l2p=6;dscp=46
qos queue-type wrr 25 25 25 expedite
!
qos dscp-cos 0 8 16 24 32 40 46 56 to 0 1 2 3 4 5 6 7

no dos-protection

no desktop-auditing dhcp

no network-forensics ip dhcp
!
spanning-tree priority 32000
!
vlan 1
name "Default"
!
vlan 6
name "Voice"
!
interface gigabit-switchport 0/1
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/2
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/3
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/4
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/5
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/6
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/7
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/8
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/9
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/10
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/11
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/12
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/13
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/14
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/15
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/16
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/17
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/18
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/19
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/20
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/21
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/22
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/23
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/24
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/25
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/26
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/27
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/28
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/30
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/31
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/32
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/33
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/34
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/35
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/36
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/37
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/38
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/39
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/40
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/41
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/42
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/43
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/44
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport access vlan 1
switchport voice vlan 6
switchport voice-signaling vlan 6
!
interface gigabit-switchport 0/45
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport mode trunk
switchport trunk allowed vlan 1,6
!
interface gigabit-switchport 0/46
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport mode trunk
switchport trunk allowed vlan 1,6
!
interface gigabit-switchport 0/47
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport mode trunk
switchport trunk allowed vlan 1,6
!
interface gigabit-switchport 0/48
description =>(redacted)/PHONE/PC
spanning-tree edgeport
no shutdown
switchport mode trunk
switchport trunk allowed vlan 1,6
!
interface vlan 6
description Voice
ip address 192.168.200.254 255.255.255.0
no ip route-cache express
no shutdown
!
interface vlan 1
description Default
ip address 10.0.0.254 255.255.255.0
no ip route-cache express
no shutdown
!
no tftp server
no tftp server overwrite
http server
http secure-server
no snmp agent
no ip ftp server
ip ftp server default-filesystem flash
no ip scp server
no ip sntp server
!
line con 0
login local-userlist
!
line telnet 0 4
login local-userlist
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
end


The PBX hates it. The phones will grab their IP, but the TFTP server is assigned 192.168.0.0 and then they just hang there. It looks like said phone makes it all the way through the bootup process but stops right before it advances to the UI.

I am missing something, but I'll be damned if I can figure it out. I mean the whole dadgum thing goes haywire. I only had 2 hours tonight to troubleshoot it (7-9) but I'm at a loss and could really use some help.

Thanks in advance for any help!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close