INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Kodakpulse.com - "Missing required Permissions manifest attribute"

Kodakpulse.com - "Missing required Permissions manifest attribute"

Kodakpulse.com - "Missing required Permissions manifest attribute"

(OP)
Firstly I hope I'm posting the correct place, and secondly, I'm probably looking for confirmation that the solution is not in my hands.

Kodakpulse.com is a website which allows users to wirelessly manage a Kodak Pulse digital picture frame.

The website has worked as expected for several years, but it now appears that the latest Java Update (V7 U51) is causing real problems.
Here's the error message.



It seems to me the error is Kodak's - there's something adrift in the file jumploader_z88.jar. It gets downloaded and fails a security check of some sort.

I have contacted Kodak but not really got anywhere. This page from Nov 2013 seems to be the best response: Java: "It's A Problem and We're Working On It" but it doesn't offer a solution.

I've tried removing V7 U51 and installing an older version of Java, but then I can't bypass the update notification when Java fires up.

While this is not critical from my point of view, it; very frustrating having to transfer files via SD Card or email to the frame instead of a few online clicks.

Many thanks.

Iechyd da! John
Glannau Mersi, Lloegr.

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

Take a look at this

Cheers,
Dian

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

(OP)
Thanks, Dian.

It's good to know the reasons why it's happening, and how to get around it.

Hopefully Kodak will wake up and correct things from there end.

Iechyd da! John
Glannau Mersi, Lloegr.

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

@BionicJohn and @Diancecht,
Thank you for the tips, it helped me solve the problem.
I also own a couple of those Kodakpulse photoframes and ran into the same problem. Kodak does not give any support on these products anymore I experienced in earlier contact about another problem.
Usually I only use portable browsers Firefox, Iron and Chrome. They update automatically through the 'start platform' from portableapps and have their own Java extensions/plugins.
I read the workaround, but that is of no use since I didn't had Java installed on my Windows 8 pro tabled/laptop.

Just for the uplaod of pictures to my Kodak frames I opened the kodakpulse website in IE10 and installed the Java console when it asked me. After installation of the Java console(the latest I suppose), the java plugin of the kodakpulse website loaded right away without any warnings or blocking. (I didn't add any url as explained in the workaround)

Florisz

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

I had the same situation with KodakPulse yesterday with Java permissions, so I went to the Java console and added the site and applet URL to the Java exceptions list as Dian suggested, ir worked for a few hours, but now the certificate has been revoked and there is no way KodakPulse application can work. Kodak has discontinued the support to this product and offered no solution. Any other ideas?

Best Regards,

Rodolfo

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

What error is shown now?

Cheers,
Dian

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

Thanks Dian,

The first error screen says:
Certificate has been revoked.
The application will not be executed.
Name: EkcPulseUplooader
Location: http://www.kodakpulse.com

Then it shows another message with:
Do you want to Continue?
The web site's certificate has been verified
Website: https://javadl-esd-secure.oracle.com:443
Note: The certificate is valid and has been used to verify the identity of this website

Then another with:
The following plug-in is unresponsive:Java(TM) Platform SE 7
U51
Would you like to stop it?
Y N

Any help is appreciated,

Best Regards,

Rodolfo

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

Hi !
I live in Paris, France (sorry for my english) and I just bought a Kodak Pulse digital frame (W730), and I have the exact same problems with the kodakpulse.com website and the java. I tried with different browsers, Internet Explorer, Mozilla Firefox, Google Chrome, but none of them worked. I also went to the java console and added the URLS to the java exception list but it still didn't work... I always get the same java errors messages when I try to upload pictures on the kodak website.
If anyone has a solution, I really would be grateful !
Many thanks.
Best regards.
Herve.

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

I'd start thinking in not using this Kodak thingie anymore. I don't know if there's a word in English, but in Spanish I'd call this a "chapuza". Code not signed, bad certificates, that is completely unnaceptable for a serious application,

But If you still wnat to go with it, I'd try this

Cheers,
Dian

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

Thanks Dian, you made my day ! (But you are right, this Kodak frame is a real Chapuza, even if I don't understand spanish, I am sure I know what you mean...)
I finally managed to add pictures to the kodakpulse website (for this I just changed "all certificates in chain of trust" to "do not check")
I know it's not recommended but is this really risky to uncheck this box everytime I need to upload pictures ?
Why is this "dangerous" ? What kind of problems can I get if I just uncheck it for uploading pictures ?
Many thanks.
Best regards.
Herve

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

Dian, Herven,

I have tried to setup Java advance setting to "do not check certificate" before, and again a few minutes ago enticed by Herven, but both times error messages of SE7U51 continue to appear even when I respond as "yes" to warning messages asking the user to take responsibility.

As Dian said, "chapuza" is a way to describe it but it is not due to poorly written code/application but rather for not anticipating that discontinuing maintenance/upgrades on the application for business problems all over Kodak (and Kodak is still open) should not disenfranchise users that continue using the last version of the app due to not even maintaining the apps interface with other key components that are still being upgraded, such as Java.

An idea that I am not sure if would work is that Java may have allowed users to still been able to download previous versions of the code to help on problems like this, to at least let old apps to still perform for just a moment under users responsibility, and upon finishing the job to do then the user should upgrade Java to the current version.

I would call them "irresponsables" for not even caring for the people that already paid for the frame and specific product functionality, similar to selling a product that does not work as advertised since day one.

I assume XP will go thru similar nightmares now that has been also discontinued.

Thanks for reading the rant and for helping.

Best Regards,

Rodolfo

RE: Kodakpulse.com - "Missing required Permissions manifest attribute"

Herve: a certificate proves that a website is legit. When you don't check it, the risk is that the web you're using may be another one faking the legit one. In this case the risk may not be high, but think on any online shopping cart where you enter you card details.

Cheers,
Dian

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close