INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Forwarding calls from Cisco to Fujitsu not working

Forwarding calls from Cisco to Fujitsu not working

(OP)
Problem Description
When call is extended to Fujitsu Voice mail system it drops, calling party gets a busy signal. The Fujitsu and CIsco are setup with QSIG. We can make calls to and from the 2 systems. The only problem is when the Cisco ext is busy/no answer it is suppose to go to voicemail that resides on Fujitsu.

Example:
Cisco ext 8150 is forwarded on busy/ no answer to ext 3457. Ext 3457 resides in Fujitsu. When the call goes to ext 3457 you get a busy signal. You can call ext 3457 from Cisco and you will get the voicemail.

Below is a trace from Cisco.

Troubleshooting Performed

Call Flow :

Fujitsu phone>>>Pri>>>MGCP gateway>>CUCM >> IP phone>> (CFNA)>>CUCM>> MGCP gateway>>Pri>> Fujitsu VM system.


++ Tried not sending the Redirecting Party but that did not work.

++Collected traces and debugs and for a failed call.


In debugs we see when we send a q931 setup to Fujitsu , it sends a release complete.


++ Below is the detailed debugs:

Incoming Set-up received from the Fujitsu

1041485: *Dec 18 21:12:02.128: ISDN Se0/0/0:23 Q931: RX <- SETUP pd = 8 callref = 0x0141
Bearer Capability i = 0x8090A2
Standard = CCITT
Transfer Capability = Speech
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xA98381
Exclusive, Channel 1
Progress Ind i = 0x8183 - Origination address is non-ISDN
Calling Party Number i = 0x4980, '5787'
Plan:Private, Type:Subscriber(local)
Calling Party SubAddr i = 0x80, 'P5787'
Called Party Number i = 0xA1, '8150'
Plan:ISDN, Type:National

Sending Proceeding to Fujitsu

1041488: *Dec 18 21:12:02.136: ISDN Se0/0/0:23 Q931: TX -> CALL_PROC pd = 8 callref = 0x8141
Channel ID i = 0xA98381
Exclusive, Channel 1


Sending Alerting to Fujitsu

1041489: *Dec 18 21:12:02.164: ISDN Se0/0/0:23 Q931: TX -> ALERTING pd = 8 callref = 0x8141
Facility i = 0x9FAA06800100820100A114020101020101800C4272656E7420537079726B61
Progress Ind i = 0x8088 - In-band info or appropriate now available


Here after Call is forwarded , we send a set-up to the Fujitsu

1041494: *Dec 18 21:12:12.196: ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8 callref = 0x0003
Sending Complete
Bearer Capability i = 0x8090A2
Standard = CCITT
Transfer Capability = Speech
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xA98382
Exclusive, Channel 2
Facility i = 0x9FAA068001008201008B0100A12B02010102011530230201010A0103800103A108A006800438313530A30E800C4272656E7420537079726B61
Facility i = 0x9FAA06800100820100A1080201000201008400
Calling Party Number i = 0x4983, '5787'
Plan:Private, Type:Subscriber(local)
Called Party Number i = 0xC1, '3457'
Plan:ISDN, Type:Subscriber(local)
Redirecting Number i = 0x000082, '8150'
Plan:Unknown, Type:Unknown


we received a Release complete from Fujitsu

1041495: *Dec 18 21:12:12.456: ISDN Se0/0/0:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x8003

So we have to check with Fujitsu why are they sending the release complete.

RE: Forwarding calls from Cisco to Fujitsu not working

Can you dial the voice mail pilot number directly from Cisco and get anything different than the busy tones? I've run into several issues going from a non-Cisco phone system to Unity Voicemail, but this does sound familiar.

And maybe I missed it but from the example you gave above, where does the extension 5787 come from?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close