INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

NAT on Router running BGP

NAT on Router running BGP

(OP)
I am trying to get NAT working on a router that is running bgp. We are trying to nat against our publicly announced space vs one of the peers/providers ip address. I've tried using a loopback interface and a sub-interface, neither worked. This is on a 7206VXR with an NPE-G1.

RE: NAT on Router running BGP

sh run

We must go always forward, not backward
always up, not down and always twirling twirling towards infinity.

RE: NAT on Router running BGP

(OP)
Sorry. Relevant config below. BGP Peers are on GI0/1 and GI0/3. I am trying to bring the inter-vlan routing on to a couple c3560's and get rid of an old sonicwall.

interface Loopback3
ip address 162.210.240.x 255.255.255.248
ip nat outside
ip virtual-reassembly in

interface GigabitEthernet0/2.66
encapsulation dot1Q 66
ip address 10.1.11.1 255.255.255.0
ip nat inside
ip virtual-reassembly in

ip nat inside source list 50 interface Loopback3 overload
access-list 50 permit 10.1.11.0 0.0.0.255

RE: NAT on Router running BGP

how are you advertising the route through BGP ?
you dont need to have an interface to nat .. if you own the segment, pick an ip address and instead of the interface command actually use the IP address ..
your router should respond with arps when queried of "who has xxxx"

We must go always forward, not backward
always up, not down and always twirling twirling towards infinity.

RE: NAT on Router running BGP

(OP)
That works. I just used NAT pool.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close