INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

home lab:trying to get isp to assign IP addresses

home lab:trying to get isp to assign IP addresses

(OP)
ok,I have set up one sub-interface 0/0.1 on a router for ip address DHCP, I can ping my routers other sub-interfaces 0/0.2,0/0.3 when I connect my pc to a switchport,and as a test i connected the ISP directly to the routers fa0/1(second port)and was able to get a IP assigned to it,but when I connect the ISP to switchport fa0/1 it wont assign a isp to the sub-interface 0/0.1.Any help out there


interface FastEthernet0/1
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 2
switchport mode access
spanning-tree portfast

!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
description OUTSIDE VLAN
ip address 192.168.1.99 255.255.255.0
!
interface Vlan2
description VOICE VLAN
no ip address
!
interface Vlan3
description DATA VLAN

interface FastEthernet0/0.1
description OUTSIDE INTERFACE
encapsulation dot1Q 1 native
ip address dhcp
ip nat outside
ip virtual-reassembly
!
interface FastEthernet0/0.2
description VOICE LAN INTERFACE
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.3
description DATA LAN INTERFACE
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.128
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.30
description WIRELESS
encapsulation dot1Q 30
ip address 192.168.3.129 255.255.255.128
ip nat inside
ip virtual-reassembly
no ip address













RE: home lab:trying to get isp to assign IP addresses

is this on the same device?
or you forgot to break apart the configuration of your switch and your router?


interface FastEthernet0/0.1
description OUTSIDE INTERFACE
encapsulation dot1Q 1 native
ip address dhcp
ip nat outside
ip virtual-reassembly

interface Vlan1
description OUTSIDE VLAN
ip address 192.168.1.99 255.255.255.0

We must go always forward, not backward
always up, not down and always twirling twirling towards infinity.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close