INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

PortChannel Cisco 3750x-HP Procurve

PortChannel Cisco 3750x-HP Procurve

(OP)
Im having a small problem. Im trying to port channel a 3750X to a Procurve 5406zl
It works if I just connect it regular, with 1GB port. But we need a port channel.
Where am I going wrong in this setup?

Here is my setup:

HP Procurve 5406zl

module 1 type J8702A
module 2 type J8702A
trunk A24,B24 Trk1 LACP
no timesync
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
tagged A1-A23,B1-B23,Trk1
no ip address
exit
spanning-tree Trk1 priority 4

Cisco 3750x

interface GigabitEthernet1/0/47
description 1st-floor-sw-port-A24
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
channel-group 30 mode on

interface GigabitEthernet2/0/47
description 1st-floor-sw-port-B24
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
channel-group 30 mode on


interface Port-channel30
description 1st-fl-sw-porta24-b24
switchport trunk encapsulation dot1q
switchport trunk native vlan 499
switchport mode trunk
spanning-tree portfast trunk

RE: PortChannel Cisco 3750x-HP Procurve

A few things:
1. Portfast option is questionable.
2. You force LACP on on the HP and do "mode on" on the Cisco. Remove LACP and force the the port channel on the HP.
3. The untagged VLAN numbers have to match. I see you have 499 and 1. Your 802.1q encapsulation won't work either.

RE: PortChannel Cisco 3750x-HP Procurve

(OP)
How do I force the port channel on the HP? Ive been lookin thru their website and I found nothing...
Im working on changing the rest of the setup

RE: PortChannel Cisco 3750x-HP Procurve

Not sure, I do not work on HP so i am not familiar with the exact syntax. Try getting rid of "LACP"?

RE: PortChannel Cisco 3750x-HP Procurve

(OP)
I did. I tried to get rid of the LACP and didnt work..

RE: PortChannel Cisco 3750x-HP Procurve

How about, under g1/0/47 and g2/0/47 add:
channel-protocol lacp

RE: PortChannel Cisco 3750x-HP Procurve

Sorry, I missed one obvious thing.
under g1/0/47 and g2/0/47 also add:
switchport mode trunk

RE: PortChannel Cisco 3750x-HP Procurve

(OP)
Ouch. I missed that one too. I will try that one tonight after production hours and see if that works.
THANK YOU VERY MUCH...

RE: PortChannel Cisco 3750x-HP Procurve

(OP)
Hmmm i just tried to add the channel-protocol lacp
I cannot do channel-protocol lacp is channel-group 30 is on.

Would that still work? I did it on one of the interfaces, trying to get it ready for tonight. I didnt actually did the connection, as its a production interface. Currently running on 1 port only...

RE: PortChannel Cisco 3750x-HP Procurve

"Channel-group mode on" is wrong - this is a Cisco-proprietary link aggregation.

You need "channel-group mode active".

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close