INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

(OP)
Can't figure this out we know its the switch because we plug the phones straight into the router and they work no problem. Basically about half of the phones come up in the right vlan the other half don't.

Tried everything we can think of including lldp.

Anyone run into this?

ddcommllc.com
Avaya/Toshiba/SyntelSolutions

ACIS

"Will work for stars"

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

If I had to guess the switch ports are not configured properly on the non working ports?

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

(OP)
We went over the configs and all ports are configured the same. It seems completely sporadic

ddcommllc.com
Avaya/Toshiba/SyntelSolutions

ACIS

"Will work for stars"

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

What happens to the ones that don't? What stage are they stuck on?
Do you have enough ip addresses in your dhcp scope?
Keep in mind I don't know a thing about Astra phones

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

(OP)
Phones are easy and there are plenty of ip addresses available , the router is adsigning dhcp and when I plug phones directly into the router they come up no problem.

The ones that have problems get an IP address in the data vlan,
There is another device assigning dhcp for the data vlan only. I have never seem phones that are tagged for one vlan grab an ip from another. IMO there is a problem with the routing in the switch

ddcommllc.com
Avaya/Toshiba/SyntelSolutions

ACIS

"Will work for stars"

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

How are the phones discovering the Voice VLAN? Some Aastra IP phones support LLDP, some don't (the Ericsson ones). All generally support DHCP vendor options but this requires the 'double DHCP' boot. The voice VLAN tag could also be coming from a configuration file downloaded by the phone on booting.

I suggest you get a sniffer on (wireshark?) and mirror a port whilst a phone attempts to boot. Make sure your PC is configured to display the 802.1q tags (most Windows NIC drivers strip the 802.1q tags off and need registry tweak).

Andy

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

(OP)
The phones are hardcoded to the voice vlan, and we tried lldp

The it vendor ran a wireshark trace but couldn't find the voice traffic

ddcommllc.com
Avaya/Toshiba/SyntelSolutions

ACIS

"Will work for stars"

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

I'd say your VLANs are bridged and you have two DHCP servers serving out two different ranges on what is effectively a single broadcast segment.

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

(OP)
Any ideas what they may have done wrong ?

ddcommllc.com
Avaya/Toshiba/SyntelSolutions

ACIS

"Will work for stars"

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

(OP)
They tried these two configs:


interface GigabitEthernet1/9
switchport access vlan 100
switchport mode access
switchport voice vlan 10
spanning-tree portfast

interface GigabitEthernet6/4
switchport trunk native vlan 100
switchport trunk allowed vlan 10,100
switchport mode trunk
spanning-tree portfast

ddcommllc.com
Avaya/Toshiba/SyntelSolutions

ACIS

"Will work for stars"

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

For a phone that supports CDP, the first one is the right one.

For phones that don't support CDP, you could use either, both work the same.

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

(OP)
Neither have worked at this point ,it's about 50/50

ddcommllc.com
Avaya/Toshiba/SyntelSolutions

ACIS

"Will work for stars"

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

(OP)
So just to keep you guys posted cisco is reviewing a wireshark trace right now... They are stumped it appears as well

ddcommllc.com
Avaya/Toshiba/SyntelSolutions

ACIS

"Will work for stars"

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

What's the config of the DHCP server's switchport?

RE: Aastra phones with separate vlan getting ip from the data vlan catalyst 4507

(OP)
It's not the dhcp server we eliminated that by setting up another switch in our lab

ddcommllc.com
Avaya/Toshiba/SyntelSolutions

ACIS

"Will work for stars"

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close