INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Swf files won't play on http server, but works fine on Sunone web server

Swf files won't play on http server, but works fine on Sunone web server

Swf files won't play on http server, but works fine on Sunone web server

(OP)
We currently migrating over from SunOne to HTTP Server. Flash files work fine on SunOne but not on the HTTP Server.

When you go to run launch.html another window opens but the swf doesnt start playing.
Both .flv (video/x-flv) and .swf application/x-shockwave-flash are in the mime.types

Launch.html file
#####################################################
Include /opt/IBM/WebSphere/HTTPServer/conf/httpd.conf
#####################################################
#
#Listen IP address and Port Number

Listen xxxxxxx
#
###################################################

### Section 2: 'Main' server configuration
#
######### DocumentRoot ############################
#
DocumentRoot "/www/edc/docs"

<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>


<Directory "/www/edc/docs">

Options FollowSymLinks
#
</Directory>
#
######### DirectoryIndex ############################################
#
directoryIndex index.html index.htm
IndexOptions FancyIndexing VersionSort
#
######### Mime Types ################################################
#
TypesConfig conf/mime.types
DefaultType text/plain

<IfModule mod_mime_magic.c>
MIMEMagicFile conf/magic
</IfModule>
#
#
########## Pidfile location,Error and Access Logs #####################
#
PidFile /opt/IBM/WebSphere/HTTPServer/logs/edc/httpd.pid
ErrorLog "|/opt/IBM/WebSphere/HTTPServer/bin/rotatelogs /opt/IBM/WebSphere/HTTPServer/logs/edc/error_%Y-%m-%d-%H:%M 86400 -360"
CustomLog /opt/IBM/WebSphere/HTTPServer/logs/edc/access_log common
CustomLog "|/opt/IBM/WebSphere/HTTPServer/bin/rotatelogs /opt/IBM/WebSphere/HTTPServer/logs/edc/access_%Y-%m-%d-%H:%M 86400 -360" common

LogLevel warn

# The following directives define some format nicknames for use with a CustomLog directive
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
#

Alias /icons/ "/opt/IBM/WebSphere/HTTPServer/icons/"

<Directory "/opt/IBM/WebSphere/HTTPServer/icons">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

####################################################################################

RE: Swf files won't play on http server, but works fine on Sunone web server

(OP)
The page works fine in firefox but not ie8.

RE: Swf files won't play on http server, but works fine on Sunone web server

(OP)
This actually doesn't work at all. Can anyone help me?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close