Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

goombawaho (MIS) (OP)
3 Jun 13 12:28
Trying to backup a Western Digital network hard drive. The path is something like \\10.1.10.10\fpc-shared and it has the S: drive mapped to that. The destination I: is a 2.5" USB hard drive.

Robocopy is giving me the follow errors depending upon whether I try to choose the source as \\fpc-shared\ or S:\
I have NOT tried the IP address as a way of addressing the source. Here are the two different errors I get. The errors equate to "The specified path is invalid." and "The system cannot find the path specified." Not understanding what's going on. The same batch file used to work on XP. Yes, I am right-clicking and "run as administrator" on batch file.


Using \\fpc-shared as source
===========================================================================
Started : Mon Jun 03 11:17:31 2013

2013/06/03 11:17:31 ERROR 161 (0x000000A1) Getting File System Type of Source \\FPC-SHARED\
The specified path is invalid.
Source - \\FPC-SHARED\
Dest : I:\
Files : *.*
Options : *.* /FFT /L /TEE /S /E /COPY:DAT /PURGE /MIR /ZB /R:2 /W:5
------------------------------------------------------------------------------
2013/06/03 11:17:31 ERROR 161 (0x000000A1) Accessing Source Directory \\FPC-SHARED\
The specified path is invalid.Waiting 5 seconds... Retrying...
2013/06/03 11:17:36 ERROR 161 (0x000000A1) Accessing Source Directory \\FPC-SHARED\
The specified path is invalid.Waiting 5 seconds...
================================================================================


Using S:\ as source
===============================================================================
ROBOCOPY :: Robust File Copy for Windows
-------------------------------------------------------------------------------

Started : Mon Jun 03 11:21:39 2013

2013/06/03 11:21:39 ERROR 3 (0x00000003) Getting File System Type of Source S:\
The system cannot find the path specified.


Source - S:\
Dest : I:\
Files : *.*
Options : *.* /FFT /L /TEE /S /E /COPY:DAT /PURGE /MIR /ZB /R:2 /W:5
------------------------------------------------------------------------------
2013/06/03 11:21:39 ERROR 3 (0x00000003) Accessing Source Directory S:\
The system cannot find the path specified.
strongm (MIS)
3 Jun 13 14:35
Are your folder names in the batch file by any chance surrounded by quotes?
guitarzan (Programmer)
3 Jun 13 17:19
>I have NOT tried the IP address as a way of addressing the source

The source should be \\computername\sharename or \\ipaddress\sharename
You can't just use \\sharename\

As for why a working mapped drive doesn't work as the source, check permissions on the share. Instead of Run As Administrator, you may need to Run As another user account
goombawaho (MIS) (OP)
4 Jun 13 10:39

Quote:

Are your folder names in the batch file by any chance surrounded by quotes?
I didn't mention it, but I tried SOURCE in quotes and no difference.

Quote:

The source should be \\computername\sharename or \\ipaddress\sharename You can't just use \\sharename\
Well, I can't use \\computername because it's not a computer - it's an external/networked hard drive.
I will try to use \\ipaddress\sharename.

Not understanding why Windows mapped drive (S:) doesn't work though.

Quote:

check permissions on the share. Instead of Run As Administrator, you may need to Run As another user account
You mean like an administrative user in the hard drive web interface/administrative console perhaps?
strongm (MIS)
4 Jun 13 11:07
>but I tried SOURCE in quotes

Actually, my point was going to be that if it is in quotes, then a trailing backslash gets misinterpreted, and can lead to the sort of error you are seeing.
Helpful Member!  guitarzan (Programmer)
4 Jun 13 11:41
Yea, try \\10.1.10.10\fpc-shared, maybe you get lucky.

For the S: drive map, maybe open a command prompt and confirm you can browse to the S drive, and if so, try the batch file from that command prompt. I don't see why RoboCopy would report "cannot find the path specified" in that case.

Assuming it's a network-attached storage with a web interface, you could use the IP as I indicated.

As for not being able to use \\computername because it's not a computer... It should also have a NETBios name you could use. And, there could be share permissions getting in the way. As an example, some NAS devices can integrate directly with Active Directory.
goombawaho (MIS) (OP)
4 Jun 13 12:27
Okay - good suggestions. Thanks. No active directory here, just individual PCs and the NAS HDD.
goombawaho (MIS) (OP)
29 Jun 13 10:55
So, yes this suggestion worked (use IP address of NAS) \\10.1.10.10\public\fpc-shared But the key was using the IP address. Don't know why I didn't think of it. Thanks.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close