INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

ipoffice phone issue with cisco 2960 and procurve 2530

ipoffice phone issue with cisco 2960 and procurve 2530

(OP)
Hi Guys,

new to this sub forum but hope you can help.

I have an Avaya IP office 500 system connected to 4 x cisco 2960 switches. This has been working fine for ages but recently a new switch was purchased and its is an HP Procurve 2530.

I have configured the HP with the correct Vlans etc but when making internal calls to internal extensions some of those calls are silent, it is always the same internal extensions and its only happens when one phone is plugged into the HP switch and the other into a cisco although it doesn't matter which of the 4 ciscos it would seem.


I think that vlan traffic is being dropped by the ciscos for some reason

Has any one experienced this and could please help
Cheers

my config is below:-

Avaya ip office 500
4x cisco 2960 –all working with ip phones
1 hp procurve 2530


2 vlans

Vlan id 1 for data on 192.168.1.x range

Vlan id 42 for voice on 192.168.42.x range


The Hp 2530 is connected via physical port 1 to a trunk port of the cisco 2960 and this is configured as a trunk on the cisco.

RE: ipoffice phone issue with cisco 2960 and procurve 2530

You need to make sure Cisco and HP have the same untagged VLAN. Cisco calls the VLAN "native" and out of the box it is VLAN1 on their switches. I'd also check the qos settings such as trust, cos-dscp and dscp-cos maps on both.

RE: ipoffice phone issue with cisco 2960 and procurve 2530

(OP)
Thanks for the reply iggsterman,

I was thinking along the same lines, I have tagged vlan id 42 on the hp 2530 and lest the vlan id 1 un tagged.

some documents refer to both vlans being tagged on the uplink port on the procurve but I cant get any communication that way,

my cisco config is as follows

Ccswitch4#sh run
Building configuration...

Current configuration : 9684 bytes
!
! Last configuration change at 15:10:48 UTC Sat Apr 17 1993
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Ccswitch4
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
system mtu routing 1500
vtp mode transparent
!
!
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 70 30
mls qos srr-queue input threshold 1 80 90
mls qos srr-queue input priority-queue 2 bandwidth 30
mls qos srr-queue input cos-map queue 1 threshold 2 3
mls qos srr-queue input cos-map queue 1 threshold 3 6 7
mls qos srr-queue input cos-map queue 2 threshold 1 4
mls qos srr-queue input dscp-map queue 1 threshold 2 24
mls qos srr-queue input dscp-map queue 1 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue input dscp-map queue 1 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue input dscp-map queue 2 threshold 3 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 4 5
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 0
mls qos srr-queue output cos-map queue 4 threshold 3 1
mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue output dscp-map queue 1 threshold 3 46 47
mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35
mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39
mls qos srr-queue output dscp-map queue 2 threshold 2 24
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15
mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14
mls qos queue-set output 1 threshold 1 100 100 50 200
mls qos queue-set output 1 threshold 2 125 125 100 400
mls qos queue-set output 1 threshold 3 100 100 100 400
mls qos queue-set output 1 threshold 4 60 150 50 200
mls qos queue-set output 1 buffers 15 25 40 20
mls qos
!

quit
!
!
!
auto qos srnd4
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 42
name voice-vlan42
!
!
!
!
!
!
interface FastEthernet0/1
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 10 10 60 20
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!

interface FastEthernet0/2
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/3
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust


interface FastEthernet0/4
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/5
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/6
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/7
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/8
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/9
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/10
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/11
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/12
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/13
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/14
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/15
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/16
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/17
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 10 10 60 20
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/18
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/19
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/20
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/21
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/22
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/23
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 10 10 60 20
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/24
switchport mode access
switchport voice vlan 42
srr-queue bandwidth share 10 10 60 20
priority-queue out
mls qos trust cos
auto qos trust
no cdp enable
spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport mode trunk
!
interface Vlan1
ip address 192.168.1.43 255.255.255.0
!
ip default-gateway 192.168.1.1
ip http server
ip http secure-server
logging esm config
snmp-server community ccsnmp RO

!
end

RE: ipoffice phone issue with cisco 2960 and procurve 2530

A few observations.
1. Cisco auto-qos is not really recommended when integrating with Avaya. It was specifically designed for Cisco IP phones. This gets worse in multiple vendor switch setup as you'd have to match tons of auto-generated Cisco auto-qos statements on your HP switch. I'd go with manual config on both if I had to do it from scratch. There are a few documents by Avaya specifically addressing Avaya equipment to Cisco Layer 2 and 3 connectivity.
Look them up. If you wish I can supply a document that I have used, Cisco only, no HP.
2. There should be end to end QoS but from your config I do not see you have it on the trunk port.
3. You do need to check that HP places packets from phones and those coming from the Cisco switches into the strict priority queue. To further clarify my point, for QoS to function properly across the switches, all need to have proper maps of COS values to priority queues, e.g. COS=5 packets coming from an IP phone need to have the CoS preserved (trust) and mapped to the strict prio queue.
4. One more thing to look at is same STP settings. Your Cisco switch shows PVST. Avaya recommends Rapid PVST. Not a big deal but I would at least match them between Cisco and HP.

RE: ipoffice phone issue with cisco 2960 and procurve 2530

I assume the HP switch is patched to G0/2 on the Cisco?
The facing HP switchport should therefore have VLAN42 tagged and VLAN1 untagged.

The next thing to worry about is the HP switchport config for where the phone is patched: it should be configured to match the access ports on the Cisco switches, ie, VLAN42 tagged, VLAN1 untagged.

Iggsterman's advice on QoS and STP are pertinent, but a lack of QoS will give you poor quality voice, not likely to give you no voice at all, so I think you have some basic config to get right before worrying about QoS.

Check your phones on the HP switch are getting a correct IP address on the VLAN42 subnet.

RE: ipoffice phone issue with cisco 2960 and procurve 2530

(OP)
Thanks guys!

I will check the QoS.

Vince you are correct re trunk port. I do have the port connected to the cisco (number 1 as it happens) on the HP set up as you suggest with Vlan42 tagged and vlan 1 untagged. Also on ports with Avaya IP phones they also have Vlan42 Tagged.

The phones all get correct IP addresses from the dhcp server on the IP office and I am able to contact the Voice mail server etc no problem. Indeed I can make external calls with out issue.

I cant see QoS only stopping internal voice when there is nothing else on the HP switch at all.

I will try and apply QoS on the cisco trunk port anyway.

I have set vlan42 to highest priority on the HP but I guess this may not match the cisco way of doing things.

What else could it be?

Thanks Guys, fantastic tips as always.

RE: ipoffice phone issue with cisco 2960 and procurve 2530

(OP)
Hi All,

thanks once again for all your help.

I think that I have resolved this issue.

lldp run on all ciscos and HP and im up and running with voice across all switches.
e.g

conf t

lldp run
lldp enable-notification (hp only I believe)

I had to disable then enable on the HP oddly but all is well.

thanks again!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close