INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

VLAN Setup Help

VLAN Setup Help

(OP)
I have never really setup VLANs before from scratch. I have a Cisco 881 Router and 2 Cisco Switches (SG200-50 and SF300-48P). I need to have two vlans. Vlan1 (10.100.20.0) and Vlan21 (10.100.21.0). Both these should be able to talk to each other for various reasons. The Cisco router is configured with two interfaces. FA0 using VLAN1 and FA1 using VLAN21 currently. I have VLAN1 plugged into G1 on the SG200-50. I have VLAN2 plugged into G4 on SF300-48P. Now, I know this probably isn't a good setup. Each VLAN will work on their own switch, but I want to be able to use both VLANs on each switch. I tried linking the switches together, but that ended up in no connectivity. It may have been due to a loop since VLAN1 and VLAN21 can talk to each other. Can someone help me figure out the best way of doing this. It should be simple for someone experienced in networking. I have attached a diagram to help make sense of the matter. Thanks!


881w Router Config (Main Things)

!
interface FastEthernet0
description .20 Interface
switchport mode trunk
no ip address
!
interface FastEthernet1
description .21 Interface
switchport access vlan 21
no ip address
!
interface Vlan1
description .20 Interface
ip address 10.100.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
zone-member security in-zone
ip tcp adjust-mss 1452
!
interface Vlan21
description .21 Interface
ip address 10.100.21.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
zone-member security in-zone
!

RE: VLAN Setup Help

(OP)
Any thoughts?

RE: VLAN Setup Help

if your diag is correct then to switch 2 you are only sending vlan 21 .. and not a trunk (vlan 1 and vlan 21) ...

fix that.

We must go always forward, not backward
always up, not down and always twirling twirling towards infinity.

RE: VLAN Setup Help

Yup, like L2 trunk

and switchport trunk encaps dot1q 1 (native, optional)

ip access-list extended IP-Options-and-Powerball
deny ip any any winning-powerball-ticket
permit ip any any option any-options
!
class-map ACL-Options-and-Powerball
match access-group name IP-Options-and-Powerball
!
policy-map CoPP-POLICY
class ACL-Options-and-Powerball
drop
!
control-plane
service-policy input CoPP-POLICY

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close