INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

QoS Marking Question

QoS Marking Question

(OP)
Hi,

I have a small problem and I'm a bit confused, Cisco suggested that you should mark traffic as close to the end devices as possible. So I wanted to try marking the traffic coming from S1 to R1, S2 to R2, and S3 to R3 on Switch 2 (Cisco Catalyst 2960) with the following config:

access-list 101 permit udp any any eq 10101
access-list 102 permit udp any any eq 10102
access-list 103 permit udp any any eq 10103

class-map PHONE
match access-group 101
exit
class-map CAMERA
match access-group 102
exit
class-map WEB
match access-group 103
exit

policy-map MARK
class PHONE
set ip dscp 46
exit
class CAMERA
set ip dscp 32
exit
class WEB
set ip dscp 10
exit
exit

interface fa0/1
service-policy out MARK

I did "service-policy out" to mark the traffic coming out of Switch 2's Fa0/1 going to Router 2's Fa0/0 so they are ready for the queueing mechanism at Router 2's S0/0/0 interface, but after entering the command it says it is not supported. From what I understand I am marking "engress" traffic (traffic from S1 to R1 as an example) thats why I used the command "service-policy out", rather than "ingress" traffic (traffic coming from R1 to S1).

My questions:

1. Have I got the concept of ingress and engress correctly?
2. Is there another way to do it or the only way possible is marking traffic on Router 2's Fa0/0?
3. If I do the marking on Router 2's Fa0/0 is it going to be ingress (service-policy in MARK) or egress (service-policy out MARK)

Thanks,
Unicross


RE: QoS Marking Question

(OP)
I meant egress :D

RE: QoS Marking Question

Depending on what your switch is, you may not have the option of marking them "out".
I've usually had to mark it "in" at the access ports.

RE: QoS Marking Question

The 2960/3560/3750 switches do not support egress QoS policies. You must do the marking on ingress - which is even closer to the device... On egress you queue the traffic based on its marking by mapping the appropriate DSCP values to one of the three thresholds in one of the four queues - i.e. Q1T2.

Andy

RE: QoS Marking Question

(OP)
Thanks, I'm now marking traffic for each ports connected to the end devices :D using the command service-policy input MARK.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close