INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

MWI is not working, mwistate.mdb is not updating

MWI is not working, mwistate.mdb is not updating

(OP)
Hi,

We have a Modular Messaging connected to S8800 via H323, MM version is 5.2. Lately I found out that MWI is no longer working. Upon checking the mwi state audit, the last time it has a data was 01-10-2013. Since then, there are no longer data being populated to mwi state logs.

MWI Internal Audit Report Generated At 02:00:01 10/01/2013 (DD/MM/YYYY)
================================================================================
Users: 28;InSync: 21 (75.00%);OutOfSync: 7 (25.00%)
================================================================================
Result;StationID;LampState;MessageState;SearchKey
================================================================================
FAIL;829090;ON ;OFF;UMOBJECTGUID=2397D9BAE5A111E1816DE41F136656A4 OU=PEOPLE DC=AVAYA
FAIL;860052;OFF;ON ;UMOBJECTGUID=D9447572EC0911DF943DE41F136656A4 OU=PEOPLE DC=AVAYA
FAIL;860080;ON ;OFF;UMOBJECTGUID=4BDFD57A95F211E1816DE41F136656A4 OU=PEOPLE DC=AVAYA
FAIL;860485;ON ;OFF;UMOBJECTGUID=652133A415C211E19B25E41F136656A4 OU=PEOPLE DC=AVAYA
FAIL;860506;OFF;ON ;UMOBJECTGUID=191BB49078C711E09B25E41F136656A4 OU=PEOPLE DC=AVAYA
FAIL;860698;ON ;OFF;UMOBJECTGUID=0CC7F47CE59211E1816DE41F136656A4 OU=PEOPLE DC=AVAYA
FAIL;868686;OFF;ON ;UMOBJECTGUID=701AE62A558511E2816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;829046;OFF;OFF;UMOBJECTGUID=5ACF1A8EE5A011E1816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860000;ON ;ON ;UMOBJECTGUID=F9EDCB5AE81E11DF9344E41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860015;ON ;ON ;UMOBJECTGUID=C95173B265BD11E09B25E41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860016;OFF;OFF;UMOBJECTGUID=E489225614E511E19B25E41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860017;OFF;OFF;UMOBJECTGUID=F86347DE150811E19B25E41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860020;OFF;OFF;UMOBJECTGUID=AACCCDE265DB11E09B25E41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860050;ON ;ON ;UMOBJECTGUID=06F7E358083111E0822CE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860055;OFF;OFF;UMOBJECTGUID=1CA8F1E0E64911E1816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860095;ON ;ON ;UMOBJECTGUID=84E61E3E083011E0822CE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860305;OFF;OFF;UMOBJECTGUID=B75F9EE278C611E09B25E41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860543;ON ;ON ;UMOBJECTGUID=081ECBE8794111E1816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860658;OFF;OFF;UMOBJECTGUID=042038A2558611E2816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860660;OFF;OFF;UMOBJECTGUID=D69A19D8558611E2816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860677;ON ;ON ;UMOBJECTGUID=1A4436F495F311E1816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860697;OFF;OFF;UMOBJECTGUID=387B308EE59211E1816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860699;ON ;ON ;UMOBJECTGUID=2844E5DEE4C011E1816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860941;OFF;OFF;UMOBJECTGUID=6D537546558611E2816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860943;OFF;OFF;UMOBJECTGUID=2717364E558611E2816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860966;OFF;OFF;UMOBJECTGUID=8BC9324A558611E2816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;860967;OFF;OFF;UMOBJECTGUID=4A8DDF92558611E2816DE41F136656A4 OU=PEOPLE DC=AVAYA
PASS;999999;OFF;OFF;UMOBJECTGUID=3562C4F8D29211DF9344E41F136656A4 OU=PEOPLE DC=AVAYA

########################################################################################################

MWI Internal Audit Report Generated At 02:16:00 11/01/2013 (DD/MM/YYYY)
================================================================================
Users: 28;InSync: 0 (0.00%);OutOfSync: 0 (0.00%)
================================================================================
Result;StationID;LampState;MessageState;SearchKey
================================================================================

MWI Internal Audit Report Generated At 02:00:01 24/01/2013 (DD/MM/YYYY)
================================================================================
Users: 29;InSync: 0 (0.00%);OutOfSync: 0 (0.00%)
================================================================================
Result;StationID;LampState;MessageState;SearchKey
================================================================================


I already restarted the MAS service and rebuild the mwistate.mdb, but still no avail.

MAS server itself was also restarted, but the issue still persist.


Could you interpret this kind of log I got from MM Audit logs viewer:
Type Time Username Application Operation ObjectType Object Old Value New Value
Allowed 1/10/2013 15:29 PRIVDOM\dom-mmlog MYMAS1\vserver.exe opMWIWrite Domain\MWI MWI update schedule guid {46B2B983-EA2C-421A-A185-CC241B2D55FE} {15A0DC86-D15A-4F29-906F-253419BA18C6}
Allowed 1/10/2013 15:27 PRIVDOM\dom-mmlog MYMAS1\asconfig.exe opMWIRead Domain\MWI MWI settings Object Object


What I'am missing here?

Thanks

-Bok

RE: MWI is not working, mwistate.mdb is not updating

Please review https://support.avaya.com/kb/ext/SOLN142288 which may help resolve this issue. Often times people don't rename the mwistate.ldb file along with the mwistate.mdb file which can cause the MWI database to not rebuild correctly. If you do that proceedure and still don't see the mwistate.mdb file updating I would recommend resyncronizing the Front End Database, see https://support.avaya.com/kb/ext/SOLN124706. If the FEDB is out of sync it can cause the MWI database not to rebuild correctly.

I hope that helps! You can always open a support request on https://support.avaya.com.

RE: MWI is not working, mwistate.mdb is not updating

(OP)
By changing the binding orders of network adapter, mwistate.mdb is now updated with on and off state. However, MWI lamp of phoneset still not working. By the way, MM integration to CM is by H323.
Is there any tricks on how to solve this?

RE: MWI is not working, mwistate.mdb is not updating

Did you resynchronize it as well?

Ken Means

www.tel-is.com
"I find that the harder I work, the more luck I seem to have."
- Thomas Jefferson (1743-1826)

RE: MWI is not working, mwistate.mdb is not updating

do you mean by doing on-demand update on the MWI?

RE: MWI is not working, mwistate.mdb is not updating

No I mean rebuilding the mwi database after it started updating the mwi in the one file.

Ken Means

www.tel-is.com
"I find that the harder I work, the more luck I seem to have."
- Thomas Jefferson (1743-1826)

RE: MWI is not working, mwistate.mdb is not updating

Already done with that part and wmtstate is now updating. MWI activity now viewed on OPHIST but there's an error:

....error Set, request Glare has occured from port 30"

I think it's the connection within MAS and CM since it was a request Glare...

Any ideas?

Mark

RE: MWI is not working, mwistate.mdb is not updating


Subscribe Printable version Email
Modular Messaging: MWI not working for H.323 Integration, getting glare or device Busy
Rate this Page

Doc ID: SOLN138347
Version: 2.0
Status: Published
Published date: 03 Jul 2009
Updated: 06 May 2012
Author:
Girish Dineshan

DETAILS
Modular Messaging (MM) 3.0 and above with IP Integration.
Modular Messaging Implementation with IP Integration on Avaya CM. Configuration Notes to be used is cn88014.pdf.
Message-Waiting Indicator (MWI), call me, Find me do not work.
When a trace is run on the PBX, there is no instance of the call coming from the MM.
So basically the MM does not outcall back to the Communication Manager (CM).
PROBLEM CLARIFICATION
MWI not working for H.323 Integration, getting glare or device Busy.
CAUSE
The CLAN IP address and the Messaging Application Server (MAS) Private IP address have been configured to use the same Subnet.
An example is provided as a snapshot.
Explanation:
MAS Private IP address = 10.132.18.38
MAS corporate IP address = 10.132.0.216
CLAN IP address = 10.132.18.36
The Subnet mask is 255.255.255.0
When the MAS needs to make an outcall (for MWI, call me, Find Me) it has to make it through the Corporate LAN interface to the CLAN on the switch.
But in this scenario, since the IP address 10.132.18.36 is closer to the Private Interface 10.132.18.38, it tries to send out the Outcalling request on the Private interface and since there is no route to the PBX on this interface it fails with the error, Glare or Device Busy.
To verify this use the command line interface on the MAS. Command used is arp -a
SOLUTION
There are two Solutions to the above problem:
A. Change the IP address of the CLAN so that it is in the Corporate IP address subnet
B. Add a static route on the Corporate Network Switch to route the Packets from the MAS to the CLAN interface
Note: Adding a route will be the user's responsibility.
A. Changing the CLAN IP:
Log in to the PBX and change the IP address of the CLAN interface
On the command interface on the PBX type the command change ip-interfaces
Scroll down to the CLAN for the MM, and change the IP address, so that it belongs to the Corporate LAN subnet
Administer the same CLAN address on the MAS, VMSC --> MAS --> PBX Integration --> IP Configuration and enter the PBX IP Address as the CLAN IP
B. Adding a static route on the Corporate Network Switch:
Get in touch with the Network Administration team and have the static route administered on the PBX
This would be a solution that the user's network team would have to undertake
LEGACY ID
KB01079694

Please rate this article


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy



There are two Solutions to the above problem:
A. Change the IP address of the CLAN so that it is in the Corporate IP address subnet
B. Add a static route on the Corporate Network Switch to route the Packets from the MAS to the CLAN interface
Note: Adding a route will be the user's responsibility.
A. Changing the CLAN IP:
Log in to the PBX and change the IP address of the CLAN interface
On the command interface on the PBX type the command change ip-interfaces
Scroll down to the CLAN for the MM, and change the IP address, so that it belongs to the Corporate LAN subnet
Administer the same CLAN address on the MAS, VMSC --> MAS --> PBX Integration --> IP Configuration and enter the PBX IP Address as the CLAN IP
B. Adding a static route on the Corporate Network Switch:
Get in touch with the Network Administration team and have the static route administered on the PBX
This would be a solution that the user's network team would have to undertake

Ken Means

www.tel-is.com
"I find that the harder I work, the more luck I seem to have."
- Thomas Jefferson (1743-1826)

RE: MWI is not working, mwistate.mdb is not updating

The MAS corporate and Private IP addresses are on different subnet groups.

Corporate IP - 10.243.56.96
Private - 192.168.1.250

In the arp table, PBX and MSS were resigtered on the Corporate LAN interface.

RE: MWI is not working, mwistate.mdb is not updating

Is this still an issue ?

Ken Means

www.tel-is.com
"I find that the harder I work, the more luck I seem to have."
- Thomas Jefferson (1743-1826)

RE: MWI is not working, mwistate.mdb is not updating

Hi Ken,

Yes and it's getting interesting...

Last March, client perform their building maintenance so they reboot the MM. Apparently, there's an incident that the MSS Hard Disk was corrupted. To make it short, we reinstall the MM Server.

Upon testing, request glare issue (21441) is still present on the server. Verify the mwiserver and it is updating.

Thanks,
Mark

RE: MWI is not working, mwistate.mdb is not updating

Is the CLAN card dedicated to the MM or is it included in the user network region too?

RE: MWI is not working, mwistate.mdb is not updating



Try this.

MM unable to communicate out, Call Me, Find Me, MWW fail system wide
OP hist shows 21441 events "MWI notification being sent to high-level component for extension XXXXX, error Reset, request Glare has occured from port XX"
CM a traces show no instance of the call coming from the MM
PROBLEM CLARIFICATION
MWI, Call Me, Find Me not working for H.323 Integration, getting glare or device Busy
CAUSE
CLANs moved to a different region with the exception of the one MM talks to.
SOLUTION
The CLAN needed to be reset, the arp table in the CLAN needs to be flushed.
Reset the CLAN to flush the arp cache

Ken Means

www.tel-is.com
"I find that the harder I work, the more luck I seem to have."
- Thomas Jefferson (1743-1826)

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close