INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Shortcut to compiled DOS program - Inconsistent mouse behaviour.

Shortcut to compiled DOS program - Inconsistent mouse behaviour.

Shortcut to compiled DOS program - Inconsistent mouse behaviour.

(OP)
I have a DOS application into which includes mouse routines developed from the Clipmous library. I have modified the GETSYS.PRG routines to interpret the mouse movements, and clicks, and this works satisfactorily.

When I run this program in a DOS (cmd) window it works fine, and responds to the mouse moves.

However, on one Windows XP machine (my client’s), I find that if I create a shortcut directly to my application (for example, a link to myprog.exe, starting in C:\myprogs), the program runs correctly, but does not pick up mouse clicks. Instead it just highlights (in red) one or more characters (from a SAY statement), usually close to where I have clicked.

If (on this same machine) I open a cmd window (so, a shortcut to DOS cmd), and then navigate to c:myprogs, and then key in myprog.exe, the program works fine, mouse and all.

I cannot discover the reason for this difference in behaviour : On the one hand a direct shortcut to myprog.exe; on the other hand opening a DOS session, then calling myprog.exe from the DOS command window.

I had thought there might be something in the properties of the shortcut, but cannot see anything obvious). Is there perhaps a setting in CONFIG.NT which I need to have?

On my own machine the program works fine, whichever way it is started.

If anyone has experienced a similar problem I would be very grateful to hear.

Andrew

RE: Shortcut to compiled DOS program - Inconsistent mouse behaviour.

(OP)
In answer to my own question, the problem seems to be caused by the setting of the QuickEdit option in a cmd session under windows.

If you right-click on the the C:\ icon at the top left of the DOS window, then go into properties, there is a check-box on the options tab called !QuickEdit mode". If that box is cleared, the mouse seems to work satisfactorily.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close