Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Borvik (Programmer) (OP)
19 Dec 12 10:14
As the title states, we have 1 user that is generally really slow in GP. It's not limited to Login, or opening a Window, but also doing searches, selecting line items - basically anywhere it accesses data. Sometimes it is better than others, but it is usually pretty slow.

This user just received a computer upgrade. A brand new machine running Windows 7 64bit w/ 8 GB RAM and a Intel i5 processor.

The network is just fine as it connects to our server and has a normal data transfer rate.

Other applications I have written (report applications using VS2008) connect just fine to the GP database and pull reports at their normal speeds.

It appears that GP itself on this machine is the only thing having issues with speed.

I have already copied an identical installation from another working Win7 64bit machine over top this slow one, with no results.

Later I plan to uninstall, delete directories, and reinstall - trying to repair the .NET Framework 2.0 installation at the same time.

Anyone have any thoughts on why this might be slow.
Borvik (Programmer) (OP)
19 Dec 12 10:19
I have some more information - you never get the full story from the user until the 3rd or 4th retelling...

It now appears most of GP is fine. It is just slow on windows I have developed plugins on. So it would seem to have something to do with my 3rd party plugins that I wrote.

I have built some of these with VS2008 so, it could still be an issue with the Framework, but it now narrows down my search parameters.
Borvik (Programmer) (OP)
19 Dec 12 14:03
I've attempted to fix the Framework - it appears version 2.0 is part of the Windows 7 core features, and can't be removed or reinstalled. I've run sfc /scannow with no results either.

I have removed the AddIn from the directory, and have confirmed it IS the Visual Studio Tools for Dynamics GP application plugin that I've written that is causing the slowdown. Yet this is the ONLY machine to do this (I have tried other user profile with the same results), and we do have other Win7 64 bit machines using this plugin.
Borvik (Programmer) (OP)
19 Dec 12 15:01
SOLVED!!!

I had been using some Registry code to help get database connections (we aren't using gpconnnet) by scanning for the DSN.

I upgraded that bit of the code, so it wasn't accessing the registry and everything is working fine now.
VictoriaYudin (IS/IT--Management)
20 Dec 12 7:30
Borvik,

Thanks for posting what the solution was! Hopefully it will help others in the future.

Victoria Yudin
Dynamics GP MVP 2005 - 2012
Use Crystal Reports and SSRS with GP:
http://www.GPReportsViewer.com/gpreports.html
blog: http://victoriayudin.com

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close