INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

PB 11.5, EAserver 6.2, Oracle 10g --- ORA-24388 occurs after multiple retrieves

PB 11.5, EAserver 6.2, Oracle 10g --- ORA-24388 occurs after multiple retrieves

PB 11.5, EAserver 6.2, Oracle 10g --- ORA-24388 occurs after multiple retrieves

(OP)
Hello,

We have a window that establishes a connection to EAServer, and gets a reference to an NVO (#1) on that server. The NVO (#1) creates a datastore NVO (#2).

A button on the window calls a method on NVO #1, which uses NVO #2 to retrieve data. (We're trying to use setFullState / GetFullState ).

The first retrieve always works and no dberror message is returned. Around the third retrieve, however, only some of the rows are returned and we get the "ORA-24388: statement handle not executed" error returned from the dbError event of the datastore NVO.

All subsequent retrieves also give that error.

Re-deploying the NVO #1 fixes things.
Or, having the NVO #1 disconnect and reconnect when the retrieve() fails fixes things ... for a single retrieve.

It feels like we are running into some resource limit ... but I don't know what the limit is.
When the retrieve works, we get 180k rows, and have a blob of 26mb. When the retrieve fails ... we have some number of rows less than 180k ... it varies.

We've done a bunch of googling ... but haven't found anything that looked appropriate.

Thanks,

LR

RE: PB 11.5, EAserver 6.2, Oracle 10g --- ORA-24388 occurs after multiple retrieves

(OP)
Hello,

Our EAServer version is actually 6.3 and there is a chance that this is related to the Sybase Change Request 6956167, which indicates there is a problem with virtual memory usage concerning blobs in EAServer.

LR

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close