INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Export to .txt - Not wide enough

Export to .txt - Not wide enough

(OP)
SAP - Crystal Reports XI

Hi

I'm new to this version of Crystal Reports and I'm having issues with the following;

I have designed my report and want to export it to .txt
I have set characters per inch to 16 and the number of lines per page to zero.

Unfortunately the entire data string on some records does not export. It appears to have set a limit of 258 characters.

Does anyone know if there is a limit to the number of characters per record you can extract or how I can widen my export?

Many thanks

Steve

RE: Export to .txt - Not wide enough

I believe that XI still had that limit. Crystal 2008 and higher does not.

-Dell

DecisionFirst Technologies - Six-time SAP BusinessObjects Solution Partner of the Year
www.decisionfirst.com

RE: Export to .txt - Not wide enough

(OP)
Thanks Hilfy

Apologies but I should have said CR 2011 not XI, which based on what you said that 2008 onwards does not have that limit, how do I extend the width to incorporate the full data set?

Kind regards

Steve

RE: Export to .txt - Not wide enough

Try making your number of characters per inch larger for the text export. You could also try changing your paper size and making it landscape so that it is wider - sometimes that will make a difference with the export.

Are you adding commas and making this a .csv or are you doing a fixed width export?

-Dell

DecisionFirst Technologies - Six-time SAP BusinessObjects Solution Partner of the Year
www.decisionfirst.com

RE: Export to .txt - Not wide enough

(OP)
I already have it as landscape and the CPI is set at 16 with 0 pagenation.

The data is pipe delimited

RE: Export to .txt - Not wide enough

If the data is pipe delimited, you might want to try this instead of exporting as text:

1. In the Page Setup, turn on No Printer and Dissociate Formatting Page Size and Printer Paper Size. Also, set the page size to User Defined and make it fairly wide.
2. Place all of your fields on the report in the order that you want them to be in the output.
3. Export to CSV. Set the Separator to a pipe, if you're not putting quotes around the strings, delete the quotes from the Delimiter. You should also play with the other options to make sure that you get what you're looking for in the file. Set the export file name to something other than .csv.

-Dell

DecisionFirst Technologies - Six-time SAP BusinessObjects Solution Partner of the Year
www.decisionfirst.com

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close