INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

This page contains the following errors: error on line 18 at column 11: attributes construct error

This page contains the following errors: error on line 18 at column 11: attributes construct error

This page contains the following errors: error on line 18 at column 11: attributes construct error

(OP)
I cannot find out what this error means, can someone have a quick look and let me know what it is. I have been up all night and I need a set of fresh eyes, anybody?

code is below

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:epub="http://www.idpf.org/2007/ops" xmlns:ibooks="http://apple.com/ibooks/html-extensions">

<head>
<meta name="viewport" CONTENT="width=738,height=985"></meta>
<meta CONTENT="text/html; charset=UTF-8"></meta>
<title>Xxxxx</title>
<link HREF="css/3950906A-0B6A-46CA-958A-9DB22A232ED5.css" TYPE="text/css" REL="stylesheet"></link>
</head>

<body>

<div CLASS="page">
<span id="word0"></span>
<img CLASS="background" SRC="images/79DA61A7-41C9-43B7-889D-9B791F171D28.jpg" ALT="image" />

<img CLASS="ibooks-media-audio"data-ibooks-audio-src="audio/nigerianNumbersPage1.m4a"
id="image1" SRC="images/2445D9BD-1619-40A9-A1C6-D159EE05DC84.jpg" ALT="image" />
<p>
<br/>
</p>
</div>

</body>
</html>

RE: This page contains the following errors: error on line 18 at column 11: attributes construct error

Hi there!

Attributes need to be separated by spaces if I'm not mistaken.
So your error would be with this line:

CODE

<img CLASS="ibooks-media-audio"data-ibooks-audio-src="audio/nigerianNumbersPage1.m4a"
id="image1" SRC="images/2445D9BD-1619-40A9-A1C6-D159EE05DC84.jpg" ALT="image" /> 
Change it thus:

CODE

<img CLASS="ibooks-media-audio" data-ibooks-audio-src="audio/nigerianNumbersPage1.m4a" id="image1" SRC="images/2445D9BD-1619-40A9-A1C6-D159EE05DC84.jpg" ALT="image" /> 

Plus: it is not all too good practice to mix uppercase and lowercase attribute names like this. Better stick to one convention as to avoid any kind of confusion. XML is case sensitive after all.

Cheers,
MakeItSo

“Knowledge is power. Information is liberating. Education is the premise of progress, in every society, in every family.” (Kofi Annan)
Oppose SOPA, PIPA, ACTA; measures to curb freedom of information under whatever name whatsoever.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close