INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

SQL Taks fails but data is correct at the time of failure

SQL Taks fails but data is correct at the time of failure

(OP)
I have a stored procedure to parse a name field. Every once in a while the SQL Data Task will fail stating

[Execute SQL Task] Error: Executing the query "SSISParseTheName2" failed with the following error: "The statement has been terminated.". Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters not set correctly, or connection not established correctly.

When I look into the database, all of the records where parsed correctly. Does anyone have any ideas? Is there any way to continue processing even though the task failed? I'm using SQL Server 2005.

Thanks, Penny

RE: SQL Taks fails but data is correct at the time of failure

put some error trapping in there - add an error flow on the SQL task. Attach a script to it and get it to pop up an error message with any details that are relevant

Rgds, Geoff

We could learn a lot from crayons. Some are sharp, some are pretty and some are dull. Some have weird names and all are different colours but they all live in the same box.

Please read FAQ222-2244: How to get the best answers before you ask a question

RE: SQL Taks fails but data is correct at the time of failure

(OP)
Thanks but I have no idea how to do that. Can you walk me through it or point me to a URL that can? I've googled it but have not found the "how to's".

RE: SQL Taks fails but data is correct at the time of failure

(OP)
I solved my issue. When several of the "Execute SQL Task"'s failed. I copied the code from the stored procedure directly into the Task. It worked perfectly from there. Apparently the connection to SLQ Server was timing out.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close