Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

"error 1325 : <filename> is not a valid short filename"

Leozack (MIS) (OP)
26 Mar 12 4:40
Hi all - I'm getting this error when deploying some software via GPO that deployed fine to XP 32bit but not to win7 64bit and I don't know why.  I found that if I literally make every folder in the install path 8 letters or less the error doens't happen, but on the software I did that with I then had corrupted results in some of the config files and such where folder paths had folders over 8 letters they wer ereplaced with random 8 character strings  :(  what's stranger is not only does it deploy fine to XP 32bit, but even on this win7 64bit if I run the install manually it works - it only fails when it's deployed to clients from GPO and installed at startup.  I'm not getting much help from software vendors and I'm finding very little online that doesnt' refer to office 97 or something old and suggesting using msi cleanup util or whatever.  Nearest thing I've found it this but I don't have enough time onsite to keep testing so I'm really hoping anyone can shed some light on this?

http://blogs.msdn.com/b/astebner/archive/2005/01/27/362049.aspx

_________________________________
Leozack

CODE

MakeUniverse($infinity,1,42);

Leozack (MIS) (OP)
26 Mar 12 4:49
I've found some further information but it's not overly helpful  suggestions like changing your username or using a different account or disabling offline files!

http://superuser.com/questions/258239/error-1325-username-is-not-a-valid-short-file-name

http://www.vistax64.com/vista-general/57795-error-3125-not-valid-short-name.html

http://techsmith.custhelp.com/app/answers/detail/a_id/1320/~/snagit-for-windows---error-1325%3A-file-name-is-not-a-valid-short-file-name

_________________________________
Leozack

CODE

MakeUniverse($infinity,1,42);

linney (TechnicalUser)
26 Mar 12 15:02
I wonder if this might work, or give you a few clues, in Windows 7?  Fsutil.exe is available in Windows 7 with the "8dot3name       8dot3name management"  command.  I must admit I also wonder if it is relevant to your problem too?


How to Disable the 8.3 Name Creation on NTFS Partitions
http://support.microsoft.com/kb/121007#appliesto



Does including full paths in quotes make any difference?
Leozack (MIS) (OP)
26 Mar 12 15:20
I'm not in a hurry to change the way the system works with 8.3 since only some packages are having this problem and I know by disabled 8.3 to "speed up for XP pc" in old tips I actually found certain software failed to run because it relied on it (you can't help people writing crao sofware I guess - age old problem!)

I'm not giving paths in quotes or otherwise - I'm making a GPO and setting an MSI to deploy with it.  Some work fine, but particular ones fail with this message.  But if you run them while logged in they work fine - they also deploy fine (while not logged in) as they always did on 32bit XP.

So I dunno if it's a problem with 64bit, or win7, or permissions (works when logged in, not as system during startup as deployed msi via gpo) but I dont' really have resources to test it (already lost a whole day trying to get it going and eventually managed it by making all folders in path 8 chars - which then corrupts/fails parts of the program containing long folders even though it installs ok!)

:/

_________________________________
Leozack

CODE

MakeUniverse($infinity,1,42);

Leozack (MIS) (OP)
8 May 12 6:00
Incase anyone wants to know I eventually found the answer to this!  Believe it or not it actually came down to NTFS  permissions (relevant to filename/folder length how??)

The problem was on the ROOT of the share being used, someone hsd stripped back NTFS permissions to certain users.  eg

\\servers\apps\programname

"programname is not a valid short filename" etc, and you check all the permissions in that folder and so on and wonder why it works fine on XP 32bit but not win7 64bit.

The reality is up at the apps level, you need to give either users or auth users read permissions - I found 2 different shares using different tickboxes under advanced permissions but the end result was equivilent I think to basic reading capacity.

Anyway once we did that, we found we cuold install said software.  There were plenty of other solutions offered by people but none of them worked or were relevant.  This one was a TOTAL waste of many hours of work mainly due to the completely red herring nature of what little information you are given.  Another lesson learnt was always be aware of what permissions people have set on your share roots!

Anyway hope this helps someone somewhere

_________________________________
Leozack

CODE

MakeUniverse($infinity,1,42);

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close