Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

IPECS 50B Remote LIP-8012D Phone One Way Audio

OliHall (TechnicalUser) (OP)
17 Mar 12 13:01
Hi,

Does anyone have a checklist or a guide for setting up phones in
different subnets of a local network? The phone registers but I am getting one way audio.

I have an IPECS LIK-50B and phones on one subnet 10.10.10.x, and i am trying to set up a LIP-8012D phone at a remote site connected by VPN.

I have set the following settings in the remote phone:
Phone 2 netmask=255.255.255.0
phone #2 ip=192.168.12.123
router #2 ip=192.168.12.1
mfim #2=10.10.10.2
same lan with MFIM=no
mode r/l=local

I have not changed any settings in the MFIM.

I will refer to the phone at the remote site as the 'remote' phone, but it is in the same LAN, just a different subnet. Both subnets are routable to each other and i can ping the phone from the MFIM's subnet and I can ping the MFIM from the remote subnet. A UDP send/receive utility shows UDP packets are sent and recieved correctly both ways between PCs in both subnets.

The phone will register and connect to the MFIM, it will make and receive calls and when calling from the remote subnet the other party can hear you, but you can't hear the other party.

Wireshark shows the 'remote' phone is sending UDP:8002 to any local phone you call, but the local phones are not sending any packets back to the remote phone.

To eliminate the possibility of a problem caused by the VPN server or remote VPN router, I have moved the remote phone (and reset the IP and subnet etc) into the both the local data network and another local subnet that we have which are also routable from the MFIM's subnet and the problem is exactly the same.

I have also set the remote phone to mode r/l=remote and i get registration but I get no audio in either direction.

Please can anyone help.

thanks,
Oli.
doktor (IS/IT--Management)
18 Mar 12 9:15
It is often a port in the Firewall that is not opened, or a missing route in your Router, or the default gateway is not configured in the phones or in iPECS.

///doktor
 

3Sixty (TechnicalUser)
19 Mar 12 6:46
Are you sure you are using VPN or are you just pointing the phone to the public IP address of the MFIM site.

Thanks,
Colin

www.3sixtynetworks.com

OliHall (TechnicalUser) (OP)
19 Mar 12 13:35
Hi,

thanks for the replies,

doktor: I was wondering whether it was a problem with the ISA server which runs the firewall and the VPN, so I connected the phone to a different local subnet which has no ISA firewall between the two subnets, just plain a simple draytek router, and the problem is the same.

mrmarshall: I am using the local address of the MFIM in the phone's network config and it does register to the MFIM. I definitely know that it is using the VPN as I have no ports forwarded to the MFIM on it's WAN ip apart from 5060 so it couldn't possibly register if it was looking for the WAN ip of the MFIM.

is there anything else i can try?
thanks,
Oli.
pommiekev (TechnicalUser)
28 Mar 12 3:22
has the phone worked ok directly on the same lan as mfim, i had similar problem and it was a faulty phone.
OliHall (TechnicalUser) (OP)
23 Apr 12 13:19
Hi,

Sorry for long time to reply, but I am revisiting this problem.

This phone works fine if i take it back into the office and plug it into the same segment of the LAN as the MFIM.

I have connectivity from the MFIM's LAN segment to the remote segment, all routes are correct and using a packet send/recieve util I have confirmed transmission and reciept of UDP7000 packets both ways between PCs on the two segments.

Today I have tried configuring the remote phone to connect via the WAN IP of the MFIM Instead of via the VPN.

I have forwarded the following ports to the MFIM.

5588
7000-7015
7100-7115
7300-7315
8000-8015

I have changed the phone settings: MFIM IP to WAN IP address and R/L to Remote.

This still doesn't work. Are there any more ports to forward? it is an IPECS LIK50B and LIP-8012D phone.

I notice in someone else's thread, it is suggested that you need to forward some ports to the remote phone in the router local to the phone. Do I need to forward any ports to the phone at the remote location?

thanks,
Oli.
eats4treats (TechnicalUser)
23 Apr 12 15:48
Oli

Have you tried TCP 1720 and UDP 6254?

Eats
OliHall (TechnicalUser) (OP)
23 Apr 12 15:51
Should i forward those ports to the mfim in the router that the mfim is behind or forward them to the phone in the router that the phone is behind or both?
thanks,
Oli.
eats4treats (TechnicalUser)
24 Apr 12 15:05
Oli

Just the MFIM side.   
randall1uk (TechnicalUser)
30 Apr 12 4:28
If you change the mode to remote from local you should find it will work ok
OliHall (TechnicalUser) (OP)
30 Apr 12 4:33
Hi,

I did have the phone set to R/L: Local when I had it pointed at the internal LAN ip of the MFIM with traffic handled via our VPN, but I was getting one way audio in this situation even though all my internal routes were set correctly.

In this second instance, I am trying to set the phone up not to use the VPN and to use the WAN IP of the MFIM which was why I set the phone to R/L: remote.

randall1uk: Are you saying I should have the phone set to R/L: Local while pointed to the WAN IP?

thanks,
Oli.
OliHall (TechnicalUser) (OP)
11 Oct 12 7:18
I have found the problem which is causing this, and I have found a solution, but it is a bodge and this raises a new question:

The reason for my one way audio i.e. remote phone (vpn) not being able to hear my local phones, is due to the missing router/gateway IP address in the local phones' config.

The remote phone will allow me to set the 'remote' router IP correctly and will forward rtsp packets to the local phones as confirmed by wireshark.
The local phones will not forward rtsp packets back to the remote phone as confirmed by wireshark because they have no 'local' router IP.

The problem is that it appears to be impossible to set a router/gateway IP address in the local phones. Whenever I go into the network config of a local phone and set a router IP, the phone will restart once, and say "no connection/ack" and then will restart a second time and will connect, but when you go back into the network config, the router IP will again be set at 0.0.0.0

I have found a work around which allows you to set a router IP in the local phone. If I set 'same lan as mfim'='no' in the local phone, and then set the router IP, it will persist through the restart and does connect to the MFIM. When checking the rotuer IP after the restart, this is correctly set and the one way audio problem is fixed.

Clearly this is a bodge, as you should not have to set your local phones to 'same lan as MFIM'='no' when they are on the same subnet as the MFIM.

Please can anyone tell me if I am doing anything wrong, and how I can fix this?

I am running 5.5Fc in the MFIM and 1.1Ef in the phones.

thanks,
Oli.

SteveBUK (Instructor)
11 Oct 12 8:01
Hi Gents,

The set up needs to be...
Phones on the far side need to be set as Local but NOT on Same LAN
PGM 102/103 - make a note of the Sequence number of the far side phones.
Then in PGM 132 - type in the router IP Address (Gateway IP) of the router at the far side..

Then there will be two way speech.

Regards
Steve
OliHall (TechnicalUser) (OP)
11 Oct 12 8:34
Hi,

thanks for your reply!

1. Phones on the far side need to be set as Local but NOT on Same LAN - done (this was already correctly set)
2. PGM 102/103 - make a note of the Sequence number of the far side phones - my far side phone is seq 9
3. Then in PGM 132 - type in the router IP Address (Gateway IP) of the router at the far side.. - i have gone to PGM132, seq 9, entered the ip of the remote vpn router into 'router ip address'.

I am still getting one way audio. I didn't try a reset of the MFIM as we are in working hours, please let me know if this is needed.

n.b. the address of the vpn router is not on the same subnet as the MFIM.
The local phones and MFIM are on 10.10.10.X.
The remote vpn router is 192.168.12.1.
The remote phone is 192.168.12.114.

The route to the remote vpn subnet from the phones' subnet is via the default gateway of 10.10.10.1
10.10.10.1 holds a static route that sends all 192.168.x.x traffic to 10.10.10.4
10.10.10.4 is an ip on our ISA server which resides in the phones' subnet and allows traffic between the phone subnet and the protected network and the VPN subnets which are on 192.168.x.x

Due to this, I have also tried entering 10.10.10.1 in step 3 as this is the route that the mfim and the local phones need to use to route to the remote phone.

I know that all the above routing works ok from the MFIM to the remote phone, as external calls work just fine with two way audio, it is just internal calls where local phones can't route to the remote phone.

Do you have any further suggestions?

many thanks,
Oli.
lifesgood (TechnicalUser)
11 Oct 12 12:32
Hi Oli,

Am i correct ins aying you can make an external call ok, but cannot make an internal call due to no speech..?
The reason if this is teh case is that the phones talk to each other directly, so point to point.
In a VPN environment the local phones will need a default gateway whihc is where PGM 132 comes into it..so for all the local IP Phones enter the VPN gateway address of 10.10.10.1

The system sets up the call setup while they speech is direct.
Best regards,
LT
OliHall (TechnicalUser) (OP)
11 Oct 12 13:00
Hi LT,

thanks for your reply, In my post about four above this one, I already established that the problem is with the local phones' missing router IP as you suggest, but I am having trouble setting the router IP in the local phones.

Quote:

The problem is that it appears to be impossible to set a router/gateway IP address in the local phones. Whenever I go into the network config of a local phone and set a router IP, the phone will restart once, and say "no connection/ack" and then will restart a second time and will connect, but when you go back into the network config, the router IP will again be set at 0.0.0.0

I have found a work around which allows you to set a router IP in the local phone. If I set 'same lan as mfim'='no' in the local phone, and then set the router IP, it will persist through the restart and does connect to the MFIM. When checking the rotuer IP after the restart, this is correctly set and the one way audio problem is fixed.

Clearly this is a bodge, as you should not have to set your local phones to 'same lan as MFIM'='no' when they are on the same subnet as the MFIM.

Do you have any suggestion about how to correctly set the local phones' router IP?

many thanks,
Oli.
OliHall (TechnicalUser) (OP)
17 Oct 12 11:52
Hi LT,

This problem is now fuly solved - Thank you LT.
I re-read your suggestion as i misunderstood it first time round.

I went to PGM 102 and wrote down the sequence numbers for all the local phones.
I then went to PGM132 and for each of the local phones' sequence numbers, I set "Router IP Address" as the local router IP.
It is daft that you have to set the local phones' router IP in PGM132 and you can't set it in the handset's network config.

This solved my problem and each of the local phones displays a router IP in their network configuration.
I am now getting two way audio between all local phones and my remote phone.

Thank you very much for everyone's suggestions!

Oli.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close