Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

failure: Sorry,_no_mailbox_here_by_that_name._(#5.1.1)

jgonsalves (TechnicalUser) (OP)
1 Mar 12 5:00
I am using Centos 5.7 and have built a qmail server I started by using LWQ and configured it to use Maildir, I have installed pop3d and user mail boxes to be located at:
/home/popuser/popboxes/mydomain/user/Maildir now I can connect to the mail box from outlook express and I can send out emails. The MX record is correct the spf record is correct and the RDNS is also correct.

My problem is I cannot receive emails to the account I have setup, if I send email from external accounts they bounce back with 4.4.1 errors in the bounce back, when I send emails internally ( send an email from my account to my account I get this error:
 
starting delivery 36: msg 8028525 to local jgonsalves@mydomain 2012-03-01 09:30:56.679247500 status: local 1/10 remote 0/20
2012-03-01 09:30:56.681980500 delivery 36: failure: Sorry,_no_mailbox_here_by_that_name._(#5.1.1)/
2012-03-01 09:30:56.681981500 status: local 0/10 remote 0/20
2012-03-01 09:30:56.684466500 bounce msg 8028525 qp 21405
2012-03-01 09:30:56.684467500 end msg 8028525
2012-03-01 09:30:56.684631500 new msg 8028521
2012-03-01 09:30:56.684632500 info msg 8028521: bytes 2384 from <#@[]> qp 21405 uid 7796
2012-03-01 09:30:56.687378500 starting delivery 37: msg 8028521 to local postmaster@mail1.mydomain
2012-03-01 09:30:56.687379500 status: local 1/10 remote 0/20
2012-03-01 09:30:56.691376500 new msg 8028525
2012-03-01 09:30:56.691377500 info msg 8028525: bytes 2493 from <#@[]> qp 21407 uid 7790
2012-03-01 09:30:56.694265500 starting delivery 38: msg 8028525 to local root@mail1.mydomain
2012-03-01 09:30:56.694266500 status: local 2/10 remote 0/20
2012-03-01 09:30:56.694267500 delivery 37: success: did_0+1+0/qp_21407/
2012-03-01 09:30:56.694267500 status: local 1/10 remote 0/20
2012-03-01 09:30:56.694268500 end msg 8028521

I think my problems is the that smptd has no reference to my mail box but I,m not sure how go about referencing it.

please help me
Noway2 (Programmer)
1 Mar 12 13:29
I am afraid that I am probably not going to be a whole lot of help with a specifically qmail issue, but have you consulted the tutorial (downloadable) "Life with Qmail"? http://www.lifewithqmail.org/

I imagine that there is a mechanism to map the usernames to a valid recipients list.  Specifically look at the section titled 3.3. Multiple host names in the Life With Qmail.  In particular:

Quote:


    rcpthosts, which tells qmail-smtpd to accept mail addressed to these hosts, and
    locals, which tells qmail-send that addresses on these hosts are to be delivered locally.
jgonsalves (TechnicalUser) (OP)
2 Mar 12 7:19
Thanks will have a look at this  

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close