Member Login

Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Subreport Problem.

Subreport Problem.

I would like to create a report that has a subreport.  I would like to use two parameter crosstab queries - 1 for the main report and a 2nd one for the subreport.

First, when I tried to insert a subreport control into the main report the crosstab query fields would not show up in the wizard. I then created a separate report using the 2nd crosstab query. I inserted the second report into the main report.

When I first tried to run the report, I got a pass-through query error. I found a microsoft KB article that had a suggested work around - on the main form_Onload property I inserted the following code:

Private Sub Report_Load()
Me!rptDeptEvalSubReport.Report.RecordSource= "qryDeptEvalSubQuery"
End Sub

Now,when I run the report, the main report will run, but I get the following error relating to the subreport:

         Object doesn't support this property or method.

I'm not sure how to approach this.

Thank you for any suggestions.

RE: Subreport Problem.

I solved my problem.


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close