Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

HTTP Post msxml3.dll error '800c005'

woter324 (TechnicalUser) (OP)
10 Nov 11 8:33
I would have replied to the thread 1281365 but it's closed.

I used that thread to get most of the HTTPPOST code.

There seems to be quite a few posts on this error, but as I am already subscribed here and so many people have helped me on this site, I am sharing here.

I was getting the error:
msxml3.dll error '800c0005' The system cannot locate the resource specified.

Our corporate environment sits behind MS ISA proxy. My web server is IIS 7 on Windows Server 2008 R2. The site consists of two simple asp pages.
I found entering the POST URL straight into the browser, it worked, yet through IIS and my web page, I couldn't even see the external request hitting the proxy. However, on my personal laptop off the corporate network, it worked fine.

After many hours of thinking the code was wrong, something I came across a while ago made me think about setting the proxy using WinHTTP. My IE proxy was already set up correctly so I was able to use the command from the IIS box:

CODE

C:\> netsh winhttp import proxy source=ie

Once I did that, it work straight away.

The other thing I found is that you need "http(s)://" in the URL to post.

MS Reference Article


A little side-tip for google to pick up, you need to use netsh to set the static routes. I found this when configuring Exchange 2010 clustering. It stops the flip-flop between cluster nodes. (Assuming one's network has static routes). On Win2K8 server, it doesn't like the old dos routeadd command.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close