Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

whughesiii (MIS) (OP)
7 Oct 11 17:50
I have a laptop running Windows 7 32-bit Enterprise with BitLocker encryption. I have an HP Photosmart D110 All In One device. Every time I try to install the software, it fails at the same spot. The error is MSI.netdevicemanager01 "Fatal error during installation Module C:\Program Files\HP\DigitalImaging\bin\HPSLPSVC32.DLL failed to register. HRESULT - 2147467259. Contactyour support personnel.

When I look, there is no C:\Program Files\HP\DigitalImaging\bin\HPSLPSVC32.DLL.

I have tried running as administrator, running using psexec, with all start up objects disabled and I even uninstalled the anti-virus software. I am at a loss and am wondering if any one else has seen this or has any ideas. My google searches have not helped one bit.
rclarke250 (TechnicalUser)
7 Oct 11 22:04
have you tried downloading the software from HP? the CD may be damaged.
BadBigBen (MIS)
8 Oct 11 4:52
that is a registry permission problem...

in the RUN BOX, type REGEDIT, opening the regeditor, once open navigate to the following key:

HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/Current Version/SvcHost

now there right click on SvcHost and select permissions, then give Administrators and Users Full Control permission...

REBOOT and try to install the Printer App again...

keep us posted...
 

Ben
"If it works don't fix it! If it doesn't use a sledgehammer..."
How to ask a question, when posting them to a professional forum.
Only ask questions with yes/no answers if you want "yes" or "no"

goombawaho (MIS)
9 Oct 11 8:55
Do what BadBigBen says, but before that I would try doing a full removal of the software and see if there is a removal utility from HP for your model.  You really want to get everything cleaned out and then reboot before attempting to reinstall.

Probably a reg cleaning wouldn't hurt either, so:

0.  Unplug printer from PC and leave unplugged.
1.  Remove software in Add/Remove programs list.  Reboot.
2.  See if there is a utility from HP that can be run.  If so, run it and then reboot.
3.  Do a reg cleaning with CCleaner until no errors found. Reboot
4.  Do what Ben said.  Reboot
5.  Try to install software.

I know it's a lot of restarts, but it's best to start CLEAN.
whughesiii (MIS) (OP)
10 Oct 11 10:08
I suppose I should have mentioned in my first post. I knew I would forget something. I tried changing the permissions on the SVCHOST subkey, but I got an access denied error. When I looked I saw that it was owned by SYSTEM, and I wasn't sure of what would happen if I changed ownership to Administrators. I have not been able to get the HP software installed, but I will look for a utility from HP for removal. And I will look at using CCleaner as well. I will keep you posted. I won't be able to work on the laptop again until Friday.
BadBigBen (MIS)
10 Oct 11 15:50
Owning and permissions are two different pair of shoes...!

e.g System (me) owns a house, now I give all my renters (users) and the housekeeper (administrator) permission to enter the premisses...

so basically put, SYSTEM still owns the KEY but you are just giving the USERS and ADMINS permission to change things... once that is done, you can always take those permissions away again...


 

Ben
"If it works don't fix it! If it doesn't use a sledgehammer..."
How to ask a question, when posting them to a professional forum.
Only ask questions with yes/no answers if you want "yes" or "no"

whughesiii (MIS) (OP)
10 Oct 11 16:03
BigBadBen, I understand that concept of Ownership vs. Permissions. However everytime I tried, I received Access Denied message when trying to set permissions.
BadBigBen (MIS)
11 Oct 11 1:19
OK, I understand now what the problem was...

now on my system, and I never changed the permissions nor the ownership of that kex, the OWNERs are the Administrators (only other option listed is the main-user account, nothing at all about SYSTEM), and permissions are as follows:

Administrators - Full
Users - Full
Main-User - Full
SYSTEM - Full

so in other words, make the Administrators the OWNER of said KEY, and set the permissions accordingly...
 

Ben
"If it works don't fix it! If it doesn't use a sledgehammer..."
How to ask a question, when posting them to a professional forum.
Only ask questions with yes/no answers if you want "yes" or "no"

cdogg (TechnicalUser)
11 Oct 11 1:22
Ownership is required to make those changes (as I'm sure you've realized).

It will not harm Windows to take ownership away from SYSTEM as long as you leave SYSTEM with full control of the key(s) in question.  If you wanted to be extra careful, you could temporarily take ownership.  Disable "inheritable permissions" as well choosing to "copy" the existing ones over.  Elevate Administrators to full control status, save changes, then give ownership back to SYSTEM.

-Carl
"The glass is neither half-full nor half-empty: it's twice as big as it needs to be."

    For this site's posting policies, click here.

whughesiii (MIS) (OP)
12 Oct 11 9:34
Just an update. I was able to successfully install the software on the laptop. Everything is working great. Thanks all for your help!
BadBigBen (MIS)
12 Oct 11 16:42
glad to hear that it is working... mind telling us what fixed it for you?

Ben
"If it works don't fix it! If it doesn't use a sledgehammer..."
How to ask a question, when posting them to a professional forum.
Only ask questions with yes/no answers if you want "yes" or "no"

whughesiii (MIS) (OP)
12 Oct 11 16:53
I had to take ownership of the SVCHOST key, assign full control to administrators and users. Then reboot and voila, success.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close