Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

WinSPM on Windows 7 64bit & US Robotics 5637 Modem - Problem

J1121 (MIS) (OP)
18 Aug 11 14:34
My config is this:
WinSPM on Windows 7 64bit & US Robotics 5637 USB Modem with drivers and firmware downloaded from US Robotics web site.

This modem works fine with Avaya Site Administration for connecting to Definity and so on.  I just can't get it to work for WinSPM (version 9).  What happens is, it dials and seems like it's connecting.  The dialing window goes away like it should right before you get the prompt for your barrier code/password.   But, the window for the barrier code never appears.  It just sits there and the program is more or less unresponsive at that point.  I've waited a little over a minute and finally I just have to use Windows Task Manager to kill WinSPM.   I've tried running WinSPM in 'compatibility mode' on Windows 7 to see if that made any difference and it doesn't.  Any ideas?  Anyone have a USB modem working with WinSPM on Windows 7 64 bit?   If direct connecting via RS232 serial, WinSPM works just fine on this laptop.  It's just the modem that's the problem.
CarGoSki (Programmer)
18 Aug 11 15:34
USB modems probably use high comm port numbers?

SPM uses comm ports 1 through 4.

What comm port is your modem?

J1121 (MIS) (OP)
18 Aug 11 15:39
It's on COM 5.  I can see about changing it and see if that makes any difference.  I'll give it a shot.  
dagwoodsystems (Programmer)
19 Aug 11 0:46
Yeah...crud.  I see this problem too from time to time.  I swear if Magix were still viable, I would rewrite some of the WinSPM code.  It wasn't bad stuff to begin with, but it's clear to me that the group that wrote it were a little on the young side.

For example, if you're doing a backup and you CNTL-TAB switch to another app and then switch back to WinSPM, you lose the "child" window that gives you the backup progress.  Oh there's a workaround alright.  Just minimize WinSPM and move it over to the right of the screen and the child window pops up again.  Stupid.

Is it a "high port com number" problem?  Maybe...but I don't think so.  I'm sure I've seen this issue on COM2 and COM3 as well.  This IS likely a WinSPM issue and that it can be overcome with Windows settings.

If you report back, I promise I'll help find the cause of this.

Tim Alberstein
www.dagwoodsystems.com

J1121 (MIS) (OP)
19 Aug 11 5:59
Ok, I changed the modem settings in Windows so the modem is using COM 2.   I still get the same behaviour.  Works fine with Avaya Site Admin, but does the same thing I originally described when trying to use it with WinSPM.   It looks ok until you're supposed to get the login prompt for the barrier code.  It never appears.
dagwoodsystems (Programmer)
19 Aug 11 6:36
A quick "pot shot" before buckling down further:  Are you running a late version of WinSPM?  You can grab version 9 from http://www.mediafire.com/?mkzmnu1nohk or go through Avaya's portal for the stepwise upgrade.  The copy hosted through mediafile is my own and I know it works (846 downloads and no complaints).  So I'd like to start there.

So you work with the big boys too, huh?  Yesterday I was in Moorpark troubleshooting an old ProLogix.  I'm more of an old-school ProComm Plus guy than an ASA guy, but Site Admin is cool.  It certainly beats those crummy 513 terminals.

Tim Alberstein
www.dagwoodsystems.com

J1121 (MIS) (OP)
19 Aug 11 6:42
I'm using version 9.  The last full version I had was 6, but I have all the patches/upgrades to get to V9.  

Yes, I also deal with the latest Avaya media gateways and so on but also the older Definitys.  I like to use ASA because I save all the connection info there and just click one button to connect.  I also use it for running reports of various types.  Just makes it move convenient.
dagwoodsystems (Programmer)
19 Aug 11 7:11
And smugmug, too?  Are you a photographer?  Sorry for the ramble folks...we'll get to the answer here.  It just that this guy(?) sounds like my kind of people.

Tim Alberstein
www.dagwoodsystems.com

J1121 (MIS) (OP)
19 Aug 11 7:18
Yep.  Nikon D700, Panasonic GH2, Panasonic LX5 in my inventory smile
J1121 (MIS) (OP)
19 Aug 11 8:21
If I don't get SPM working with the modem on this laptop, it's not the end of the world.  I always have a network connection one way or the other and as long as I'm on the network, I can do a remote desktop connection to a XP machine I keep running that has a modem and SPM installed.  I can connect to the systems using that XP machine.  Not as convenient, but it's not too bad and it works fine.
merlinman (Programmer)
19 Aug 11 9:41
I know you mentioned "Compatibility Mode", but the only way I can make WINSPM work on my Windows 7 machine is to set it to be compatible with XP, and I am using the SP3 setting.


 

http://home.comcast.net/~merlinman     -merlinmansblog.blogspot.com

CarGoSki (Programmer)
19 Aug 11 12:06
You can download and install xp mode on win 7 to get winspm working.

http://www.microsoft.com/windows/virtual-pc/download.aspx

J1121 (MIS) (OP)
19 Aug 11 12:17
I've used 'XP Mode' (virtual machine) on Windows 7 before, but I decided not to install it on this one just to be able to use WinSPM with a modem.  It's one of those 'more trouble than it's worth' scenarios.   It's much quicker and easier for me to just do a remote desktop connection to that real XP machine I have that stays online all the time if I really do need to use SPM with a modem (via that real XP machine).  But sure, if I could make SPM work with a modem on my primary system, that would be great.  If I can't get it to work, it's only a slight inconvenience at this point.  It just bugs me that it's not working though.   
Pepperz (Programmer)
16 Oct 11 10:46
Is it as simple as WinSPM just won't run on a 64-bit platform?

CarGoSki (Programmer)
16 Oct 11 13:01
This Dell laptop runs win 7 64 bit and winspm. The trick was to install xp mode.

Not run in xp emulation or compatability mode.. this one > http://www.microsoft.com/windows/virtual-pc/download.aspx

I have also shifted things around a bit on my Dell XP laptop where I now have a more stable modem connection to winspm and even Partner Admin.

I moved the pcmcia card from com 4 to com 2 and the internal modem from com 4 to com 3. The com switcheroo has made a huge difference on the xp box. Go figure.

I may try Partner Admin on the win 7 64 bit box since I have it runing pretty good on the xp box.
 

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close