Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

BobVitter (TechnicalUser) (OP)
22 Jul 11 10:34
Export to Excel worked ok for MSP 2007 but 2010 appears to export all data with an apostrophe as the first character so the fields are all text in Excel. This is a real problem for dates and numeric fields such as % Complete which can not be easily formatted in Excel when defined as a text field. Excel format does not work, the only way to format a cell is to manually remove the apostrophe.  
Helpful Member!  SkipVought (Programmer)
22 Jul 11 12:21


hi,

In Excel, in an EMPTY CELL, Enter a

1

that's the number one.

COPY that cell.

SELECT the DATA in the columns you want to convert from TEXT to NUMBERS (including DATE columns, assuming that your dates strings are structured d/m/yyyy or yyyy/mm/dd)

In the SELECTED DATA, RIGHT-click and select Edit > Paste Special -- Operation: MULTIPLY  This will coerce the conversion.

Please note: if you have also selected EMPTY CELLS, each will contain 0 (numeric zero)  

Skip,

glassesJust traded in my old subtlety...
for a NUANCE!tongue

JulieInMaine (TechnicalUser)
28 Jul 11 15:12
Hi Bob,

I'm not seeing this.  I've exported from Project 2010 SP-1 and the dates appear as date/time.  What export map are you selecting and what version of Excel?
BobVitter (TechnicalUser) (OP)
31 Jul 11 22:19
Excel 2010 and I am using a custom map I created from scratch.  
SkipVought (Programmer)
1 Aug 11 8:19



Bob,

Did you try my suggestion?

Skip,

glassesJust traded in my old subtlety...
for a NUANCE!tongue

SkipVought (Programmer)
1 Aug 11 8:23




You could also try exporting as a .csv and then IMPORTING the .csv file into an existing Excel workbook.

Once you have your IMPORT QueryTable defined, specifying which fields are Text, Numeric and Date, this IMPORT can be accomplished, simply using the REFRESH method.

Skip,

glassesJust traded in my old subtlety...
for a NUANCE!tongue

JulieInMaine (TechnicalUser)
1 Aug 11 14:15
Hi Bob,
Sorry for the delay.  Again, I am not seeing this with Project 2010 and SP-1 with Excel SP-1 installed.

Can you post the details of the custom map?

Julie
BobVitter (TechnicalUser) (OP)
1 Aug 11 21:07
I tried exporting using a standard map "Default Task Information" and I get the same result, all numeric fields are formatted as text but is such a way that they can not be reformatted in Excel short of taking extra steps such as the one Skip recommended above.
The export map specifies the output data type as Text and I can not change that. The real issue is that the output fields have some special character (not an apostrophe) as the lead character so Excel will not reformat the cels.
SkipVought (Programmer)
2 Aug 11 8:12


Quote:

output fields have some special character (not an apostrophe) as the lead character so Excel will not reformat the cels.

Please COPY & PASTE the data from one of these fields here, including the prepended value in question, for analysis purposes.

Skip,

glassesJust traded in my old subtlety...
for a NUANCE!tongue

BobVitter (TechnicalUser) (OP)
2 Aug 11 19:45
I attached the sample Excel spreadsheet
JulieInMaine (TechnicalUser)
3 Aug 11 8:23
When looking at your spreadsheet, I see that the TaskID field is a number stored as text. I can't imagine you are attempting to use that field for calculation.  The duration field and the predecessors field are text due to the text values in the field.

I was able to quickly convert the TaskID to numbers using the error checking option to convert the text to numbers.  

 

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close