Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

bronano (TechnicalUser) (OP)
28 Jun 11 13:05

 How to check if Serial Port ( COM 1) is working properly.
In Device manager there is no yellow sign – all seems O.K.
Check Device properties for  COM 1 – no conflicts , device is working properly.
I've noticed problem when connecting card reader  - card is not recognized.
Please advice me if exist any simple way to check Serial Port COM1 functionality.
 
vacunita (Programmer)
28 Jun 11 14:12
Technically speaking, Windows does not automatically detect hardware plugged into serial ports, like COMs.

You would need to setup the drivers from the add hardware wizard for the device so windows can see and use it.

Do you have drivers for the card reader?
What make and model of card reader is it?
If you connect say a serial mouse to that port can it be used?

 

----------------------------------
Phil AKA Vacunita
----------------------------------
Ignorance is not necessarily Bliss, case in point:
Unknown has caused an Unknown Error on Unknown and must be shutdown to prevent damage to Unknown.

Behind the Web, Tips and Tricks for Web Development.
http://behindtheweb.blogspot.com/
 

rclarke250 (TechnicalUser)
28 Jun 11 15:18
is the serial port configured for the device in question? something like baud 9600 8,n,1  which would translate to 9600 bits per second,8 bit word,no parity bit,and 1 stop bit. May also have settings for flow control. hardware,software, or no flow control. Also check that com1 is associated with serial port one.

Check here for making a loopback plug, and performing the loopback test. http://zone.ni.com/devzone/cda/tut/p/id/3450
bronano (TechnicalUser) (OP)
29 Jun 11 7:10

 Thanks for answers.
My problem is to define what is causing  the problem – Card reader , or COM 1 Port.
I guess Card reader is faulty, but to be sure I need to test it on another computer what I'll do soon.
All settings of COM1 are O.K.
 
edfair (TechnicalUser)
29 Jun 11 13:04
You basically short pins 2&3 on the serial port connection then pull up hyperterm, tell it to use the port and anything you type should show up on the screen.

That covers the transmit and receive.  There are also some handshake issues but if R/W is good you will at least be at a starting point.

Pins 2&3 are on the 5 pin row, middle (3) and the one to the right of it.

Using hyperterm you might be able to get a response back from the card reader if you type in any of the control codes it uses.

The suggestion to use a serial mouse is good, if you have one.
 

Ed Fair
Give the wrong symptoms, get the wrong solutions.

bronano (TechnicalUser) (OP)
1 Jul 11 6:57
Thanks very much for assistance.
Checked programmer on another comp and this one is faulty.
Warmly hope Serial Port ( COM 1) is O.K.- will see.
 
xwb (Programmer)
2 Jul 11 16:11
Is it one of those old PCs that as 2 COM ports?  If so, you could use COM2 instead of COM1.
bronano (TechnicalUser) (OP)
3 Jul 11 6:15
@xwb,
Yes my PC is old one with 2 COM ports.
I'll try what you suggest , thanks a lot  
bronano (TechnicalUser) (OP)
23 Jul 11 7:58

 In mentime bought one USB Serial Port Device and on my big surprise my card reader device works.
Conclusion this device is faulty one, I drawn from test Card reader on another comp and this one was showing two led lights on ,but in normal state these led should be off.
So I change the Standard RS 232 cable, but result was as before- no fix.
Anyhow what rest is my Serial port COM1 who  probably not working properly.
Goggled searching for simple method to test it, but all what I found didn't help me.
I have Null Modem cable, Hyper terminal installed,so please if you could suggest some simple program or whatsoever I can use to test and repair Serial Port COM1 specially because USB Serial port device works very slowly.
Thanks for any assistance  
webrabbit (MIS)
23 Jul 11 10:20
Serial port cards (used to be) very cheap.  If they still are, buy and install one.
bronano (TechnicalUser) (OP)
23 Jul 11 13:34
@webrabbit,
your advice is O.K.This can be solution if  this card is available on the market.
What is confusing me is a fact I can not test this Communication Port and there is no application suitable to do this job.   
edfair (TechnicalUser)
23 Jul 11 14:04
Run hyperterm on com1.

With the null modem cable attached to com1:, on the other end you short together either the pins or socket # 2&3.

If it is pins the numbering is     1 2 3 4 5
                                    6 7 8 9

If it is socker it is     5 4 3 2 1
                           9 8 7 6

A 25 pin/socket connector has the same order from pin 1 except it is 1-13 and 14-25.

You can use a paper clip as the jumper for a socket.

There are also handshake pins that are used with devices but hyperterm, IIRC, will communicate without them being active.

Normal loopback would short 4&5 and 6,8,&20, sometimes just 6&20.

If you will need to test often you might consider getting a 25s or 9s, whichever size the com port will take and permanently make a loopback plug.

Ed Fair
Give the wrong symptoms, get the wrong solutions.

rclarke250 (TechnicalUser)
23 Jul 11 15:26
The link I posted back in June, shows how to create the loopback plug for testing the port, and also the commands and different programs to use to test, using the plug.
bronano (TechnicalUser) (OP)
24 Jul 11 11:22
@edfair,
Thanks for help.
Using Null Modem cable on socket end shorted #2&3>
Run Hyperterminal   , done all as explained , but was unable to type anything in Hiperterminal window.
Try also to transfer file or capture text, but after while received "connection timeout" and at the end "Error limit exceeded"
On the lower left part of the Hyperterminal window is shown as "Connected"
Don't know what to do else.
 
edfair (TechnicalUser)
24 Jul 11 22:40
I don't have a system set up now to look at the hyperterm requirements.  I'll post back tomorrow after I've modified one.

Ed Fair
Give the wrong symptoms, get the wrong solutions.

bronano (TechnicalUser) (OP)
25 Jul 11 7:19
Today I connected my card reader to COM2  hopping if COM 1 is faulty – COM 2 should be O.K.
At the beginning all looks fine, led didn't light, but after start Card reading on COM 2, received message "Error....
Also try with other Card Reader – same result.
All this bring me to conclusion my Serial Card two ports is gone.
Only one thing what I would like to define is to precise what caused this – hardware mater or software- something related to Windows XP SP3 .
 
BadBigBen (MIS)
25 Jul 11 14:39
it also could be just simply that the COM ports are turned off in the BIOS...

check the BIOS if there are any settings concerning the COM Ports...


and yes, COM ports can go faulty, specially on venerable equipment, e.g. ESD damage...

Ben
"If it works don't fix it! If it doesn't use a sledgehammer..."
How to ask a question, when posting them to a professional forum.
Only ask questions with yes/no answers if you want "yes" or "no"

edfair (TechnicalUser)
25 Jul 11 15:22
When you run hyperterm the connected at the bottom left only indicates that there is a com port recognized, it has nothing to do with anything possibly connected on the other side of the chip.

Hyperterm takes keyboard input and puts it out to the com port and takes stuff off the com port and puts it on the display.

It is probable that you got no display on the screen when you shorted 2&3 because the flow control setting was set to hardware and you didn't have the handshake lines connected.  On the test setup it required 4&5 (25 pin connector) to work in hardware handshake but 2&3 worked without the 4/5 jumper while in Xon/Xoff or none.

the test setup:
DELL GX270 COM1:
modem cable > 25p-25p gender changer > null adapter > 232 patch
2&3 shorted on the patch adapter, no other wires inserted
HT set for com1: 2400 N81 no handshake

If you have access to a VOM it might be worth a few minutes to ohm out the end to end connections to insure you are dealing with a null cable with minimal handshaking available.

Ed Fair
Give the wrong symptoms, get the wrong solutions.

bronano (TechnicalUser) (OP)
26 Jul 11 7:23
@edfair,
Thanks for reply.
The flow control setting was set to "none"
I have 9 pin connector and I suppose your advice in previous post was done properly for Loopback test of 9 pin RS 232 connector and Null Modem using Hyperterminal.HT set for com1: 2400 N81 no handshake

If you think that Device report for those two COM (1 and 2) ports could be useful to define what create this problem, I am ready to post it here.
By the way- COM3 on which is connected internal Modem 56k , works fine.
Checked the BIOS but,  didn't find where are settings for Port
 
 
edfair (TechnicalUser)
26 Jul 11 17:07
I was using a 9 to 25 modem cable but 2&3 fit for 9 pin cables too.

There would be a different set of pins for handshaking but doesn't matter with none.

There is a piece of test equipment, a signal level telltale, that lights up LEDs when the signal levels are right.  You could also use a VOM to test the voltage on the Tx signal, pin 3 on a 9 pin connector, looking for -12 w/respect to pin 5. The signals coming out of the UART are 0 & 5 but then go through a conversion to +/- 12v in a line driver.  Low voltage coming out of the driver causes the receiver on the other end to not flip as there is a dead zone generally +/-3v.

Working with 232 can be frustrating, as you now know.

If the com ports were disabled in the BIOS you would not have the connected in HT.

On modern boards the com ports and the line driver/line receivers are built into a do-everything chip. Other than turning off the chips in the BIOS and installing a dual serial card in an ISA slot there isn't much you can do.  And there is a good possibility you don't have ISA slots.

 

Ed Fair
Give the wrong symptoms, get the wrong solutions.

bronano (TechnicalUser) (OP)
27 Jul 11 8:55

Used a VOM to test the voltage on the Tx signal,no voltage.
I 'll repeat search for Ports settings in BIOS again, but do not believe to  found it.
Soon I'll do a test with old mouse , to define finally if this is hardware problem.  
 
bronano (TechnicalUser) (OP)
27 Jul 11 10:26

 Settings in BIOS for On-board Serial Port 1 and 2 are on "AUTO".
Shall I change it , or this is O.K.
edfair (TechnicalUser)
27 Jul 11 12:56
If there is no voltage on TX, the line drive is dead, done, gone. Double check by measuring on 2. Null cables switch wires. If perhaps we got mixed up in what you are using it may be that you don't have a null cable. On a 25 cable 2 is Tx. On a 9 cable 3 is Tx. A null cable on 9 pin port leads to Tx on 2 at the end of the cable.

It is designed for -12 or +12 independent of any setting of the  UART.

The serial mouse is a good idea. Thought maybe it had been suggested before. XP sets mine up at 9600.

Ed Fair
Give the wrong symptoms, get the wrong solutions.

bronano (TechnicalUser) (OP)
28 Jul 11 6:04
@edfair ,
Hi mate,
Your diagnostic is clear.Please let me know re my settings in BIOS for Serial port 1 and 2- are they O.K. or not ?
BadBigBen (MIS)
28 Jul 11 9:24
The setting AUTO should be OK, if there is an option for ENABLE, then use it instead (DISABLE turns them OFF)...

 

Ben
"If it works don't fix it! If it doesn't use a sledgehammer..."
How to ask a question, when posting them to a professional forum.
Only ask questions with yes/no answers if you want "yes" or "no"

bronano (TechnicalUser) (OP)
31 Jul 11 13:21

 Probably Serial ports are gone.
 No changes after BIOS modification
edfair (TechnicalUser)
31 Jul 11 21:13
Time to cripple the on-board serial ports and get a dual serial card. Assume that it has ISA I/O ports. Or failing that, a ATIO card and cripple the unneeded stuff.

Ed Fair
Give the wrong symptoms, get the wrong solutions.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close