INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Wrong sorting order of Date dimension in Excel.

Wrong sorting order of Date dimension in Excel.

(OP)
Hi.
I have a Date/Calendar dimension in my cube. When I open my cube in SSAS cube browser, and then expend year to quarter and then quarter to month, those months labels show in correct order, Jan, Feb, Mar and so on. But when I do the same in Excel 2007, when I am connected to the same cube, the order of those months is alphabetical. I tried to change different sorting options, like "Data source order", "Ascending by Month", "Autosort" and so on, nothing works. It's like Excel completely ignores it's own settings and only sorts alphabetically.
Is there a way to make it work ?
Please, help. It's an urgent project.

Thank you,
Victor.

RE: Wrong sorting order of Date dimension in Excel.

A couple of things you might try:

- Add an additional attribute to the date dimension which is the date formatted as "MM/DD/YYYY".  Excel might pick that up as a date.
- Add a additional column(s) as above but for YYYYMMDD or YYYY and MM and DD, or YYYYMM.  Even if Excel doesn't recognize the date, it will be sorted in the right order.  

The trouble with doing something right the first time is that nobody appreciates how difficult it was - Steven Wright

RE: Wrong sorting order of Date dimension in Excel.

(OP)
Thank you, John.
I already solved this problem. I my Calendar table besides Month Short (Jan, Feb, Mar and so on) I also have a field Month Number (1,2,3 ...). So, in the properties for Month Short I set the KeyColumn as Month Number, and for NameColumn I set Month Short. Works perfectly good.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close