INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

ANT <delete> not working

ANT <delete> not working

(OP)
My ANT script gives output for every section except the <delete>.  It also doesn't really delete the desired directories.  I can't figure this out! >:-[

<?xml version="1.0"?>

<project name="loginExample" default="all" basedir=".">

   <!-- ***************************************************************** -->
   <!-- INITIALIZATION AND CLEANUP                                        -->
   <!-- ***************************************************************** -->


   <!-- Initialization needed for any target -->

   <target name="init">
      <property name="name" value="loginExample" />
      <property name="src.dir" value="src" />
      <property name="lib.dir" value="lib" />
      <property name="etc.dir" value="etc" />
      <property name="build.dir" value="build" />
      <property name="orion.dir" value="C:/orion" />
      <property name="build.compiler" value="modern" />
   </target>


   <!-- Removes all generated files and directories -->

   <target name="clean" depends="init">
      <del dir="${lib.dir}" />
      <del dir="${build.dir}" />
   </target>


   <!-- Prepares any other build target by creating the expected directory
        structure. -->

   <target name="prepare" depends="init">
      <mkdir dir="${lib.dir}" />
      <mkdir dir="${lib.dir}/ejb" />
      <mkdir dir="${lib.dir}/ejb/META-INF" />
      <mkdir dir="${lib.dir}/web" />
      <mkdir dir="${lib.dir}/web/WEB-INF" />
      <mkdir dir="${lib.dir}/web/WEB-INF/classes" />
      <mkdir dir="${lib.dir}/j2ee" />
      <mkdir dir="${lib.dir}/META-INF" />
      <mkdir dir="${build.dir}" />
   </target>

bla, bla, bla, bla,
</project>

RE: ANT <delete> not working

(OP)
Fixed it. smile
Changed <target name="prepare" depends="init">
to
<target name="prepare" depends="clean">

hehehe
¯\(©¿©)/¯  <SHRUG>

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close