INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

VoIP QoS TSHOOT

VoIP QoS TSHOOT

(OP)
Hi, i have a problem where after configuring QoS VoIP on my customers router, he can hear me from  the other side but i cannot hear him, what could lead to this?

These are the configs on my customer's router.
Router#sho conf
Using 4149 out of 196600 bytes
!
! Last configuration change at 18:09:38 UTC Fri May 6 2011
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CCCCCC
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$.2of$sQxNvPdU7g98hU5YRpcwD/
!
no aaa new-model
ip source-route
!
!
!
!
ip cef
ip domain name yourdomain.com
ip name-server X.X.X.X
ip name-server X.X.X.X
multilink bundle-name authenticated
!
!
license udi pid CISCO1841 sn FCZ144992FV
!
!
!
class-map match-all voice-signaling
 match access-group 101
class-map match-all voice-traffic
 match access-group 102
!
!
policy-map qos-voice
 class voice-traffic
    priority percent 10
 class voice-signaling
    bandwidth percent 20
 class class-default
!
!
!
!
!
interface FastEthernet0/0
 description maun internet network
 ip address X.X.X.X 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 speed auto
 full-duplex
!
interface FastEthernet0/1
 description interface to VSAT modem
 ip address X.X.X.X 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 speed auto
 full-duplex
 max-reserved-bandwidth 100
 service-policy output qos-voice
!
interface Serial0/1/0
 no ip address
 shutdown
 clock rate 2000000
!
ip forward-protocol nd
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface FastEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
ip route 0.0.0.0 0.0.0.0 X.X.X.X
!
access-list 1 permit 192.X.X.X 0.0.0.255
access-list 1 permit 192.X.X.X 0.0.0.255
access-list 1 permit 192.X.X.X 0.0.0.255
access-list 102 permit udp any any range 16384 32776
access-list 102 permit udp any any eq 2427
access-list 102 permit udp any any eq 32767
access-list 102 permit udp any any eq 4569
access-list 102 permit udp any any range 5060 5065
!
!

RE: VoIP QoS TSHOOT

Can't say about the router config, but that sounds like a classic firewall issue.
The RTP stream is being allowed in one direction but not the other.
It may be also be due to the firewire transalting ports for STUN, for example port 6004 may be being translated to 10,000. The other end replies to port 10,000 and the receing end goes, "what the hell is port 10,000, I only accept 6000 - 6100."

Actually looking that the router, I don't see an obvious port allowance range for RTP (SIP devices often uses 6000 up).

 

Robert Wilensky:
We've all heard that a million monkeys banging on a million typewriters will eventually reproduce the entire works of Shakespeare. Now, thanks to the Internet, we know this is not true.

 

RE: VoIP QoS TSHOOT

I think the golden rule for easy troubleshooting would be to get it working with a bare-bones config, then add in the security, then add in the QoS, then deploy it.

RE: VoIP QoS TSHOOT

It can also be a routing or codec problem. But as stated above the firewall is you're first point of concern i think.

As VinceWhirlwind suggested, start bare-bone

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close