INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

log4j Websphere

log4j Websphere

(OP)
I can run a java application without a server using eclipse ide and log4j will send emails as setup in a log4j.properties file. When I try to run the application on a Server however the emails are not sent. I have googled this problem all day and can't seem to find a reason behind this. Thanks for any help.

RE: log4j Websphere

I don't understand. A Java application (J2SE) has a main method and is executed standalone. When you talk about a server, is it an application server or a bigger machine? What errors are you getting?

Cheers,
Dian

RE: log4j Websphere

(OP)
In the RAD(Rational Application Development) ide run on eclipse I have a web application project. Yes, there are some classes that have a main method with log.error, log.debug, etc. I can run these java classes standalone in the IDE with out running them on a server and the emails get sent out...no problem...Once I run the entire project on a server(WebSphere Application Server) and also have log statements, the emails do not get sent out. I don't understand the differences...There are no errors being outputted to indicate a problem....Howver the difference in the console output is this...

standalone....(email gets sent to me)

DEBUG 2011-03-10 09:11:33,865 LogClass - Debug is enabled
INFO  2011-03-10 09:11:33,880 LogClass - Info is enabled
WARN  2011-03-10 09:11:33,880 LogClass - Warn
ERROR 2011-03-10 09:11:33,880 LogClass - Error
FATAL 2011-03-10 09:11:34,787 LogClass - Fatal

server.....(No emails are sent)
[3/10/11 9:12:05:369 CST] 00000024 SystemOut     O DEBUG 2011-03-10 09:12:05,369 LogTester - Debug is enabled
[3/10/11 9:12:05:369 CST] 00000024 SystemOut     O INFO  2011-03-10 09:12:05,369 LogTester - Info is enabled
[3/10/11 9:12:05:369 CST] 00000024 SystemOut     O WARN  2011-03-10 09:12:05,369 LogTester - Warn
[3/10/11 9:12:05:369 CST] 00000024 SystemOut     O ERROR 2011-03-10 09:12:05,369 LogTester - Error
[3/10/11 9:12:05:369 CST] 00000024 SystemOut     O FATAL 2011-03-10 09:12:05,369 LogTester - Fatal

RE: log4j Websphere

I get you have in your RAD a test application server like WebSphere Test Environment, JBoss or something like that.

I'd take look at the configuration files, specially the SMTP parameters and the log4j configuration.

Cheers,
Dian

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close