INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Call drops after 20 seconds

Call drops after 20 seconds

(OP)
I have a Cisco Router 2651XM.  It's setup with NAT.  I have a single nat command to forward all ports to my Linksys spa2102.  Tested and works.   From the outside I can easily http into the configuration console of the SPA without any needed ip nat commands.

ip nat inside source static 192.168.xxx.xxx interface FastEthernet0/0

FA0/0 is set to DHCP and connected directly to cable modem and get's a public IP address.
192.168.xxx.xxx is the ip address of the SPA

Also have setup QOS.

I can receive calls without any problems.   Very reliable.  sound quality is top notch.   Can even upload and download without any degradation in sound quality.

The only problem I seem to have is outbound calls last exactly 20 seconds and then the call is silent.  (no incoming data)

I have VYL Media as my voip-sip provider.

Searched the internet all over and it seems others have the same issue.  But can't find any real fix of what causes the problem.

There is an option in the SPA that allows it to send NAT keep alives.   This is set to 10 seconds.

O and if I place the SPA before my router I have no VOIP problems at all.   But if I put the SPA in NAT mode (to allow me to use only one IP address) my 10MBps speed his halted at around 6-8Mbps tops.   If I place it in Switch mode I can get full 10Mbps (but this will require two public IP address).

I would prefer to get the SPA behind my Cisco router.


Any and all help would be welcome.

CCNA, A+, HP Certified Professional

RE: Call drops after 20 seconds

Common causes for this are.

RTP traffic not being detected due to prot translations.
Sometimes your RTP port 600x will get translated by the firewall to 10000 (STUN setting), therefore the one end belives it's RTP stream to have gone silent, so drops the call. See if there is are any disconnect on silience options in the SPA.
Often a firmware upgrade in either device can fix this isssue.

Robert Wilensky:
We've all heard that a million monkeys banging on a million typewriters will eventually reproduce the entire works of Shakespeare. Now, thanks to the Internet, we know this is not true.

 

RE: Call drops after 20 seconds

(OP)
O good point.  I have upgrade the firmware in the SPA and still have the same problem.   Have not changed the firmware on the router.  Will have to see if there is a newer version I can get.

But one other thing I did not note in my first post was that this also happens to my SoftPhone on my PC and to SipDroid on my android phone.   If my phone is using my home network and home router it will also get dropped after 20 seconds.   Same with the computer.   But if I use my Verizon Data to and disconnect wifi on my phone and use the sipdroid on my phone it works without problem.

 

CCNA, A+, HP Certified Professional

RE: Call drops after 20 seconds

(OP)
Update.  I have upgraded the cisco IOS to the latest I could download.   Still same issue.

CCNA, A+, HP Certified Professional

RE: Call drops after 20 seconds

(OP)
Update.    Switched my router noted above for a simple 1711 reset the config in it.   It's now very basic with NAT ability.   Same problem.   I have included the config below.

Current configuration : 978 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface Vlan1
 ip address 192.168.78.2 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Async1
 no ip address
 encapsulation slip
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source list nat interface FastEthernet0 overload
!
ip access-list extended nat
 permit ip any any
!
!
!
!
control-plane
!
!
line con 0
line 1
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
line vty 0 4
 login
!
end

CCNA, A+, HP Certified Professional

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close