Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Statey603 (Programmer) (OP)
21 Dec 10 14:06
We are using the Simple Filter dialog (pfc_w_filtersimple) in PB 11.  When we choose one of the columns and any Operator, the first item in the Value list is a blank row. Also....there is always one items missing from the values list and I noticed that the item always matches the value for this column in the first row of the DW that is being filtered. This problem only happens with 1 row of 12 and is consistently occurring.

I checked the code for the screen that uses the filter and cannot find any code that would remove or filter any of the filter columns.

I was wondering if anyone has seen behavior like this or might have usggestions on how to troubleshoot.

NOTE: I have tried debugging the events and functions for pfc_w_filtersimple and one thing that is a bit perplexing is I never see of_getvalues() get called which is where I believe the filter value list gets created.

If anyone can shed light on how the filter dialog gets its data, that would be awesome.

 
Statey603 (Programmer) (OP)
22 Dec 10 15:33
fyi.............

I figured out what was causing this in case it is any help to others.

The Values list in the Simple Filter dialog was getting a blank row in it if any of the rows from the DW being filtered have a value (for the column selected in the filter dialog) that does NOT match any defined lookups. Null values are handled OK, but having ID values that can't be resolved causes a blank row in the values list.

 
mbalent (Programmer)
24 Dec 10 10:25
Thanks for the info.

Matt

"Nature forges everything on the anvil of time"
www.anvil-of-time.com

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close