INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

COM component error CLSID {E2ED7231-D342-11D3-BC59-0090279AB966}

COM component error CLSID {E2ED7231-D342-11D3-BC59-0090279AB966}

(OP)
Hi,
I'm attempting use DataJunction 7.5 from within C#.

I've made a reference to the DJEngine 7.5 Components Type Library within the Solution Explorer.

I try to create and instantiate the engine using the following syntax:

DJEC.Engine eng = new DJEC.Engine();

When I run the test program, I receive the following error.

Creating an instance of the COM component with CLSID {E2ED7231-D342-11D3-BC59-0090279AB966} from the IClassFactory failed due to the following error: 80004005.

Can anyone explain how I can get around this issue?
Thanks,
MG

RE: COM component error CLSID {E2ED7231-D342-11D3-BC59-0090279AB966}

A couple of questions:
- Are you developing on a 64 bit OS?
- Is your C# project compiled as "AnyCPU"?

A few suggestions:
- If you are on 64 bit Windows and are compiling as "AnyCPU", then the project is looking for a 64 bit COM object.  I don't believe DataJunction is 64 bit.  You should compile your application as "x86".  

- I've seen the 80004005 also occur when there's a permission problem in the registry or in the COM object file itself.

Mirtheil
Certified Pervasive Developer
Certified Pervasive Technician
http://www.mirtheil.com

RE: COM component error CLSID {E2ED7231-D342-11D3-BC59-0090279AB966}

(OP)
I have less knowledge on your question we have window service that run on WIN XP/server OS and i had verified all entry in registry also, this problem starts when we do all new installation on new server(win 2000 server OS) and same issue comes on XP system also.

  

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close