INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

SSAS & SSRS; Excel 2007 Report Action with Parameter

SSAS & SSRS; Excel 2007 Report Action with Parameter

(OP)
Using SSAS & SSRS 2005; MS Excel 2007.

I am attempting to add a Report Action to a cube that passes a parameter to a SSRS report.  I have a Customer dimension with 2 attributes; customer number and customer name.

The action is defined like this:

CODE

Target Type: Attribute Members
Target Object: Customers.Customer Number
Parameters: UrlEscapeFragment( Customers.[Customer Number].CurrentMember.UniqueName )
The SSRS report ATTEMPTS to launch in the web browser; however, the parameter is not being passed correctly to the report.  I expect to pass an integer value only to the report, but part of the actual parameter description is being passed.

Here is the url that is generated by SSAS:  

CODE

http://xxxxx-xxxxxx/ReportServer$Prod/Pages/ReportViewer.aspx?/Apps/TopCust/CustProfile&CustNo=%5bCustomers%5d.%5bCustomer%20Number%5d.%26%5b2780%5d&rs:Command=Render&rs:Renderer=PDF
The "Customers" and "Customer Number" literals are being passed as well as the integer customer number.  All I want is the actual integer customer number.  In this case it is 2780.

RE: SSAS & SSRS; Excel 2007 Report Action with Parameter

Use Name instead of UniqueName.

RE: SSAS & SSRS; Excel 2007 Report Action with Parameter

(OP)
Thanks, RiverGuy.  You are the best!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close