INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

TFTP backup

TFTP backup

(OP)
Hi everyone,

I've not been having any success backing up to a tftp server and am not sure why.  From all that I've read the process seems rather simple, and I'm sure it is, once all of the right configurations are set.

When I open the tftp server window, the ip address of my computer appears, which appears right since I am using my computer as a tftp server.  

When I enter the command "copy running-config tftp" I am prompted to enter a host, which I then enter the ip address of my computer.  There is only one choice for the next prompt, so I just hit enter.  A message is then displayed saying, building configuration.  It's then that I see those dreaded "dots" instead of exclamation points.

For those of you who can do this in your sleep, can you offer some direction here?  I am using a Cisco 2514 router, by the way.

Thanks in advance!  

RE: TFTP backup

First, can you ping the computer from the switch?
Second, if so, please post the output.

/

tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!

RE: TFTP backup

Just to add to Burts post, make sure the TFTP service is running on the computer.


Stubnski

RE: TFTP backup

and..can you ping your tftp server from the router

RE: TFTP backup

Guys...he said, "When I open the tftp server window, the ip address of my computer appears, which appears right since I am using my computer as a tftp server.  "

We can assume that

A.The tftp server is indeed running
B.It's the computer that you ping, not the tftp server, which is what I asked (C'MON, TODD!!!)
C.I am always right
D.He can't ping the computer from his PC
E.Trust me
F.The letter after E.
G.Do I really have to tell you?
H.Jimi Hendrix has been sober for over 39 years.

/

tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!

RE: TFTP backup

Ok..I'm going to claim lack of sleep due to teething baby today.  I don't know what I was reading earlier.
 

RE: TFTP backup

(OP)
Sorry everyone, I've been held over on 12 hour shifts at work this weekend.  If I do not get held over tonight, I'll get the info and post it, otherwise I will have it first thing in the morning.

RE: TFTP backup

Lerdalt,

Why are you teething babies? That's soooo wrong! They aren't chew toys!

Burt,

I. Don't care

OV105,

Turn off your Windows firewall. Also, any other firewall running on your PC that prevents the switch from initiating the tftp data flow.

If you're using Linux, make sure you've created an empty file on your PC for the tftp transfer.

RE: TFTP backup

(OP)
I did turn off the fire wall before attempting the backup.  

Here is the rest of the info...

I am able to ping the router from my PC, but I cannot ping the PC from the router.  The last section I copied from the TFTP server window.

C:\Users\Atlantic>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:
Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

Ping statistics for 192.168.1.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\Users\Atlantic>

***********************************************

Erie# ping 192.168.4.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.4.100, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Erie#

***********************************************

[03-09-2010 08:48:07]
CiscoKits Windows Service started.

[03-09-2010 08:48:07]
CiscoKits Windows Service starting.  Starting TFTP Server.

[03-09-2010 08:48:07]
CiscoKits Windows Service starting.  Loading settings.
 

RE: TFTP backup

If you can't ping your PC from the router, that is the issue you need to fix.

Double check you don't have some firewall running (McAfee personal firewall?) besides the Windows firewall. If you can ping the router but the router can't ping you, that strongly indicates a firewall behavior on the PC.

Without the basic connectivity, there is nothing you can do with the TFTP server itself.

RE: TFTP backup

(OP)
I turned off the fire wall* and tried again, but met with the same results.  Is it possible there is a computer setting or service that would affect an incoming ping?  I'm running Vista 64 bit and I know there are a ton of services, much of which are unnecessary and a number of which are turned off.  

*When I looked at the fire wall, I did notice tftp server is permitted.  Even so, just to be on the safe side of this test, I turned it off.   

RE: TFTP backup

Why are the router and pc in different subnets?

post a sh run from the router and ipconfig /all from the pc.

/

tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!

RE: TFTP backup

Put the PC and router on the same network. Check IPs and masks closely. Once that is working and tftp succeeds, then move the PC to another network and fix the routing.

RE: TFTP backup

(OP)
The laptop I'm using is my personal computer which I take to work, it's not a PC in a SOHO network.  When I am home I connect to my physical router/switch lab and practice, so this accounts for the different subnets.  



 

RE: TFTP backup

So wait, if i just repeat what everybody says, can i get a star?

CCNP

RE: TFTP backup

Now you know my frustration, ISP...

OV105---post a sh run and an ipconfig /all, and describe the topology!

/

tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!

RE: TFTP backup

(OP)
The topology is as easy as it gets, my laptop connected to the router via crossover cable to the console port.  When you get to the ip's configured on the router, omit them as this is a practice lab and I know an ip route is not correct.  

To summarize the situation, I can ping the router from the computer, but I cannot ping the computer from the router.  The TFTP software has been given permission in the fire wall to run, but to be sure I did turn it completely off.  I feel pretty confident that something is either not set, or is set incorrectly, I'm just not sure if the problem is on the router or the computer.

ipconfig /all.....

Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

C:\Users\Atlantic>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : WorkStation-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : cfl.rr.com

Ethernet adapter Bluetooth Network:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth LAN Access Server Driver
   Physical Address. . . . . . . . . : 00-02-72-A1-0D-47
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : cfl.rr.com
   Description . . . . . . . . . . . : Atheros AR5009 802.11a/g/n WiFi Adapter
   Physical Address. . . . . . . . . : 00-23-4E-7D-6B-5C
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::fc31:836:3cc2:26b6%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.4.100(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Wednesday, March 10, 2010 8:51:52 AM
   Lease Expires . . . . . . . . . . : Thursday, March 11, 2010 8:51:52 AM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 234890062
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-00-A0-10-00-23-4E-7D-6B-5C

   DNS Servers . . . . . . . . . . . : 65.32.5.111
                                       65.32.5.112
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
   Physical Address. . . . . . . . . : 00-23-5A-1C-39-5C
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 6:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : cfl.rr.com
   Description . . . . . . . . . . . : isatap.cfl.rr.com
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 02-00-54-55-4E-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e74:2036:fdc:3f57:fe99(Preferred)
   Link-local IPv6 Address . . . . . : fe80::2036:fdc:3f57:fe99%13(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 11:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : 6TO4 Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 13:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{667C3C1E-468F-4FEA-B3BF-8693B970A827}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 14:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{EAE5D64A-0D14-4416-9C4A-C79FB7F0E772}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

C:\Users\Atlantic>
C:\Users\Atlantic>


Router running-config:

Erie#show running-config
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname Erie
!
enable secret 5 $1$7QFC$Jp2j.79gNqw1mcdW3MP8T1
!
username OV105 privilege 15 password ThreeRivers
partition flash 2 8 8
!
ip domain-name test.lab
!
interface Ethernet0
 no ip address
 shutdown
!
interface Ethernet1
 no ip address
 shutdown
!
interface Serial0
 description Erie_State College Link
 ip address 192.168.1.1 255.255.255.0
 no fair-queue
 clockrate 64000
!
interface Serial1
 description Pittsburgh_Monaca Link
 ip address 172.16.20.2 255.255.255.0
!
ip http server
no ip classless
ip route 172.16.10.0 255.255.255.0 Serial1
ip route 172.16.50.0 255.255.255.0 Serial1
logging buffered 51200 warnings
!
line con 0
 exec-timeout 0 0
 password Ocean
 logging synchronous
 login
line aux 0
 password LakeShores
 login
line vty 0 4
 password DeepSea
 login
!
end

Erie#

 

RE: TFTP backup

Your topology should be:

1. The PC connected to the router with a CONSOLE (rollover) cable. This is a serial connection that uses the CONSOLE port on the router and a COM port or USB port with an adapter to get a DB-9 connection for the console cable.

2. Crossover cable connected to the Ethernet interface on the router and PC NIC.

OR

2. Straight-through cable connected to the PC and a switch/hub and another straight-through cable connected to the same switch/hub and then to the router Ethernet port. Your 2514 should have a transceiver to give you the RJ-45 port.

The Ethernet interface should have an IP on it. The PC NIC should have an IP on it.

You use the console connection to configure the router parameters but you use the network connection to transfer the files through TFTP.

Config on the PC:

IP address: 192.168.1.1
Mask: 255.255.255.0
Default Gateway: unnecessary at this time

Config on the router:

Router>enable
Router#configure terminal
Router(config)#hostname TFTPTEST
TFTPTEST(config)#interface ethernet 0
TFTPTEST(config-if)#ip address 192.168.1.2 255.255.255.0
TFTPTEST(config-if)#no shutdown
TFTPTEST(config-if)#end


That's it. The ping will work. (If there is a switch between the router and PC, it'll take 30 seconds before spanning-tree will let traffic flow.)

If you only have the console connection and haven't set up the network connection you can do XMODEM but that is an entirely different process.

 

RE: TFTP backup

there you go burt..he was the first to point out subnet..

We must go always forward, not backward
always up, not down and always twirling twirling towards infinity.
 

RE: TFTP backup

Hi,

The easiest way is; disable your wireless nic and use the wired connection on your computer and follow Cluebird's instruction above.

Remove the preferred ip address because it is not on network 192.168.1.0, so your router wont see it since it does not have a route or gateway to network 192.168.4.0


Quote:



Wireless LAN adapter Wireless Network Connection:   Connection-specific DNS Suffix  . : cfl.rr.com   Description . . . . . . . . . . . : Atheros AR5009 802.11a/g/n WiFi Adapter   Physical Address. . . . . . . . . : 00-23-4E-7D-6B-5C   DHCP Enabled. . . . . . . . . . . : Yes   Autoconfiguration Enabled . . . . : Yes   Link-local IPv6 Address . . . . . : fe80::fc31:836:3cc2:26b6%11(Preferred)   IPv4 Address. . . . . . . . . . . : 192.168.4.100(Preferred)   Subnet Mask . . . . . . . . . . . : 255.255.255.0   Lease Obtained. . . . . . . . . . : Wednesday, March 10, 2010 8:51:52 AM   Lease Expires . . . . . . . . . . : Thursday, March 11, 2010 8:51:52 AM   Default Gateway . . . . . . . . . : 192.168.1.1   DHCP Server . . . . . . . . . . . : 192.168.1.1   DHCPv6 IAID . . . . . . . . . . . : 234890062   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-00-A0-10-00-23-4E-7D-6B-5C

RE: TFTP backup

(OP)
I made the connection about the "topology" (no pun intended) and have committed it to memory.

Figuratively speaking, I should have listenend to that little voice on my shoulder that kept telling me to make a network connection between the PC and router ethernet.  In all that I read, nowhere was it mentioned that a connection between PC and router ethernet was necessary, so it kind of got pushed in the background.  This, too, has been committed to memory.

The fire wall was already disabled, so I then disabled the wireless connection.  I configured both, the router and PC, according to your instructions and you are correct, because I am now able to ping between the two devices (see below.)
 
   Ping from router to PC:

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/12 ms


     The results of the backup to tftp:

TFTPTEST#copy running-config tftp
Remote host []? 192.168.1.1
Name of configuration file to write [tftptest-confg]?
Write file tftptest-confg on host 192.168.1.1? [confirm]
Building configuration...

The result is:  Writing tftptest-confg ..... [Failed]


     In the tftp server windown I see:

[03-11-2010 09:48:20]
CiscoKits Windows Service starting.  Loading settings.

[03-11-2010 09:34:13]
CiscoKits Windows Service started.

[03-11-2010 09:34:13]
CiscoKits Windows Service starting.  Starting TFTP Server.

[03-11-2010 09:34:13]
CiscoKits Windows Service starting.  Loading settings.

Hearing that little voice on my shoulder (once again, figuratively) I shutdown this tftp server and opened a different tftp server program that I also have on my computer.  No, both have never been open at the same time.

This is the message I received when I attempted another backup.

TFTPTEST#copy running-config tftp
Remote host []? 192.168.1.1
Name of configuration file to write [tftptest-confg]?
Write file tftptest-confg on host 192.168.1.1? [confirm]
Building configuration...

Writing tftptest-confg
TFTP: error code 2 received - Access violation
 [Failed]
TFTPTEST#

Connection received from 192.168.1.2 on port 345 [11/03 11:06:37.918]
Write request for file <tftptest-confg>. Mode octet [11/03 11:06:37.918]
File <tftptest-confg> : error 5 in system call CreateFile Access is denied. [11/03 11:06:37.918]

The log that was generated has both good and bad news.  The good, of course, is the router is now communicating with the tftp software.  The bad is the denial of access.  

I'm not sure if it's a PC configuration or tftp setting.  I've not changed any vlaues since installing the tftp software and I've seen nothing to suggest that I should.

Next step?











 

RE: TFTP backup

Most tftp servers have a setting to "send and receive" files, with send only being the default. Make sure your tftp server allows both.

SolarWinds TFTP works.

RE: TFTP backup

(OP)
GOT IT!!  When I changed the TFTP window setting, Allow "\"As virtual root, and then stopped and started the server again the backup worked.  Cripes, I sure hope the only question Cisco asks about tftp on the test is what port it runs on, otherwise I'll be in trouble!  To be on the safe side, I think I'll do some more research on tftp settings.

I also enabled the fire wall and tried the backup and it worked, so I know the fire wall will not interfere with further backups.

From this experience, it is abundantly more clear that whenever I use my laptop to connect into my lab or, when the time comes, a client's system, I'm going to have to configure the PC's IP to match the network I'm working in.  Where was that little voice when I began this project?  

RE: TFTP backup

(OP)
Oh and let me not forget...

MUCH THANKS!!!!

RE: TFTP backup

tftpd32--Cisco professional's tool.

CCNP

RE: TFTP backup

(OP)
That's what I used and will use from now on.

RE: TFTP backup

Is the pc 192.168.1.1, and the router .2? Usually, people set it up as the router=.1, pc=.2

But that makes no difference, unless the router is .1, and you are specifying the tftp server as being .1

According to your tftp logs, that is not the case, I would imagine...

"File <tftptest-confg> : error 5 in system call CreateFile Access is denied. [11/03 11:06:37.918]"---this is definitely a tftp permissions or related setting,perhaps like Clue mentioned. The tftp server clearly sees the request for the name you gave the config file in the router, so they are indeed communicating back AND forth.

Definitely a TFTP server setting.

I always use this one---it's free, and has never failed me at MANY many many tftp transfers...just set the root directory, which defaults to wherever the tftp.exe is started from---start it, set the directory, minimize, and transfer.

http://tftpd32.jounin.net/tftpd32_download.html

/

tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!

RE: TFTP backup

BTW, connecting via console cable---the only way to tftp via the console is from rommon, but the 2500 series do not support that (started in the day of the 2600's), so you'd be left with xmodem/zmodem. You could set the config register (rommon1>o/r 0x3922) to 3922 for BAUD of 115,200, which is much faster than 9600, and twice as fast as ISDN (It Still Does Nothing or I Still Don't Know)...lol

/  

tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!

RE: TFTP backup

(OP)
I setup the PC as .1 and the router as .2

I thought it was a tftp setting, just didn't know which one.  

I'll repeat this exercise a few times until I feel comfortable with the trial and error process I went through and the invaluable input from all of you.

One step closer!

RE: TFTP backup

Yeah---we all posted at the same time...lol

Try tftp32d as myself and ISP have suggested.

/

tim@tim-laptop ~ $ sudo apt-get install windows
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package windows...Thank Goodness!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close