INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

5250 emulation connection timing out

5250 emulation connection timing out

(OP)
Hi,

We are using Netsoft's 5250 emulation software to access some AS400 machines via TCP/IP. The problem we have is for one particular machine it always times out, say, after 60 mins of inactivity. However, for other machines they stay connected until we terminate the session. We have recently been given access to another machine which again has no timeout problems. As far as I know, no changes have been made to the firewall to exclude this new machine for checking for inactivity or know of any settings for the existing machines.

Before the firewall, I think it is a Cisco ASA 5505, was installed we had no problems with any machine timing out.

I have searched the net for solutions and found some for IBMs software but none for Netsoft. Some mentioned changing a reg entry to set the keepalive setting to 120000 milliseconds or something but this is only affecting one machine.

Therefore, any ideas for checks to look for would be much appreciated.


Thanks & regards
PS I also posted this in the Cisco PIX forum but have had no response as yet :(

RE: 5250 emulation connection timing out

ok,, so when you say "time-out",, do you mean  drops the session completely,, or signs off the session??  Does it "loose",, communications, or does it just close the session??

RE: 5250 emulation connection timing out

(OP)
Hi jmd0252. Thanks for responding.

The sessions drop completely. When I sign on again the session says I have another session already active.

Regards

RE: 5250 emulation connection timing out

so communication drops, and the sessions stays active... isn't that interesting.. does it revert to a signon screen or just black,, like someone pulled the wire loose,, so to speak?  

RE: 5250 emulation connection timing out

(OP)
Hi jmd0252,

Interesting is not the word that springs to mind - more like annoying!

The screen goes black with the II (Input inhibited) light on and you have to click on session > disconnect to terminate it and then connect again.

The strange thing is we can connect to up to four different AS400 connections and this problem only occurs on the others stay up with no probs.

Thanks & regards

RE: 5250 emulation connection timing out

OK,, THERE IS A "TIME-OUT:, option, sysval. while I would consider it to be global,, it might be workstation id specific. And I assume it is always the same workstation id, that drops off for you.  

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close