INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Why Wordpress Navigation NOT showing up?

Why Wordpress Navigation NOT showing up?

(OP)
Hi. Thanks in advance for your help. The strangest thing is happening. I can see my wordpress page fine (including my navigation menu) on my computer but cannot see it on other people's computers. The entire wordpress is hosted at Go Daddy, and all the files are ON THEIR SERVER. For some reason, though, I only can see the navigation on MY COMPUTER! I "thought" this was a javascript issue but I tested my website with a friends that uses the same templete, and his shows up fine on other people's computers. I DID change some code, making navigation bars smaller and changed background image. THE ONLY thing I am thinking: do I need to use exact words like nav_bg.png? Cos I changed the word to nav_bg_WORKINGSM.png (and yes I changed links in code). It's just weird I can see it fine on my computer and no one else can. IDEAS? Thanks much!

RE: Why Wordpress Navigation NOT showing up?

that's a cacheing issue most probably.  if you empty the cache on your computer you probably won't be able to see the stuff either.

please provide a link to the site in question if you wish us to help further.  

RE: Why Wordpress Navigation NOT showing up?

(OP)
Thanks jpadie. I checked and it is not a cache issue, but thanks for tipping me to that possibility.  It is weird that the site shows up on some computers and not others - side by side another site built with same templete. So I must have done "something" to MY code, I just don't know. I feel odd about posting the URL here because we are living in a world of google and once the site is up and running it will be forever linked to this page (and my attempts at getting site to work) :)  
Thanks and cheers.

RE: Why Wordpress Navigation NOT showing up?

you can always post the url here and when it's working ask the mods to remove the url.  they will be only too happy to do so.
 

RE: Why Wordpress Navigation NOT showing up?

(OP)
Jpadie, Great, thanks! It's www.modernrhymes.com but I think I need to send you the code (css styles I changed?), yes? If so, I can copy all my code and also reinstall and copy the original and post both somewhere (ideas?).  I am very curious what the problem could be. (Again, does it have anything to do with the fact wordpress needs basic words like "nav_bg.png" and NOT "nav_bg_SMALLIMAGE.png" or it trips up system on some people's computers? Does mac see differently than PC?) I can't figure this out... I have tried every trouble shoot (except changing back to words like nav_bg.png) with only my very basic knowledge... thanks.

RE: Why Wordpress Navigation NOT showing up?

Quote:


 does it have anything to do with the fact wordpress needs basic words like "nav_bg.png" and NOT "nav_bg_SMALLIMAGE.png"

no.  so long as the changes are made everywhere and consistently.

i will take a look later this evening.

RE: Why Wordpress Navigation NOT showing up?

a quick check shows the site working (assumedly) correctly on each of safari and firefox for windows and macs.

i cannot test ie as i don't use windows (the above tests are conducted simply by switching the User Agent, not truly testing under windows).

however nothing looks crazy in your css.  It validates (albeit with warnings). It is just possible that the floated elements are causing problems with some browsers.  you might want to fix the widths on the .header.logo, .header.contact.phone, .header.contact.mail, .header.contact.aim and .header.contact.twitter floats.

to get the other warnings run the css through the validator at http://jigsaw.w3.org/css-validator/validator

my suspicion is that this is now a browser issue.  are you using a browser different to those used by those people reporting that the site works correctly?  if so please let us know what your browser is and also post a screenshot of your site NOT working so we can see the difference.

RE: Why Wordpress Navigation NOT showing up?

(OP)
wow, thanks. I have emailed my friend to see if she uses IE. yes the "navigation" should say "About" "Watch" "Read" "Contact" - there's 8 tabs on left. I will be back when I can find out more and/or get those screenshots. thank you!!

RE: Why Wordpress Navigation NOT showing up?

(OP)
PS - admittedly I am still a bit confused about how "my" code is different from my friend using same wordpress theme when his shows up on IE and not mine (if this is the problem)... I will be back...

RE: Why Wordpress Navigation NOT showing up?

(OP)
Hi Jpadie - good day.

I just went to my friend's computer. It does appear to be a IE browser issue BUT it is still specific to MY code as other themes are showing up fine. For instance my site does not work in IE but all the others do including this one as example. http://dev.clarklab.net/wp/

I took screenshot but I have no idea how to save it on IE - i was just able to print it out. It looks EXACTLY like mine does EXCEPT the whole side navigation area is completely missing (just the purple background). As you see on Safari, there are supposed to be 8 tabs with different info (About, Watch, Read, Contact, Store, etc).

I googled and found someone answering a question about disappearing sidebar in IE he said the following. I am trying to google anything I can to figure out what could be going on. Does this have anything to do with it? Meanwhile, I will try to scan the screenshot. Also, should I copy all my CSS style code and then copy the original -- and would that help you by seeing what I changed? Thanks.

Here's what that guy said. Forgive if this is offbase-trying here.
*****

This actually looks to be a CSS problem. While most browsers wouldn't pitch a fit at the sidebar's margin-left: 545px; IE does.

Both your content and sidebar div's need to be floated left for this to work right and you should use an empty div after them with a clear:both; property.

So add this to both your #content and #sidebar styles:

float: left;

And then add this little line just before your #footer div

'<div style="clear: both;"></div>'
******

RE: Why Wordpress Navigation NOT showing up?

yes.  this looks and smells like a css problem.  but i think there are better solutions to the IE box model float problem.

try adding this to your content class definition in your css file

CODE

overflow-y:hidden;

 

RE: Why Wordpress Navigation NOT showing up?

(OP)
okay. great. but, where do I add it exactly?
here are the options where "content" is
.content{background:#9999FF; font-size:12px; line-height:18px;}
.content .panelContainer p{margin-bottom:10px;}
.content .panelContainer a{color:#28AACC;}
.content .panelContainer a:hover{color:#334957;}


and I did post the whole stylesheet now at http://modernrhymes.com/stylesheetCurrent.html

RE: Why Wordpress Navigation NOT showing up?

my suggestion is

CODE

.content{background:#9999FF; font-size:12px; line-height:18px;overflow-y:hidden;}

but i have not modelled your site, so this is best guess based on a quick analysis with firebug.

RE: Why Wordpress Navigation NOT showing up?

(OP)
hey thanks again. Still not working. I checked on a PC with IE and refreshed page. still not showing up. but thank you for your help! any other ideas I am here. have a nice weekend.

RE: Why Wordpress Navigation NOT showing up?

(OP)
Hi jpadie, just want to give an update. thank you for helping me troubleshoot. someone on the wordpress blog figured out that I had a line <strong> in my post that - since I did not close it - was the culprit in making all the posts/navigation disappear in IE! go figure ! but I am happy it is solved and thank you for your help. hope you are having a nice day.  

RE: Why Wordpress Navigation NOT showing up?

there you go!  

the w3c validator is an excellent place to start html debugging.  

RE: Why Wordpress Navigation NOT showing up?

(OP)
another great tip- thanks!  

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close