INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Report Builder 2.1 & Oracle 9i or 10g

Report Builder 2.1 & Oracle 9i or 10g

(OP)
Hi,

I have an application that has as a Back End data base Oracle.

The application use RB as the reporting tool.

I only have RB 2.1 installed (besides the app and Oracle engine)

My first question is, how do I connect to the Oracle DB so I can access the tables to build queries?

Thanks in advance.
 

RE: Report Builder 2.1 & Oracle 9i or 10g

You need to configure ONE copy of sql.ini ( which must be in your path) to use native Gupta connectivity to talk to Oracle.
The references in sql.ini must be the same as the ones in tnsnames.ora, or vica versa.
 I can get you a copy of this - but I'm not sure how to get it to you.
Do you have a copy of sqltalk.exe ? which is a quick and easy way to see if you have connectivity, ready for RB.
Have you ever had any reports working and they have stopped, or is this starting reports from scratch ?
Come back if you dont have a copy of sql.ini or need help configuring it & we'll figure something out.

RE: Report Builder 2.1 & Oracle 9i or 10g

(OP)
Thanks Steve.

I already modified the sql.ini and now I see the Oracle DBs.

The problem I am having right now is that when double click on a database, it never shows the tables.

Regards,

RE: Report Builder 2.1 & Oracle 9i or 10g

Most likely that your userid does not have SELECT rights to the tables, and/or the tables do not have PUBLIC SYNONYMS created.
Either:
- Log onto the database as the user who created the tables ( i.e. the table owner )
- or , get the owner or a user with DBA rights to grant SELECT rights on the tables to PUBLIC, and also create PUBLIC SYNONYMS.

RE: Report Builder 2.1 & Oracle 9i or 10g

(OP)
Thanks Steve,

I have no problem is I define the DB with ODBC.

With this info, do you still think is a matter of permissions?

Regards,

RE: Report Builder 2.1 & Oracle 9i or 10g


You'd have to try it.
I have never used ODBC with Oracle, as Gupta provide a native router to communicate with Oracle, so there is no ODBC overhead ( and there is one ! ODBC acts like a restrictive funnel - your queries will be much faster using the Gupta router) .

I recommend changing your sql.ini to use the native Gupta to Oracle router.

In connecting to ORACLE using the native router, your SQL.INI should be configured the following way:

remotedbname=myORA,@myORAINST

so your sql.ini should look something like:

[win32client.dll]
comdll=sqlora32

[oragtwy]
remotedbname=imsdevo,@imsdevo

of course, 'imsdevo' needs to be replaced with your dB name, and '@imsdevo' needs to be the same as the dB reference in TNSNAMES.ORA.

The Gupta router is called sqlora32.dll and (in theory) is installed when you install RB.

Tip:  Make sure you only have ONE sql.ini file and ONE tnsnames.ora file. - Just rename your old ones if you change anything so you can go back to them.

Come back if this doesn't work.

I am a Gupta / Centura / SQLBase AP, available for permanent or long term contract work in UK, Australia, NZ or USA.
See me at: http://www.linkedin.com/in/sleighton

RE: Report Builder 2.1 & Oracle 9i or 10g

(OP)
I have the ini file exactly as you say.

I am including the sql.ini for your review.

I have more than one Oracle Schema as you can see.

Regards,
==================================================
[dbnt1sv]
servername=Server1,sqlapipe
dbname=ISLAND,sqlapipe
centurydefaultmode=1
dbdir=C:\PROGRA~1\Centura
dbname=fbdata,sqlapipe

[dbnt1sv.dll]
comdll=sqlapipe

[dbnt1sv.apipe]
;debug=15,dbntsrv.dbg

[win32client]
clientname=Win32Client

[win32client.dll]
comdll=sqlapipe
comdll=sqlora32
comdll=sqlodb32
;comdll=sqlwsspx
;comdll=sqlntnbi
;comdll=sqlws32

[win32client.apipe]
;debug=15,client.dbg
[win32client.wsspx]
;
[win32client.ntnbi]
;
[win32client.ws32]
;
[odbcrtr]
remotedbname=fbdata,mcfbdata

[oragtwy]
remotedbname=FBDATA,@FBV8
substitute=SYSSQL.,
longbuffer=32760
maperror=ON
remotedbname=FBTRAINA,@FBV8
remotedbname=FBTRAINB,@FBV8
remotedbname=FBTRAINC,@FBV8
remotedbname=FBTRAIND,@FBV8
remotedbname=FBTRAINE,@FBV8
remotedbname=FBTRAINF,@FBV8
===========================================
 

RE: Report Builder 2.1 & Oracle 9i or 10g

Looks Ok.
If you choose not to use ODBC, then you can trim this ini file down even further - in fact you should try it , just to be sure you're are using the Gupta router :

Close ReportBuilder.

- comment out the entire [dbnt1sv] section ( this is for one user SQLBase )
- comment out [dbnt1sv.dll] section
- comment out 'comdll=sqlodb32' in the [win32client.dll] section
- comment out the [odbcrtr] section
( then SAVE).

You should have SQLTalk.exe in the same directory as RB ( this is repbinn.exe, where nn is your version of RB eg repbi15.exe ).
 
SQLTALK.exe is a really quick way of seeing if you have good connectivity to Oracle - if you start it, then try and connect by typing 'CONNECT FBDATA username/password;' exactly as I have written, including the semi-colon, excluding the quotes. Run this command and it will say 'Connected to FBDATA'.  This will prove you have good Gupta to Oracle connectivity with no ODBC.   RB will work fine then. But you will still need permissions setting on your dB, or logon as the table owner.
 

I am a Gupta / Centura / SQLBase AP, available for permanent or long term contract work in UK, Australia, NZ or USA.
See me at: http://www.linkedin.com/in/sleighton

RE: Report Builder 2.1 & Oracle 9i or 10g

(OP)
Thanks Steve,

On the RB install folder I do not have SQLTALK installed.

It was installed by the application I am using, so it is installed on other directory.

I copied from the application folder to the RB folder the SQLTALK.exe and other dlls that it was requiring.

SQLTALK start but fail to connect issuing following error lines in FAIL.SQL file:

7.6.1 M (1 Client)  --  2009-09-06-23.52.23.047000
03703 Missing configuration file entry

      Reason: Cannot find the configuration file entry [category] in the SQL.INI configuration file.

      Remedy: Verify that the configuration file entry exists and that the proper SQL.INI configuration file is being used.

Regards,

RE: Report Builder 2.1 & Oracle 9i or 10g

Hello ChemaT

This should ( and usually is ) very easy .

Does the application you mention connect Ok still ?  If so , then it is using a different sql.ini to the one RB and SQLTalk is using - and RB should be using the same one as your application, so just rename the  second one ( you can do a global search in windows for duplicate copies.. ). Then try copying RB into the same folder as your application is running from and see any difference.

Failing all this, if you are sure you have only ONE copy of sql.ini in your path,, then you can eMail your full sql.ini to me using the link below, and I'll check it out.

The error message u are getting is a generic one when a section is missing from sql.ini, but usually it gives the exact entry that is missing in the '[category]' part of the message - in this case its not doing that.

Use the link below to get my eMail address, and attach your sql.ini - if you are sure u only have ONE in your entire path ( including network drives ).

 

I am a Gupta / Centura / SQLBase AP, available for permanent or long term contract work in UK, Australia, NZ or USA.
See me at: http://www.linkedin.com/in/sleighton

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close