Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

khan1972 (TechnicalUser) (OP)
14 Jul 09 17:06
In GP8, I have created email alert thru Cards-->System-->Business Alerts (for Employee Extra Fields/Date1).

When tested through 'Test Alert' it works fine, but when I give weekly or daily schedule with different times such as 08:00 or 00:00, nothing happens.

Anyone's solution is highly anticipated. (I expect my favourite, Mr David Musgrave to answer this in his usual simple language)

khan1972 (TechnicalUser) (OP)
17 Jul 09 2:58
Anyone please reply with a solution. I am struck at work.
klewis10367 (MIS)
17 Jul 09 12:43
When you are setting the schedule do you still have Business Alerts open when the schedule is set to run? If so close it fully.
klewis10367 (MIS)
17 Jul 09 12:44
Also, make sure you SQL Server Agent is running, as when you create a scheduled Business Alert it creates a sql job.
khan1972 (TechnicalUser) (OP)
18 Jul 09 3:00
I have been doing as you advised, but the problem still persists.

Is it because I am logged in from client PC (with sa)?
Should I have to login from the server itself?
RobertC22 (MIS)
24 Jul 09 4:08
Several questions.

1. What version of SQL Server are you using SQL 2000, SQL 2005 or SQL 2008?
2. What Edition of SQL Server ? Express, Workgroup, Standard or Enterprise
3. if SQL 2000 is SQL Mail correctly configured?
4. If SQL 2005 are you using SQL Mail or Database Mail?
5. If SQL 2005 and database mail, are you running SQL Server 32 bit, or SQL Server 64 Bit?
6. If SQL 2005 on 32 bit with Database mail, have you replaced the stored procedure necessary (

A. Do you have any other Business Alerts, and are they working?

B. Once you have saved the Business Alert, have you checked the list of jobs in the SQL Agent jobs list?
This should show the scheduled job having a name of your Business Alert ID.
If not present, in the Business Alert maintenance window, select the ID, unmark the "Enable Alert" and SAVE.
Select the ID again, this time makr the "Enable Alert" and SAVE. Recheck the SQL Agent job list (after refreshing it).

Now that the SQL job is present (if not present, have you selected the correct SQL instance?), choose "Start Job" to manually initiate it.

Now check the job history. Does it show has having completed?
Did the run have a status of success or failure?
If failure, extract the sql statement from the job step and manually execute within a Query Analzyer window. What error message is reported?
If success, does the job history description state that an email was sent? If not, then no data matched the criteria entered in the Business Alert condition.


If success, and states email sent, then you should get an email WITH data attachment (if that had being configured in Business Alert), rather than just a test email.
If no email received, you need to check the properties of the SQL Server Agent within Entereprise Manager (if using SQL 2000) has had a mail profile configured.



The TEST ALERT uses the SQL Service credential to send the test email.
A scheduled Business Alert runs under the SQL Agent credentials. The test email may work, yet the scheduled job may not work because of this.
This assumes that the SQL Agent is running (this will not be the case if you are using Express Edition).

------
Robert

 

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close