Member Login

Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Remote File system mount?

Remote File system mount?

Hi to all,

          Pretty simple, just wondering what I need to do to add a Remote file system in my /etc/vfstab.
I have it mounted on the system using a mount command with the /net/<ip address>/files.  I need to attach an entry in the vfstab so that it boots that REMOTE file system.



RE: Remote File system mount?

Add the following entry in /etc/vfstab file:
sun:/data01 - /sun_data01 nfs - yes ro
where sun is the remote server,
      /data01 is the shared FS on sun,
      /sun_data01 is the mount pt. on local server,
      ro is the read-only option

I hope this helps....

RE: Remote File system mount?

NavinB - How are u?  Hope all is well. Thanks for responding.

My problem is that the DARN file system that I mount keeps umounting by it's self.  After a few mins the mounted file system gets umounted.  I tried everything.  I feel that the problem might be that I cannot use the -F ufs option.  When i look at the file system (in /etc/MNTTAB) i see that it is using nfs instead og ufs.  The remote file system is ufs.
I know this should be ok, but y does it keep on detaching itself.



RE: Remote File system mount?

Hi Jon,

The filesystem on local system is going to be ufs only but when u mount it on remote server then it will be mounted as nfs filesystem(network FS).So u should share it as nfs on the local system as:
sun# share -F nfs /data01

I hope this helps.....

RE: Remote File system mount?

Hey navinB,

I tried to do the share command and I get this error message:

"share_nfs: Cannot share remote filesystem: /net/XXXXXX/XXX"

I did
share -F nsf /net/xxxx/xxxxx

/net/xxxxx/xxxxx  is the mounting point of the file system

RE: Remote File system mount?


I think u have got it all wrong.Follow these steps:
local_server#share -F nfs -o ro /data01(this shares /data01)
local_server#dfshares(to see shared resources)

Then login to remote server :

remote_server#mkdir /share_data01
remote_server#mount local_server:/data01 /share_data01(this mounts the shared fs on remote_server)
I hope this helps....

RE: Remote File system mount?

I think YOUR THE MAN!!!!!

It works for now, just hope it doesn't dismount again.  Seems like its a GOOD fix.  Ur the MAN.  
Thanks for all ur help even for the help in the future.


Red Flag This Post

Please let us know here why the post below is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close