INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Application Clipper not run with processor q6600

Application Clipper not run with processor q6600

(OP)
My application clipper 5.3 compiled with blinker not run in new pc with processor q6600 Intel Core quad CPU 2.40 ghz with 3.25 GB Ram. Windows XP SP3. At the run display is black..
Help.me Thanks. Sorry for the english not correct..i'm italian
 

RE: Application Clipper not run with processor q6600

Display extra messages (using "? "I'm starting this or that") to the screen to see how far you are getting, before it actually stops working. And don't clear the screen during startup of the app, so you can see any messages it is already throwing at you.
Are you using extra libs not standard with Clipper, besides the usual Blinker stuff?

What's the Windows version you are using?

HTH
Ath

RE: Application Clipper not run with processor q6600

(OP)
Thanks.
1) The problem is with the library LLIBG  to display image BMP
2) The compiler is exospace (not blinker..sorry)
the lines of source with display black are:
SET VIDEOMODE TO LLG_VIDEO_VGA_640_480_16
GBMPDISP(GBMPLOAD("xy.BMP"),0,0)

3) My file bat for the compiler is
clipper %1 /l
EXOSPACE @PP.TXT LIB LLIBG,CLIPPER,extend,expand,BOXMENU,rcmp_c53,artful,GT_LIB,AHELP5,nocopy,NANFOR MAP=MIO
OPTEDIT c:\ANALISI\WBSF -EXTRAMIN 4096

4) The Windows version is XP Professional SP3
5) My graphic card is NIVIDIA GeForce 9400 GT

Grazie
Ciao
 
 

RE: Application Clipper not run with processor q6600

My guess (never used it) is that LLIBG is incompatible with anything beyond Windows 98, because of the way is accesses the graphics adapter. Depending on the functionality in the app, it should either be replaced or removed.
If it cannot be removed, then you are out of luck, or have to run the app inside a Virtual Machine (VMWare, Virtual PC) running Windows 98 (or maybe even MS-DOS?).
Searching Google, www.xharbour.org, www.harbour-project.org etc. should get you going, but then with a different compiler... Clipper has been un-updated for over 10 years now...

Also, the other extra libs like expand, ahelp5, etc, are not available for newer compilers like Harbour/xHarbour, so that would take quite some work... sad

HTH
TonHu

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close