INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

TERMCAP FILE 4GL PROBLEM

TERMCAP FILE 4GL PROBLEM

(OP)
HI ALL!!! I NEED HELP... I HAVE A APPLICATION THAT WHEN I HAD INFORMIX 10, IT USED TO RUN WITHOUT ANY PROBLEM, BUT NOW I HAVE MIGRATED TO INFORMIX 11.50, , WHEN I PRESS THE F1 FUNCTION BOTTOM (AS A PART OF THE PROGRAM), MY APPLICATION WINDOW  APPEARS WITH  A "6" AROUND IT... I DON'T KNOW IF THE MIGRATION HAD SOMETHING TO DO, I HAVE TRIED TO CHANGE THE TERMCAP FILE BUT NOTHING.... ALSO, I HAVE RE-COMPILED THE FORMS.. TELL ME PLEASE IF I HAVE TO DO ANYTHING EXTRA.

INFORMIX: 11.5
INFORMIX 4GL: 7.5

environment:

TERMCAP=/informix/etc/termcap
TERM=wy50

THANKS & REGARDS FROM MEXICO


 

RE: TERMCAP FILE 4GL PROBLEM

I'n not running your version of Informix, so I can't help you directly, but there are several things you can try:

1)  you might try a different wyse50 termcap entry.  On most unix systems there is a /etc/termcap file.  On my system, here is the exampe in my /etc/termcap:

CODE

#
# w: Wyse (although some are "y" entries instead)
#
# This one is here just in case anyone ever finds a use for it.  Emacs gets
#  confused drawing mode lines when the terminal is in Wyse mode.  --tpm
# The problem with mode lines is that EMACS assume 1) that video attributes
# are in effect to the end of the line, not the end of the display, and 2)
# that the "ce" capability will, on any terminal with the standout glitch,
# turn off standout mode to the end of the line.  Neither are true of the
# Wyse-50 (or Wyse-30) in Wyse mode.  --gh
# This entry comes from Steve Hartwell.  I think he got it from Pyramid's
# UNIX.  It has subsequently been merged with the 4.3BSD entry by Toni
# Guttman, extended by Jeff Anton.  The trick of using protected mode for
# standout mode has been observed to well and truly hang the terminal up,
# so that "feature" of the 4.3BSD entry has not been incorporated.
ye|w50|wyse50|wyse-50|Wyse 50 in Wyse mode:\
    :al=\EE:am:bs:bt=\EI:cd=\EY:ce=\ET:cl=^Z:cm=\E=%+ %+ :co#80:\
    :da:db:dc=\EW:dl=\ER:ei=\Er:im=\Eq:is=\E`\072\200\EC\EDF\E'\E(:\
    :kd=^J:kl=^H:kr=^L:ku=^K:li#24:nd=^L:up=^K:us=\EG8:ue=\EG0:\
    :so=\EG4:se=\EG0:sg#1:sr=\Ej:ho=^^:ug#1:\
    :if=/usr/share/lib/tabset/stdcrt:
# it is not known if the status line works with sysline
yh|w50-s|wyse50-s|Wyse 50 for sysline:\
    :hs:ts=\Ef:fs=\r:ds=\Ef\r:es:tc=w50:
  
Second, you might try using the terminfo database instead of the termcap file.  If the INFORMIXTERM variable is not set, the default variable is termcap. To use terminfo, set this way:

INFORMIXTERM=terminfo

For more information:

man terminfo


BTW, Tek-tips also has an Informix 4GL forum:

http://www.tek-tips.com/threadminder.cfm?pid=876

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close