Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

porkchopexpress (IS/IT--Management) (OP)
4 Sep 08 5:48
I'd like to be able to disconnect idle Citrix sessions but i can't seem to find where to set it I've googled this and the answers that i find are all terminal server settings. Is this where i should create these settings rather than in the Citrix console?

Using PS 4.5

Thanks.
Helpful Member!  Hof (MIS)
4 Sep 08 5:57
Hi
Yes in Presentation Server 4.5 you configure this through Terminal Services configuration in Administrative Tools. Choose Connections and the Properties on the ICA-tcp connection.

Regards
/Hof
porkchopexpress (IS/IT--Management) (OP)
4 Sep 08 7:11
Hi thanks for the reply. Can this also be set in group policy if you have multiple Citrix servers?
Hof (MIS)
4 Sep 08 8:24
Well there are settings for this under Computer configuration - Administrative Templates - Windows components - Terminal Services - Sessions and at the same place under User Configuration.
BUT..
..these settings don't apply to ICA-tcp connections, they only apply to RDP sessions.
I haven't found a way to set the ICA session timeouts through policy. I guess it should be possible if it is controlled by registry values but then a policy template has to be created first.
Regards
/Mats
porkchopexpress (IS/IT--Management) (OP)
4 Sep 08 11:04
Ah ok thanks.
itamisc (TechnicalUser)
5 Sep 08 17:35
Actually the Terminal Service settings timeouts set in group policy do work when set from group policy.

The setting is applied to terminal services not just the ica protocol.

Colin

Your Life and Technology blog
www.yourlifetech.com

porkchopexpress (IS/IT--Management) (OP)
10 Sep 08 11:15
Hmm i set it to 30 minutes in GPO and it shows (greyed out) when i look at the ICA properties but teh sessions don't disconnect. Is there more than one setting that needs to be enabled?
Hof (MIS)
11 Sep 08 9:52
I am not sure. As I said I don't think that the group policy settings will be applied to the ICA-tcp connections.
/Hof
porkchopexpress (IS/IT--Management) (OP)
11 Sep 08 15:39
I've set it manually on the ICA connection and it's working now cheers.
itamisc (TechnicalUser)
12 Sep 08 3:48
Manually setting is a good option if you do not have many servers.

In my environment We have the computer policy, set on the servers to remove disconnected sessions after 10 minutes.

In the user accounts the defaults settings are used for session timeouts.

On the servers they are not set to over ride the policy.

I guess it comes down to the group policy no being applied correctly. Are you applying user and computer policies in the same GP? Have you configure the GP loopback option?

Even though it is a different protocol it still uses terminal servers.

Hope it all works out for you.

Colin

Your Life and Technology blog
www.yourlifetech.com

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close