Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

ASA 5510 site to site VPN with Sonicwall phase 2 error

fillthy (IS/IT--Management)
17 Feb 08 11:13
Hi, still having problems getting this site to site vpn established between a Cisco ASA 5510 and a Sonicwall. Here is all the info:

Config:

ASA Version 8.0(3)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Ethernet0/0
 nameif inside
 security-level 100
 ip address 192.168.30.3 255.255.255.0
!
interface Ethernet0/1
 nameif outside
 security-level 0
 pppoe client vpdn group cppgroup
 ip address 76.65.x.x 255.255.255.255 pppoe
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
same-security-traffic permit intra-interface
access-list outside_1_cryptomap extended permit ip 192.168.30.0 255.255.255.0 any
access-list inside_nat0_outbound extended permit ip 192.168.30.0 255.255.255.0 host 66.35.x.x
access-list 101 extended permit icmp any any echo
access-list 101 extended permit icmp any any echo-reply
access-list 101 extended permit tcp any interface outside eq 3390
access-list 101 extended permit tcp any interface outside eq 3391
access-list 101 extended permit tcp any interface outside eq www
access-list 101 extended permit tcp any interface outside eq pop3
access-list 101 extended permit tcp any interface outside eq smtp
access-list 101 extended permit tcp any interface outside eq telnet
access-list 101 extended permit tcp any interface outside eq https
access-list 101 extended permit tcp any interface outside eq 10904
access-list 101 extended permit tcp any interface outside eq ftp
access-list 101 extended permit tcp any interface outside eq 3389
access-list inside_nat0_outbound_1 extended permit ip 192.168.30.0 255.255.255.0 192.168.79.0 255.255.255.0
access-list outside_1_cryptomap_1 extended permit ip 192.168.30.0 255.255.255.0 192.168.79.0 255.255.255.0
pager lines 24
logging asdm notifications
mtu inside 1500
mtu outside 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-603.bin
no asdm history enable
arp timeout 14400
global (outside) 101 interface
nat (inside) 0 access-list inside_nat0_outbound_1
nat (inside) 101 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3390 192.168.30.181 3390 netmask 255.255.255.255
static (inside,outside) tcp interface 3391 192.168.30.99 3391 netmask 255.255.255.255
static (inside,outside) tcp interface 3389 192.168.30.32 3389 netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.30.6 www netmask 255.255.255.255
static (inside,outside) tcp interface pop3 192.168.30.6 pop3 netmask 255.255.255.255
static (inside,outside) tcp interface smtp 192.168.30.6 smtp netmask 255.255.255.255
static (inside,outside) tcp interface telnet 192.168.30.6 telnet netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.30.6 https netmask 255.255.255.255
static (inside,outside) tcp interface 10904 192.168.30.6 10904 netmask 255.255.255.255
static (inside,outside) tcp interface ftp 192.168.30.99 ftp netmask 255.255.255.255
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 76.65.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 management
http 192.168.30.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-3DES-SHA
crypto map outside_map 1 match address outside_1_cryptomap_1
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 66.35.x.x
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group cppgroup request dialout pppoe
vpdn group cppgroup localname xxx@bellnet.ca
vpdn group cppgroup ppp authentication pap
vpdn username cppgroup password ********* store-local
vpdn username xxx@bellnet.ca password *********
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
tunnel-group 66.35.x.x type ipsec-l2l
tunnel-group 66.35.x.x ipsec-attributes
 pre-shared-key *
 isakmp keepalive disable
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:5677582f690810d3535ccafd6c267f8c
: end
asdm image disk0:/asdm-603.bin
no asdm history enable


The error logs on the ASA:

0h:00m:00s, Bytes xmt: 0, Bytes rcv: 0, Reason: Phase 2 Mismatch
3|Feb 17 2008|07:58:52|713902|||Group = 66.35.x.x, IP = 66.35.x.x, Removing peer from correlator table failed, no match!
3|Feb 17 2008|07:58:52|713902|||Group = 66.35.x.x, IP = 66.35.x.x, QM FSM error (P2 struct &0xd561e9b8, mess id 0xe391e457)!
5|Feb 17 2008|07:58:52|713904|||Group = 66.35.x.x, IP = 66.35.x.x, All IPSec SA proposals found unacceptable!
3|Feb 17 2008|07:58:52|713119|||Group = 66.35.x.x, IP = 66.35.x.x, PHASE 1 COMPLETED
4|Feb 17 2008|07:58:52|713903|||Group = 66.35.x.x, IP = 66.35.x.x, Freeing previously allocated memory for authorization-dn-attributes
4|Feb 17 2008|07:58:52|113019|||Group = 66.35.x.x, Username = 66.35.x.x, IP = 66.35.x.x, Session disconnected. Session Type: IKE, Duration: 0h:00m:00s, Bytes

xmt: 0, Bytes rcv: 0, Reason: Phase 2 Mismatch
3|Feb 17 2008|07:58:52|713902|||Group = 66.35.x.x, IP = 66.35.x.x, Removing peer from correlator table failed, no match!
3|Feb 17 2008|07:58:52|713902|||Group = 66.35.x.x, IP = 66.35.x.x, QM FSM error (P2 struct &0xd561e9b8, mess id 0x9c2072ea)!
5|Feb 17 2008|07:58:52|713904|||Group = 66.35.x.x, IP = 66.35.x.x, All IPSec SA proposals found unacceptable!
3|Feb 17 2008|07:58:51|713119|||Group = 66.35.x.x, IP = 66.35.x.x, PHASE 1 COMPLETED
4|Feb 17 2008|07:58:51|713903|||Group = 66.35.x.x, IP = 66.35.x.x, Freeing previously allocated memory for authorization-dn-attributes
5|Feb 17 2008|07:58:51|111008|||User 'enable_15' executed the 'logging enable' command.
||||||-- Syslog Connection Started --


The Sonicwall logs:

0006-B111-D15C Log (part 4) dumped to email at 2008-02-15 14:48:14
02/15/2008 14:46:54.528 - Warning - VPN IKE -   IKE Responder: IPSec
proposal does not match (Phase 2) -     76.65.x.x, 500 -
66.35.x.x, 500 -    VPN Policy: CPPVPN
02/15/2008 14:47:02.672 - Warning - VPN IKE -   Received packet
retransmission. Drop duplicate packet -         76.65.x.x, 500 -
66.35.x.x, 500 -    VPN Policy: CPPVPN
02/15/2008 14:47:07.016 - Warning - VPN IKE -   Received notify.
NO_PROPOSAL_CHOSEN -    76.65.x.x, 500 -    66.35.x.x, 500 -   
02/15/2008 14:47:12.832 - Warning - VPN IKE -   IKE Responder: ESP Perfect
Forward Secrecy mismatch  -     76.65.x.x, 500 -    66.35.x.x, 500 -
VPN Policy: CPPVPN; Local No PFS; Peer DH Group2;
02/15/2008 14:47:12.832 - Warning - VPN IKE -   IKE Responder: IPSec
proposal does not match (Phase 2) -     76.65.x.x, 500 -
66.35.x.x, 500 -    VPN Policy: CPPVPN
02/15/2008 14:47:20.832 - Warning - VPN IKE -   Received packet
retransmission. Drop duplicate packet -         76.65.x.x, 500 -
66.35.x.x, 500 -    VPN Policy: CPPVPN
02/15/2008 14:47:28.832 - Warning - VPN IKE -   IKE Responder: ESP Perfect
Forward Secrecy mismatch  -     76.65.x.x, 500 -    66.35.x.x, 500 -
VPN Policy: CPPVPN; Local No PFS; Peer DH Group2;
02/15/2008 14:47:28.832 - Warning - VPN IKE -   IKE Responder: IPSec
proposal does not match (Phase 2) -     76.65.x.x, 500 -
66.35.x.x, 500 -    VPN Policy: CPPVPN
02/15/2008 14:47:29.784 - Warning - VPN IKE -   Received notify.
NO_PROPOSAL_CHOSEN -    76.65.x.x, 500 -    66.35.x.x, 500 -   
02/15/2008 14:47:34.592 - Warning - VPN IKE -   IKE Responder: ESP Perfect
Forward Secrecy mismatch  -     76.65.x.x, 500 -    66.35.x.x, 500 -
VPN Policy: CPPVPN; Local No PFS; Peer DH Group2;
02/15/2008 14:47:34.592 - Warning - VPN IKE -   IKE Responder: IPSec
proposal does not match (Phase 2) -     76.65.x.x, 500 -
66.35.x.x, 500 -    VPN Policy: CPPVPN
02/15/2008 14:47:42.576 - Warning - VPN IKE -   Received packet
retransmission. Drop duplicate packet -         76.65.x.x, 500 -
66.35.x.x, 500 -    VPN Policy: CPPVPN

Looks like a Phase 2 problem..What can I try?

Cheers
Phil
NetworkGhost (IS/IT--Management)
17 Feb 08 12:10
Phil,

Contact me when you get a free cycle.


http://www.wr-mem.com

nnnnnnnnnn (TechnicalUser)
17 Feb 08 12:10

  It would be helpful if you could post the details of the vpn policy you have on the sonicwall, specifically gateway, destinations, and crypto suite.  It might also help to list the settings in the IPSec (Phase 2) Proposal section.  I am thinking you probably have the crypto matching, but the destination nets also have to match.  for example if my crypto map acl on side A is host to /24, on side B it must say /24 to host or it will have phase 2 mismatch.

  If you have been changing the vpn settings around you also might just have an old tunnel established that doesn't have proper settings.  You can try clearing the crypto and isakmp security associations on both side than test again.

on the ASA

clear crypto isakmp sa
clear crypto ipsec sa

on the sonicwall

not sure, I would say reboot but certainly the has to be a more elegant way.

cheers
NetworkGhost (IS/IT--Management)
17 Feb 08 12:18
Sorry, wrong Phil. Agree with Hepcatg,

verify crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

and you match addresses

Post a screenshot of the Sonicwall VPN conf if youd like.

http://www.wr-mem.com

fillthy (IS/IT--Management)
17 Feb 08 12:44
Hi thanks for this guys. Here the best I can get for the SonicWall...these are all screens:

http://www.philipcurwen.com/sonicwall.php

Cheers
fillthy (IS/IT--Management)
17 Feb 08 12:59
Hi, if i execute these commands on the 5510 do I need to re-establish anything?

clear crypto isakmp sa
clear crypto ipsec sa

Cheers
Phil
nnnnnnnnnn (TechnicalUser)
17 Feb 08 13:00


here is what I see, and for give me I am not so savvy with sonicwall.  It looks like the error on your sonicwall says the ASA is using perfect forward security group 2 but your sonicwall is not.  Its interesting the Cisco doc says not to set it for this type of setup.  However I would try checking that opthion and selecting group 2.  You will need to clear you security associations than seeif that works.

cheers


02/15/2008 14:47:12.832 - Warning - VPN IKE -   IKE Responder: ESP Perfect
Forward Secrecy mismatch  -     76.65.x.x, 500 -    66.35.x.x, 500 -
VPN Policy: CPPVPN; Local No PFS; Peer DH Group2;
nnnnnnnnnn (TechnicalUser)
17 Feb 08 13:09

Not sure what you mean by re-establish.  Those commands clear active connections in the database.  They don't modify the running configuration.  to re-establish the tunnel you should only have to try to send traffic trough it.


  By the way this is what you are clearing

show crypto ipsec sa
show crypto isakmp sa

cheers
Supergrrover (IS/IT--Management)
17 Feb 08 15:22
On the sonicwall you have PFS disabled, but on the ASA you have in it enabled. These settings have to match on both sides of the tunnel.

Brent
Systems Engineer / Consultant
CCNP, CCSP

fillthy (IS/IT--Management)
17 Feb 08 15:27
Hi, Hepcatg your a genius, I disabled perfect forward secrecy on the ASA and all is fine now. No errors and the tunnel is established..Thanks all for your support
Cheers
Supergrrover (IS/IT--Management)
17 Feb 08 17:08
You would have been done with this a lot faster if you had kept to the original thread you started. The answer was posted 2 days ago. surprise
http://www.tek-tips.com/viewthread.cfm?qid=1451070&page=1

Brent
Systems Engineer / Consultant
CCNP, CCSP

fillthy (IS/IT--Management)
20 Feb 08 13:50
Hi, how do I enable all traffic from the remote network 192.168.79.0 to my LAN? through the VPN. They have IBM tools that cannot connect right now.
Cheers
Phil

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close