Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Serial interface up line protocol down

bsludick (TechnicalUser)
17 Jan 08 10:58
Hope someone can help. I am setting up a lab with three Cisco 2500 routers.I am using DCE DTE crossover cables between the routers. On one link I am getting Serial interface up down. I have checked the keep alive settings are both interfaces are set to 10 sec and encapsulation settings are both set to HDLC. I have the clock rate configured on the DCE end (whch is where I get the up down)and I have changed the crossover cable and still no joy. Any ideas?
chipk (IS/IT--Management)
17 Jan 08 11:07
Post the "show interface" from both sides.
bsludick (TechnicalUser)
17 Jan 08 17:16
Thanks hope this helps.....link is between router 1 and router 3

Router1#sh int serial 1
Serial1 is up, line protocol is down
  Hardware is HD64570
  Description: Link to Router 3
  Internet address is 10.1.2.2/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input never, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     89 packets output, 2819 bytes, 0 underruns
     0 output errors, 0 collisions, 31 interface resets
     0 output buffer failures, 0 output buffers swapped out
     106 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Router1#
***********************************************************
router3#
router3#sh int serial 1
Serial1 is up, line protocol is up
  Hardware is HD64570
  Description: serial link to router 1
  Internet address is 10.1.2.3/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input 00:00:03, output 00:00:04, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/3/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     123 packets input, 3567 bytes, 0 no buffer
     Received 123 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     293 packets output, 42809 bytes, 0 underruns
     0 output errors, 0 collisions, 77 interface resets
     0 output buffer failures, 0 output buffers swapped out
     88 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
router3#
namesrhard2pick (TechnicalUser)
17 Jan 08 18:20
What do you see if you do a show contollers serial X (X being the serial interface you configured the clockrate). You should see DCE cable, clockrate XXXXXX
burtsbees (Programmer)
17 Jan 08 18:42
Post a sh run
Also, do a clear counters

Burt
dtrtel (TechnicalUser)
17 Jan 08 22:39
Sounds like a flaky serial port or connector wire or pin on the receive path to the router reporting line protocal down. The interface up just means it's not shutdown and it's trying to sync up.

There isn't much you can screw up with a lab-based cisco HDLC link.

You mentioned three routers, if all are connecting via serial port HDLC, like R1-R2-R3, troubleshoot the hardware by testing the other connection permutations: R1-R3-R2, or R2-R1-R3. If the problem stays on the same router port, it's got a bad port.

--jeff
http://linkedin.com/in/JeffLynch

burtsbees (Programmer)
17 Jan 08 23:09
Well, I doubt that...
he should still post a sh run from all 3 routers, or at least a sh int from the serial interface of R2 connecting the the up/down from R1.

Burt
dtrtel (TechnicalUser)
17 Jan 08 23:25
Agree, config info always helps. But think about it, Burt. We're only talking about an L2 cisco HDLC sync issue. If he just rips out any attempts at modifying the hdlc parms, which I doubt there are any at this point, the only thing left is L1/Phy. They're not integrated CSU/DSU ports, he's using a DCE-DTE cable connection.

--jeff
http://linkedin.com/in/JeffLynch

chipk (IS/IT--Management)
18 Jan 08 8:30
I'm thinking physical layer problem as well.
lerdalt (MIS)
18 Jan 08 9:21
Out of curiosity, you might want to try changing to ppp encapsulation.  Also, judging by the sh int outputs, looks like there might be a difference in IOS version.  Not that it should make a difference, but it might make things a little easier.

burtsbees (Programmer)
18 Jan 08 9:25
Well, the physical side is up, and line protocol is down. That's one, anyway---we still need the in-between router outputs...

Burt
chipk (IS/IT--Management)
18 Jan 08 9:30
Burt, are you saying a cable problem can't cause up/down status on an interface?
t0mm0 (TechnicalUser)
18 Jan 08 9:51
bsludick , what happened when you followed namesrhard2pick suggestion?

What do you see if you do a show contollers serial X (X being the serial interface you configured the clockrate). You should see DCE cable, clockrate XXXXXX


Also do the logs of R1 outline anything??
burtsbees (Programmer)
18 Jan 08 10:18
No, definitely not, chipk. I know line protocol down could very well be a cable problem I'm going on the fact that he said he has R2 to R3 working, and he took that cable from the working one and put it on the non-working one. I realize it could still be a bent pin on the card, and of course to troubleshoot physical problem, you always (well, if you can) take a known working card/cable and put it into the router in question, or take a known good router and put the serial card/cable in it. Once this is done with no luck, then we can look at other things...configs, ping outputs, etc. Of course we still need a sh run and a positive ID on his topology---judging from the IP addresses on the interfaces, it looks as if int s1, R1 is connected to int s1, R3...wonder where R2 fits in the picture. At first, I thought he was showing one end to the other (and it's still possible he is, in which case the IP addressing is wrong), like R1-----R2-----R3

Burt
kajo (IS/IT--Management)
18 Jan 08 12:37
perhaps he has it more of a triangle.... R1-----R3
                                           \   /
                                            \ /
                                            R2
bsludick (TechnicalUser)
18 Jan 08 13:39
Hi Guys, here is the configs of Router 1 and 3. Yes I do have it in a triangle with Router 1 at the top. It is the link from Router 1 to Router 3 that is giving me the problems.

Router1#
Router1#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
BRI0                   unassigned      YES NVRAM  administratively down down
BRI0:1                 unassigned      YES unset  administratively down down
BRI0:2                 unassigned      YES unset  administratively down down
Ethernet0              192.168.0.20    YES NVRAM  up                    up
Loopback0              10.1.10.2       YES NVRAM  up                    up
Serial0                10.1.1.2        YES NVRAM  up                    up
Serial1                10.1.2.2        YES NVRAM  up                    down
Router1#
-----------------------------
Router1#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
enable password cisco
!
ip subnet-zero
ip dhcp excluded-address 192.168.0.1 192.168.0.101
!
ip dhcp pool lab
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 192.168.0.1
   lease infinite
!
!
!
!
interface Loopback0
 ip address 10.1.10.2 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 192.168.0.20 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 description serial link to router 2
 ip address 10.1.1.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 56000
!
interface Serial1
 description Link to Router 3
 ip address 10.1.2.2 255.255.255.0
 no ip directed-broadcast
 no fair-queue
 clockrate 56000
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
!
banner motd ^C Welcome to the Cisco test lab - router1 ^C
!
line con 0
 password cisco
 login
 transport input none
line aux 0
 password cisco
 login
line vty 0 1
 password cisco
 login
line vty 2 4
 login
!
end

Router1#
-------------------------
Router1#
Router1#sh controllers serial 1
HD unit 1, idb = 0x16CEC8, driver structure at 0x1723B8
buffer size 1524  HD unit 1, V.35 DCE cable, clockrate 56000
cpb = 0x63, eda = 0x2940, cda = 0x2800
RX ring with 16 entries at 0x632800
00 bd_ptr=0x2800 pak=0x175954 ds=0x63C60C status=80 pak_size=0
01 bd_ptr=0x2814 pak=0x175718 ds=0x63BF50 status=80 pak_size=0
02 bd_ptr=0x2828 pak=0x1754DC ds=0x63B894 status=80 pak_size=0
03 bd_ptr=0x283C pak=0x1752A0 ds=0x63B1D8 status=80 pak_size=0
04 bd_ptr=0x2850 pak=0x175064 ds=0x63AB1C status=80 pak_size=0
05 bd_ptr=0x2864 pak=0x174E28 ds=0x63A460 status=80 pak_size=0
06 bd_ptr=0x2878 pak=0x174BEC ds=0x639DA4 status=80 pak_size=0
07 bd_ptr=0x288C pak=0x1749B0 ds=0x6396E8 status=80 pak_size=0
08 bd_ptr=0x28A0 pak=0x174774 ds=0x63902C status=80 pak_size=0
09 bd_ptr=0x28B4 pak=0x174538 ds=0x638970 status=80 pak_size=0
10 bd_ptr=0x28C8 pak=0x1742FC ds=0x6382B4 status=80 pak_size=0
11 bd_ptr=0x28DC pak=0x1740C0 ds=0x637BF8 status=80 pak_size=0
12 bd_ptr=0x28F0 pak=0x173E84 ds=0x63753C status=80 pak_size=0
13 bd_ptr=0x2904 pak=0x173C48 ds=0x636E80 status=80 pak_size=0
14 bd_ptr=0x2918 pak=0x173A0C ds=0x6367C4 status=80 pak_size=0
15 bd_ptr=0x292C pak=0x1737D0 ds=0x636108 status=80 pak_size=0
16 bd_ptr=0x2940 pak=0x173594 ds=0x635A4C status=80 pak_size=0
cpb = 0x63, eda = 0x3014, cda = 0x3014
TX ring with 4 entries at 0x633000
00 bd_ptr=0x3000 pak=0x000000 ds=0x6329E4 status=80 pak_size=22
01 bd_ptr=0x3014 pak=0x000000 ds=0x000000 status=80 pak_size=0
02 bd_ptr=0x3028 pak=0x000000 ds=0x000000 status=80 pak_size=0
03 bd_ptr=0x303C pak=0x000000 ds=0x000000 status=80 pak_size=0
04 bd_ptr=0x3050 pak=0x000000 ds=0x000000 status=80 pak_size=0
0 missed datagrams, 0 overruns
0 bad datagram encapsulations, 0 memory errors
0 transmitter underruns
0 residual bit errors

Router1#
---------------------------------

router3#
router3#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0              192.168.0.22    YES NVRAM  up                    up
Serial0                10.1.3.3        YES manual up                    up
Serial1                10.1.2.3        YES NVRAM  up                    up
router3#
router3#
--------------------------------

router3#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router3
!
enable secret 5 $1$VtbO$CsNywhxYwKoJGQ7OT8oc2/
enable password copper01
!
ip subnet-zero
no ip routing
!
!
!
interface Ethernet0
 ip address 192.168.0.22 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 description serial link to Router 2
 ip address 10.1.3.3 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Serial1
 description serial link to router 1
 ip address 10.1.2.3 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
ip classless
!
!
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

router3#
-----------------------------

router3#sh controllers serial 1
HD unit 1, idb = 0xD5C50, driver structure at 0xDB0D8
buffer size 1524  HD unit 1, V.35 DTE cable
cpb = 0x82, eda = 0x3000, cda = 0x3014
RX ring with 16 entries at 0x823000
00 bd_ptr=0x3000 pak=0x0DD558 ds=0x82A5A4 status=80 pak_size=22
01 bd_ptr=0x3014 pak=0x0DE578 ds=0x82DB84 status=80 pak_size=0
02 bd_ptr=0x3028 pak=0x0DDD68 ds=0x82C094 status=80 pak_size=0
03 bd_ptr=0x303C pak=0x0DE374 ds=0x82D4C8 status=80 pak_size=0
04 bd_ptr=0x3050 pak=0x0DDB64 ds=0x82B9D8 status=80 pak_size=0
05 bd_ptr=0x3064 pak=0x0DD960 ds=0x82B31C status=80 pak_size=0
06 bd_ptr=0x3078 pak=0x0DD75C ds=0x82AC60 status=80 pak_size=0
07 bd_ptr=0x308C pak=0x0DD354 ds=0x829EE8 status=80 pak_size=0
08 bd_ptr=0x30A0 pak=0x0DD150 ds=0x82982C status=80 pak_size=0
09 bd_ptr=0x30B4 pak=0x0DCF4C ds=0x829170 status=80 pak_size=0
10 bd_ptr=0x30C8 pak=0x0DCD48 ds=0x828AB4 status=80 pak_size=0
11 bd_ptr=0x30DC pak=0x0DCB44 ds=0x8283F8 status=80 pak_size=0
12 bd_ptr=0x30F0 pak=0x0DC940 ds=0x827D3C status=80 pak_size=0
13 bd_ptr=0x3104 pak=0x0DC73C ds=0x827680 status=80 pak_size=0
14 bd_ptr=0x3118 pak=0x0DC538 ds=0x826FC4 status=80 pak_size=0
15 bd_ptr=0x312C pak=0x0DC334 ds=0x826908 status=80 pak_size=0
16 bd_ptr=0x3140 pak=0x0DC130 ds=0x82624C status=80 pak_size=0
cpb = 0x82, eda = 0x3800, cda = 0x3800
TX ring with 1 entries at 0x823800
00 bd_ptr=0x3800 pak=0x000000 ds=0x830D08 status=80 pak_size=22
01 bd_ptr=0x3814 pak=0x000000 ds=0x846408 status=80 pak_size=292
0 missed datagrams, 0 overruns
0 bad datagram encapsulations, 0 memory errors
0 transmitter underruns
0 residual bit errors
---------------------------------------
bsludick (TechnicalUser)
18 Jan 08 13:43
Hi Again

The layout is something like this
   R1
  /\
 R2-R3
chipk (IS/IT--Management)
18 Jan 08 14:08
I wonder if the framing or line code is wrong in one of the controller configs?  I don't see that in any of the output.  Usually this would be determined by your provider, but since you're just doing a point-to-point with a crossover, I wonder if that's the problem...
jneiberger (TechnicalUser)
18 Jan 08 14:09
Take the working cable from the R1-R2 connection and move it to the R1-R3 connection and see if it comes up. This just sounds like a bad cable or bad interface to me.
dtrtel (TechnicalUser)
18 Jan 08 14:31
As jneiberber says, yes.

You have these known-good scenarios:

R1(s1)clock ----- R2(sX)
R3(s0)      ----- R2(sY)  (who clocks this?)

So you may have a bad serial port (you proved cables good, yes?) on either:  R1(s0) or R3(s1)

So connect
   R1(s0)DCE-clock <----> R2(sY)DTE-no-clock
If line protocol comes up, R1(s0) is now known good, too. If not, you found your problem with R1(s0).

If line protocol comes up, then connect
   R3(s1)DTE-no-clock <----> R2(sX)DCE-clock
Again, check line protocol, if it comes up, you know R3(s1) is good. Otherwise you have found your problem with R3(s1).

The only IOS config you would do is:
 "clock rate 56000" on the DCE-cabled serial port and
 "no clock rate 56000" on the DTE-cabled serial port
You don't even have to save the config for the tests.

--jeff
http://linkedin.com/in/JeffLynch

namesrhard2pick (TechnicalUser)
18 Jan 08 14:57
I would add clockrate 56000 to your R3 sX interface before swapping cables around. I had a similiar issue and it was corrected by adding a secondary clockrate to my 3rd router. I think dtrtel is on to something.
dtrtel (TechnicalUser)
18 Jan 08 15:07
I would add that you can do this really fast because you don't have to worry about re-configuring to pass IP traffic at this point. Just check the interfaces for "line protocol is up" while consoled-in to the router(s).

--jeff
http://linkedin.com/in/JeffLynch

bsludick (TechnicalUser)
18 Jan 08 17:47
Hi

I am really confused now. Bearing in mind that the link I am having issues with is from R1/serial 1/DCE to R3/serial 1/DTE.
Router 1 was Up down and Router 3 Up  Up.
 
When I moved the cable from a working link (R1/s0 - R2/s0) on router 1 to (R1 / s1 - R2 / s0)guess what... the Serial 1 interface came up up!!! So I am thinking that it must be the cable. Strange as already replaced the cable with a new one.
So I then move the DTE ends across so we have as before:
Router 1 / serial 1 - Router 3 / serial 1
Router 1 / serial 0 - Router 2 /serial 0

and I get the same old error message again:

Router1#sh ip int brief
Interface              IP-Address      OK? Method Status                Protoco
BRI0                   unassigned      YES NVRAM  administratively down down
BRI0:1                 unassigned      YES unset  administratively down down
BRI0:2                 unassigned      YES unset  administratively down down
Ethernet0              192.168.0.20    YES NVRAM  up                    up
Loopback0              10.1.10.2       YES NVRAM  up                    up
Serial0                10.1.1.2        YES NVRAM  up                    up
Serial1                10.1.2.2        YES NVRAM  up                    down
Router1#
jneiberger (TechnicalUser)
18 Jan 08 17:50
If you have a serial link and one side is up/up while the other is up/down, that's almost certainly a bad cable or interface.
brianinms (MIS)
18 Jan 08 18:00
On a side note, those cables are directional meaning the dce has to connect to the dce end and the dte end to the dte end.
bsludick (TechnicalUser)
18 Jan 08 18:15
This is the third time I am changing the cable and the cable worked fine on the link it took if from - so it cannot be the cable.
The interface (Router1/Serial 1) was up up a minute ago After I plugged router 2's Serial 0 DCE cable into the Router 1 Serial 1 interface.
On a Cisco 2500 with two serial interfaces can you configure both as DCE's?
jneiberger (TechnicalUser)
18 Jan 08 18:17
Sure, you can have both interfaces as DCE. It doesn't matter. Just make sure your cables are connected to the right interfaces and you have clocking on your DCE. If you're seeing the same thing with different cables then I think you might have a bad interface. Try mixing things up a bit to see if you can isolate a bad interface. I used to have a lab full of 2500 series routers at my house and I went through this then. One of the routers ended up having a bad interface.
burtsbees (Programmer)
18 Jan 08 19:33
R1 S1 seems bad, eh? At this point, I would configure the R1 as a frame switch so that both serial interfaces have to be DCE, and responsible for the clocking. Sometimes troubleshooting frame relay connections can be more helpful.

Burt
jneiberger (TechnicalUser)
18 Jan 08 19:34
Just to clarify, the DCE/DTE function as it relates to a frame relay switch is entirely unrelated to the DCE/DTE function at the physical layer. They do not correlate in any way.
burtsbees (Programmer)
18 Jan 08 19:53
I was thinking about maybe a deleted status of the pvc.

Burt
dtrtel (TechnicalUser)
18 Jan 08 20:50
<quote>When I moved the cable from a working link (R1/s0 - R2/s0) on router 1 to (R1 / s1 - R2 / s0)guess what... the Serial 1 interface came up up!!! </quote>

STOP! You just proved that R1(s1) is good.

Now you turn your attention to R3(s1). You need to be systematic and take good notes. You need to prove this interface is bad. Connect R3(s1) to any other known good serial port. Check which cable end (DTE or DCE) is connected to which serial port and check the running-config to be sure you set the clockrate on the DCE cabled int. It won't hurt to set a clockrate on a DTE interface, but it DOES matter if you don't set the clockrate on the DCE interface.

<quote>So I am thinking that it must be the cable. Strange as already replaced the cable with a new one. </quote>

WAIT! Premature assumption. If you are certain that it should work as connected and configured, then you can swap the cable with a cable you know works on the other connections.

--jeff
http://linkedin.com/in/JeffLynch

burtsbees (Programmer)
18 Jan 08 21:10
Now I'M confused!
R1 S1 to R3 S1, R1=DCE and R3=DTE, R1 with clock rate and R3 with none...does this work with ANY cable?
R1 S1 to R3 S1, R1=DTE and R3=DCE, clock on R3...does this work with ANY cable?

Burt
t0mm0 (TechnicalUser)
19 Jan 08 6:58
No..It seems as though dtrtel believes there is a possible issue with R3, as bsludick has already proved the cabling to be good, plus the serial port came up briefly on R1.

As namesrhard2pick suggested earlier, it may be an idea to provide clocking from R3 > R1, as you may have a dodgey port as some of the guys have tried to outline..

Best of luck
bsludick (TechnicalUser)
19 Jan 08 9:53
burtsbees,

Don't worry so am I...

R1 S1 to R3 S1, R1=DCE and R3=DTE, R1 with clock rate and R3 with none...does not work with any cable.
R1 S1 to R3 S1, R1=DTE and R3=DCE, clock on R3...have not tried this yet, will do so this evening and let you know.

Thanks
burtsbees (Programmer)
19 Jan 08 10:05
Cool---just wanted to clarify for dtrtel...
"STOP! You just proved that R1(s1) is good."
No---you have probably proven the contrary to that, actually. Okay---please get back when you do try the second one! Also, here's a frame-relay config, if you decide to also try that...

!
version 11.3
service telnet-zeroidle
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Frame_Switch
!
enable password xxxxxx
!
frame-relay switching
!
!
interface Ethernet0
 ip address 172.16.0.2 255.255.0.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 clockrate 4000000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 101 interface Serial1 102
!
interface Serial1
 no ip address
 encapsulation frame-relay
 clockrate 4000000
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0 101
!
interface BRI0
 no ip address
 shutdown
!
ip classless
!
!
line con 0
 password xxxxxxxx
 logging synchronous
 login
line aux 0
line vty 0 4
 password xxxxxxxx
 login
!
end

Serial 0 goes to dlci 101, and serial 1 goes to dlci 102...

Burt



dtrtel (TechnicalUser)
19 Jan 08 11:38
<quote>
Now I'M confused!
R1 S1 to R3 S1, R1=DCE and R3=DTE, R1 with clock rate and R3 with none...does this work with ANY cable?
R1 S1 to R3 S1, R1=DTE and R3=DCE, clock on R3...does this work with ANY cable?
</quote>

Good points, Burt. I was partially premature in stating that R1(s1) is good because I did not indicate conditionally that the DCE role hadn't changed for R1(s1) when it came up on R2(s0). But if R1(s1) was configed and connected as the DCE then, I stand by this conclusion.

--jeff
http://linkedin.com/in/JeffLynch

namesrhard2pick (TechnicalUser)
19 Jan 08 17:05
Could it be a layer 2 issue since the protocol status is down? I noticed when looking more closely at the running configs for r1 and r3, the statements "no ip route-cache"
"no ip mroute-cache" are missing from r1 s1. These two statements are on the r3 s1 interface. If I am totally off, an explanation of these statements will be great.
jneiberger (TechnicalUser)
19 Jan 08 17:09
This has nothing to do with route caching (fast switching), which is what those statements affect. Do a web search for Cisco fast switching to read more about that topic. The short version of the story is that it lessens the load on the router by caching previous routing decisions so the routing portion of the router doesn't have to work so hard.
UCAtech (TechnicalUser)
19 Jan 08 17:43
can you post a sho int again (after you had cleared them)?   the 106 & 88 carrier transitions from the previous one sounds a lot like physical issue...
t0mm0 (TechnicalUser)
20 Jan 08 8:47
burtsbees your config would be good in the real world, but in a lab enviroment, would it work?

As the DLCI's are usually set up via the service providers & the LMI's on bsludick routers, would have been defaulted to cisco.

What dya reckon?
burtsbees (Programmer)
20 Jan 08 9:35
Well, I reckon that it works here at home...I have a 2620XM and a 2620 connected to my 2503 here that way. Perhaps you meant that it would work in a lab environment, but not sure in the real world?

Burt
t0mm0 (TechnicalUser)
21 Jan 08 9:06
ok..I take a step back.. ;o)
bsludick (TechnicalUser)
22 Jan 08 17:35
Hi Guys,

Tried putting the clocking on Router 3, serial 1 interface instead of Router 1 and no joy. Seeing up down on Serial 1 interface of router 3 now. I have switched the cables back to the way they were and still getting same up down on serial 1, router 1.

The routers are 2500's and are linked via dce dte serial crossover cables in a triangle with router 1 at the top.

All the other links work fine ....it is just the link between router 1 and router 3. The physicial interface must be fine as when I plug the serial cable from the serial0 interface into the Serial1 interface it comes up up!!

Any other suggestions, could it be that the 2500 routers do not like the way I setup my lab?

Thanks


jneiberger (TechnicalUser)
22 Jan 08 17:39
It's not possible that they just don't like the setup.  smile  You either have a flaky cable, a flaky interface or a bad configuration. This is a very straightforward and common lab configuration. It's not complex and you seem to have it configured properly. If you see that one side is up/up, that indicates that that router is receiving layer two keepalives from the other side. However, the side that is up/down is not receiving layer two information. That is an indication that you physical have electrical connectivity on the requisite pins to get a physical "up" status, but you do not have proper connectivity on the data pins.

burtsbees (Programmer)
22 Jan 08 18:56
Wait...so it does not like s1 R3 to s1 R1, but it likes s1 R3 to s10 R1? That's it...post all three configs!

Burt
bsludick (TechnicalUser)
27 Jan 08 8:45
Apologies not getting this posted sooner but here are all there configs, I did a sh ip int brief as well on each router.
----------------------------
Router1
**********************
Router1#
Router1#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
BRI0                   unassigned      YES NVRAM  administratively down down
BRI0:1                 unassigned      YES unset  administratively down down
BRI0:2                 unassigned      YES unset  administratively down down
Ethernet0              192.168.0.20    YES NVRAM  up                    up
Loopback0              10.1.10.2       YES NVRAM  up                    up
Serial0                10.1.1.2        YES NVRAM  up                    up
Serial1                10.1.2.2        YES NVRAM  up                    down
Router1#
Router1#
Router1#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
enable password cisco
!
ip subnet-zero
ip dhcp excluded-address 192.168.0.1 192.168.0.101
!
ip dhcp pool lab
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 192.168.0.1
   lease infinite
!
!
!
!
interface Loopback0
 ip address 10.1.10.2 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 192.168.0.20 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 description serial link to router 2
 ip address 10.1.1.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 56000
!
interface Serial1
 description Link to Router 3
 ip address 10.1.2.2 255.255.255.0
 no ip directed-broadcast
 no fair-queue
 clockrate 56000
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
!
banner motd ^C Welcome to the Cisco test lab - router1 ^C
!
line con 0
 password cisco
 login
 transport input none
line aux 0
 password cisco
 login
line vty 0 1
 password cisco
 login
line vty 2 4
 login
!
end

Router1#
************************

Router 2

Router2#
Router2#sh ip int brief
Interface                  IP-Address      OK? Method Status                Prot
ocol
BRI0                       unassigned      YES NVRAM  administratively down down

BRI0:1                     unassigned      YES unset  administratively down down

BRI0:2                     unassigned      YES unset  administratively down down

Ethernet0                  192.168.0.21    YES NVRAM  up                    down

Loopback0                  10.1.10.3       YES NVRAM  up                    up

Serial0                    10.1.1.3        YES NVRAM  up                    up

Serial1                    10.1.3.2        YES NVRAM  up                    up

Router2#
Router2#
Router2#sh run
Building configuration...

Current configuration : 687 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router2
!
enable password cisco
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.10.3 255.255.255.0
!
interface Ethernet0
 ip address 192.168.0.21 255.255.255.0
!
interface Serial0
 description serial link to router 1
 ip address 10.1.1.3 255.255.255.0
 no fair-queue
!
interface Serial1
 description Serial Link to Router 3
 ip address 10.1.3.2 255.255.255.0
 clockrate 56000
!
interface BRI0
 no ip address
 shutdown
!
ip classless
ip http server
!
!
!
line con 0
 password cisco
 login
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router2#
*********************************
Router 3

router3#
router3#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0              192.168.0.22    YES NVRAM  up                    up
Serial0                10.1.3.3        YES NVRAM  up                    up
Serial1                10.1.2.3        YES NVRAM  up                    up
router3#
router3#
router3#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router3
!
enable secret 5 $1$VtbO$CsNywhxYwKoJGQ7OT8oc2/
enable password copper01
!
ip subnet-zero
no ip routing
!
!
!
interface Ethernet0
 ip address 192.168.0.22 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 description serial link to Router 2
 ip address 10.1.3.3 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Serial1
 description Serial link to Router 1
 ip address 10.1.2.3 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
ip classless
!
!
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

router3#
***************************************
bsludick (TechnicalUser)
27 Jan 08 8:48
Hi Burtsbees,

As you say this should be pretty straight forward but for some reason I seem to be messing this up. I have posted the three configs, let me know what you think.
burtsbees (Programmer)
27 Jan 08 9:31
Right away I see that the queueing does not match on R1 S1 with the queueing on R3 S1, which is the link you had trouble with in the first place. You have no WFQ on R1 S1 probably fifo), but WQF is enabled on R3 S1...that's the only thing I see from the configs.
Without having to weed through all this, tell me what you've had problems with, and what you've done. I see you tried swapping the cable, and it came up/up, but then it all gets hairy...did it stay that way?
I would take a working cable (up/up on both sides), and plug the DCE end into R3 S1, and DTE end R1 S1, make them both fifo (on R3 S1, no fair-queue), clock the DCE end (R3 S1) and tell us what happens, and for how long. Also, look at the connections on the interfaces you put the supposed "bad" cable on. Let's start over...

Burt
burtsbees (Programmer)
27 Jan 08 9:33
Actually, the better thing to do as to not convolute everything is to just connect R1 and R3---leave the third router out of the picture COMPLETELY until the problem is resolved.

Burt
bsludick (TechnicalUser)
28 Jan 08 11:38
burtsbees,
I have disconnect the router2 so it is just Router1 and Router3 and still getting same error.


Router1#
Router1#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
BRI0                   unassigned      YES NVRAM  administratively down down
BRI0:1                 unassigned      YES unset  administratively down down
BRI0:2                 unassigned      YES unset  administratively down down
Ethernet0              192.168.0.20    YES NVRAM  up                    up
Loopback0              10.1.10.2       YES NVRAM  up                    up
Serial0                10.1.1.2        YES NVRAM  down                  down
Serial1                10.1.2.2        YES NVRAM  up                    down
Router1#
Serial1 is up, line protocol is down
  Hardware is HD64570
  Description: Link to Router 3
  Internet address is 10.1.2.2/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input never, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     37 packets output, 1670 bytes, 0 underruns
     0 output errors, 0 collisions, 14 interface resets
     0 output buffer failures, 0 output buffers swapped out
     38 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Router1#
---------
router 3
---------
router3#
router3#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0              192.168.0.22    YES NVRAM  up                    up
Serial0                10.1.3.3        YES NVRAM  down                  down
Serial1                10.1.2.3        YES NVRAM  up                    up
router3#

router3#sh int serial1
Serial1 is up, line protocol is up
  Hardware is HD64570
  Description: Serial link to Router 1
  Internet address is 10.1.2.3/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input 00:00:04, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/3/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     31 packets input, 1538 bytes, 0 no buffer
     Received 31 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     62 packets output, 9200 bytes, 0 underruns
     0 output errors, 0 collisions, 16 interface resets
     0 output buffer failures, 0 output buffers swapped out
     28 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
router3#
jneiberger (TechnicalUser)
28 Jan 08 11:52
I will say it again: this is a physical problem! You either have bad cables or you have a bad interface. You can see that one interface has bidirectional traffic but the other interface is not receiving any traffic. That's a sure sign of a bad cable or a bad interface.
bsludick (TechnicalUser)
28 Jan 08 18:01
jneiberger,

Been down this road before...
I have switch router2 back on and plugged router2's cable into the 'bad interface' and the interface comes!
Router1#
Router1#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
BRI0                   unassigned      YES NVRAM  administratively down down
BRI0:1                 unassigned      YES unset  administratively down down
BRI0:2                 unassigned      YES unset  administratively down down
Ethernet0              192.168.0.20    YES NVRAM  up                    up
Loopback0              10.1.10.2       YES NVRAM  up                    up
Serial0                10.1.1.2        YES NVRAM  down                  down
Serial1                10.1.2.2        YES NVRAM  up                    up
Router1#
So it cannot be the interface then can it?

I know the link between router 1 and router 2 is working so taken the cable from there and the results below....still up down!
Router1#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
BRI0                   unassigned      YES NVRAM  administratively down down
BRI0:1                 unassigned      YES unset  administratively down down
BRI0:2                 unassigned      YES unset  administratively down down
Ethernet0              192.168.0.20    YES NVRAM  up                    up
Loopback0              10.1.10.2       YES NVRAM  up                    up
Serial0                10.1.1.2        YES NVRAM  down                  down
Serial1                10.1.2.2        YES NVRAM  up                    down
So I am fairly confident it is not the cable either....
anythingelse I need to check.
jneiberger (TechnicalUser)
28 Jan 08 18:02
So, r2 comes up with no problem when connected to the problematic interfaces on r1 or r3? Using the same cables?
bsludick (TechnicalUser)
28 Jan 08 18:06
Hi Burtsbees

The only difference between the Router1 and Router3 configs was the queueing:

Router3
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
 Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Router1
  Last clearing of "show interface" counters 01:43:32
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops

This wouldn't have anything to do with the up down situation at the moment?

jneiberger (TechnicalUser)
28 Jan 08 18:09
Queueing will have no bearing on the status of your layer two connection. The problem, as seen in the output you posted, is that when r1 and r3 are connected, r1 sees no layer two frames whatsoever, even though r3 is sending them. That is not a configuration issue. If r1 is not seeing the layer two keepalives from r3, it will leave the status as up/down. It will not bring the layer two status to UP unless it starts seeing valid keepalives.
burtsbees (Programmer)
28 Jan 08 19:14
"I have switch router2 back on and plugged router2's cable into the 'bad interface' and the interface comes!"
Good cable...

"I know the link between router 1 and router 2 is working so taken the cable from there and the results below....still up down!"
Bad cable.

Burt
bsludick (TechnicalUser)
29 Jan 08 4:27
jneiberger,
That's correct the same cable.
Are there any commands that I can use to check that Router3 is actually sending keepalives on that interface? The link between router2 and router3 is fine so I would have thought so.
jneiberger (TechnicalUser)
29 Jan 08 12:35
You can see from the "show interface" output that keepalives are sent every 10 seconds. You could turn on serial interface debugging if you feel like it, but it's really not necessary. R1 isn't receiving any frames at all from R3, so there's no point in turning on debugging. There's nothing to debug.

This is almost certainly a physical problem somewhere. Just for grins, have you tried changing the layer two protocol? Set both sides to frame relay or PPP and see if the behavior changes. It shouldn't make a difference, but it's something you can try if you feel sure that your cables and interfaces are good.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close