INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

FormScape is corrupting the Internet Headers when sending at attachmen

FormScape is corrupting the Internet Headers when sending at attachmen

(OP)
FormScape is corrupting the Internet Headers when sending at attachment using send mail


When an attachment is sent from FormScape using send mail it corrupts the internet headers:

Microsoft Mail Internet Headers Version 2.0
Received: from THG ([10.0.254.60]) by mailgate.tsphere.co.uk with Microsoft SMTPSVC(5.0.2195.6713);
     Fri, 14 Dec 2007 10:50:33 +0000
From:fs@tsphere.co.uk
To:x@tsphere.co.uk
Subject:=?iso-8859-1?B?VGVzdA==?=
Date: Fri, 14 Dec 2007 10:50:32 +0000
MIME-Version:1.0
Content-Type:multipart/mixed;
    boundary="---- =_NEXTPART_FORMSCAPE_MAIL_message071214105032"
Return-Path: fs@tsphere.co.uk
Message-ID: <GULMOURuT1FM1JOMyQl00001297@mailgate.tsphere.co.uk>
X-OriginalArrivalTime: 14 Dec 2007 10:50:33.0714 (UTC) FILETIME=[26EF5520:01C83E3F]

------ =_NEXTPART_FORMSCAPE_MAIL_message071214105032
Content-Type: text/plain; charset=us-ascii

------ =_NEXTPART_FORMSCAPE_MAIL_message071214105032
Content-Type: text/plain;
    name="=?iso-8859-1?B?ZG9jNC50eHQ=?="
Content-Transfer-Encoding: quoted-printable
Content-Disposition: attachment;
    filename="=?iso-8859-1?B?ZG9jNC50eHQ=?="


------ =_NEXTPART_FORMSCAPE_MAIL_message071214105032--

However, when the exact email is sent without the attachment it works correctly:

Microsoft Mail Internet Headers Version 2.0
Received: from THG ([10.0.254.60]) by mailgate.tsphere.co.uk with Microsoft SMTPSVC(5.0.2195.6713);
     Fri, 14 Dec 2007 10:51:43 +0000
From: <fs@tsphere.co.uk>
To: <x@tsphere.co.uk>
Subject: Test
Date: Fri, 14 Dec 2007 10:51:42 +0000
MIME-Version:1.0
Content-Type: text/plain; charset=us-ascii
Return-Path: fs@tsphere.co.uk
Message-ID: <GILMOURmLFQG101s7hp00001298@mailgate.travelsphere.co.uk>
X-OriginalArrivalTime: 14 Dec 2007 10:51:43.0717 (UTC) FILETIME=[50A8F150:01C83E3F]
I have tried different encoding but to no avail. The same email including the attachment has been sent using VB.NET and the internet headers were ok. This was to rule out Exchange as the problem

Any help resolving this issue would be greatly appreciated.

Thanks



Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close